summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-04-29 18:55:44 +0000
committerVlastimil Babka <caster@gentoo.org>2009-04-29 18:55:44 +0000
commit8a79380b7d6371ec48038ad2a3a95e651b7bd505 (patch)
tree02268cdbca7085283edbc98c12a7e49f1efec7d7 /x11-misc
parentamd64 stable, bug #261166 (diff)
downloadgentoo-2-8a79380b7d6371ec48038ad2a3a95e651b7bd505.tar.gz
gentoo-2-8a79380b7d6371ec48038ad2a3a95e651b7bd505.tar.bz2
gentoo-2-8a79380b7d6371ec48038ad2a3a95e651b7bd505.zip
Version bump, bug #267814. Use QA_TEXTRELS to suppres warnings, bug #265171.
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/googleearth/ChangeLog9
-rw-r--r--x11-misc/googleearth/googleearth-5.0.11729.1014.ebuild93
2 files changed, 101 insertions, 1 deletions
diff --git a/x11-misc/googleearth/ChangeLog b/x11-misc/googleearth/ChangeLog
index 42f2ce21db9a..cce0ad6a11f0 100644
--- a/x11-misc/googleearth/ChangeLog
+++ b/x11-misc/googleearth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/googleearth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.42 2009/02/08 14:36:06 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.43 2009/04/29 18:55:44 caster Exp $
+
+*googleearth-5.0.11729.1014 (29 Apr 2009)
+
+ 29 Apr 2009; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.0.11729.1014.ebuild:
+ Version bump, bug #267814. Use QA_TEXTRELS to suppres warnings, bug
+ #265171.
*googleearth-5.0.11337.1968_beta (08 Feb 2009)
diff --git a/x11-misc/googleearth/googleearth-5.0.11729.1014.ebuild b/x11-misc/googleearth/googleearth-5.0.11729.1014.ebuild
new file mode 100644
index 000000000000..93d6956d9260
--- /dev/null
+++ b/x11-misc/googleearth/googleearth-5.0.11729.1014.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-5.0.11729.1014.ebuild,v 1.1 2009/04/29 18:55:44 caster Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bump and a need for version bump
+SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin
+ -> GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE=""
+
+RDEPEND="x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrender )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ <x11-drivers/ati-drivers-8.28.8 ) )
+ media-fonts/ttf-bitstream-vera"
+
+S="${WORKDIR}"
+
+QA_TEXTRELS="opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/libevll.so
+opt/googleearth/librender.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libflightsim.so
+opt/googleearth/libcollada.so
+opt/googleearth/libminizip.so
+opt/googleearth/libauth.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libmeasure.so"
+
+src_unpack() {
+ unpack_makeself
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" postinstall.sh
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml
+ domenu Google-${PN}.desktop
+ doicon ${PN}-icon.png
+ dodoc README.linux
+
+ cd bin
+ tar xf "${WORKDIR}"/${PN}-linux-x86.tar
+ exeinto /opt/${PN}
+ doexe *
+
+ cd "${D}"/opt/${PN}
+ tar xf "${WORKDIR}"/${PN}-data.tar
+
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/{xml,resources}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}