summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-02-23 15:17:56 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-02-23 15:17:56 +0000
commitb01888b0bba58cdaa7f11be7d06f39e85fbbf534 (patch)
tree6c1ff21725c713685bff2f12e4360c30d5e1e60c /x11-misc/slim
parentUSE="static-libs" and punt useless libtool archive in favour of pkg-config file. (diff)
downloadgentoo-2-b01888b0bba58cdaa7f11be7d06f39e85fbbf534.tar.gz
gentoo-2-b01888b0bba58cdaa7f11be7d06f39e85fbbf534.tar.bz2
gentoo-2-b01888b0bba58cdaa7f11be7d06f39e85fbbf534.zip
Version bump, cleaned up old ebuilds. No major changes to 1.3.3 compared to 1.3.2-r7
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'x11-misc/slim')
-rw-r--r--x11-misc/slim/ChangeLog9
-rw-r--r--x11-misc/slim/files/Xsession160
-rw-r--r--x11-misc/slim/files/slim-1.3.3-config.diff74
-rw-r--r--x11-misc/slim/slim-1.3.3.ebuild (renamed from x11-misc/slim/slim-1.3.2-r3.ebuild)73
4 files changed, 112 insertions, 204 deletions
diff --git a/x11-misc/slim/ChangeLog b/x11-misc/slim/ChangeLog
index 94d7ac56af3b..4651bec45286 100644
--- a/x11-misc/slim/ChangeLog
+++ b/x11-misc/slim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/slim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.79 2012/02/01 09:24:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.80 2012/02/23 15:17:56 axs Exp $
+
+*slim-1.3.3 (23 Feb 2012)
+
+ 23 Feb 2012; Ian Stakenvicius <axs@gentoo.org> -slim-1.3.2-r3.ebuild,
+ +slim-1.3.3.ebuild, +files/slim-1.3.3-config.diff, -files/Xsession:
+ Version bump, cleaned up old ebuilds. No major changes to 1.3.3 compared to
+ 1.3.2-r7
01 Feb 2012; Samuli Suominen <ssuominen@gentoo.org> slim-1.3.2-r7.ebuild:
ppc/ppc64 stable wrt #401135
diff --git a/x11-misc/slim/files/Xsession b/x11-misc/slim/files/Xsession
deleted file mode 100644
index d24ee1c03011..000000000000
--- a/x11-misc/slim/files/Xsession
+++ /dev/null
@@ -1,160 +0,0 @@
-#!/bin/sh
-#
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/files/Xsession,v 1.1 2010/09/20 15:22:38 darkside Exp $
-#
-# SLiM Xsession script
-#
-# This script is a wrapper that handles selection of a session from
-# /etc/X11/Sessions/ as necessary. It doesn't handle actual session setup.
-#
-# The script takes a session name as the first argument. If no argument is
-# given, or if the argument does not match an available session script:
-# - Run ~/.xsession and if that's not available,
-# - Run the appropriate Xclients startup (see the code below)
-#
-# (Note that other arguments could also follow, but only the command one is
-# right now relevant and supported)
-#
-# The output is redirected to /var/log/slim.log.
-#
-# By default this is run in a login shell, see /etc/slim.conf for details.
-
-command="$@"
-
-# this will go into the slim.log along with all other echo's
-# good for debugging where things went wrong
-echo "$0: Beginning session setup..."
-
-# Read /etc/xprofile and .xprofile for X specific setup
-test -f /etc/xprofile && . /etc/xprofile
-test -f "$HOME/.xprofile" && . "$HOME/.xprofile"
-
-# userresources and sysresources and all these other vars are
-# unneeded here as by default the session script we're handing
-# off to will take care of it.
-
-# wrap possible arguments to determine whether to treat special or not
-if [ "x$command" = "xcustom" ] || [ "x$command" = "xCustom" ] || \
- [ "x$command" = "xdefault" ] || [ "x$command" = "xDefault" ]; then
- command="Xsession"
-fi
-if [ "x$command" = "x" ]; then
- # no default specified, check if Xsession will complete
- # and if not then assign XSESSION to command
- if [ -x "$HOME/.xsession" ] || [ -x "$HOME/.Xclients" ] || \
- [ -x /etc/X11/xinit/Xclients ] || [ -x /etc/X11/Xclients ]; then
- command="Xsession"
- else
- command=$XSESSION
- fi
-fi
-
-# ripped directly from /etc/X11/chooser.sh
-
-sessionscript=""
-for x in /etc/X11/Sessions/* ; do
- if [ "`echo ${x##*/} | awk '{ print toupper($1) }'`" \
- = "`echo ${command} | awk '{ print toupper($1) }'`" ]; then
- # Found the matching session
- sessionscript="${x}"
- break
- fi
-done
-
-if [ -n "$sessionscript" ]; then
-
- if [ -f ${sessionscript} ]; then
- if [ -x ${sessionscript} ]; then
- exec "${sessionscript}"
- else
- exec /bin/sh "${sessionscript}"
- fi
- fi
-
- echo "Unable to execute session script ${sessionscript}"
- exit 1
-
-fi
-
-# Launch a default session
-# This was mostly ripped from GDM's Xsession script
-
-
-echo "Could not find appropriate session script, exec'ing xterm"
-
-userresources="$HOME/.Xresources"
-usermodmap="$HOME/.Xmodmap"
-userxkbmap="$HOME/.Xkbmap"
-
-sysresources=/etc/X11/Xresources
-sysmodmap=/etc/X11/Xmodmap
-sysxkbmap=/etc/X11/Xkbmap
-
-rh6sysresources=/etc/X11/xinit/Xresources
-rh6sysmodmap=/etc/X11/xinit/Xmodmap
-
-# merge in defaults
-if [ -f "$rh6sysresources" ]; then
- xrdb -merge "$rh6sysresources"
-fi
-
-if [ -f "$sysresources" ]; then
- xrdb -merge "$sysresources"
-fi
-
-if [ -f "$userresources" ]; then
- xrdb -merge "$userresources"
-fi
-
-# merge in keymaps
-if [ -f "$sysxkbmap" ]; then
- setxkbmap `cat "$sysxkbmap"`
- XKB_IN_USE=yes
-fi
-
-if [ -f "$userxkbmap" ]; then
- setxkbmap `cat "$userxkbmap"`
- XKB_IN_USE=yes
-fi
-
-#
-# Eeek, this seems like too much magic here
-#
-if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
- if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
- xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
- if [ -n "$xkbsymbols" ]; then
- setxkbmap -symbols "$xkbsymbols"
- XKB_IN_USE=yes
- fi
- fi
-fi
-
-# xkb and xmodmap don't play nice together
-if [ -z "$XKB_IN_USE" ]; then
- if [ -f "$rh6sysmodmap" ]; then
- xmodmap "$rh6sysmodmap"
- fi
-
- if [ -f "$sysmodmap" ]; then
- xmodmap "$sysmodmap"
- fi
-
- if [ -f "$usermodmap" ]; then
- xmodmap "$usermodmap"
- fi
-fi
-
-unset XKB_IN_USE
-
-# run all system xinitrc shell scripts.
-if [ -d /etc/X11/xinit/xinitrc.d ]; then
- for i in /etc/X11/xinit/xinitrc.d/* ; do
- if [ -x "$i" ]; then
- . "$i"
- fi
- done
-fi
-
-exec xterm -geometry 80x24+0+0
-
diff --git a/x11-misc/slim/files/slim-1.3.3-config.diff b/x11-misc/slim/files/slim-1.3.3-config.diff
new file mode 100644
index 000000000000..533b3ac4ac42
--- /dev/null
+++ b/x11-misc/slim/files/slim-1.3.3-config.diff
@@ -0,0 +1,74 @@
+--- slim.conf.orig 2010-08-25 11:52:23.000000000 -0400
++++ slim.conf 2010-08-25 11:58:58.000000000 -0400
+@@ -2,7 +2,7 @@
+ # Note: -xauth $authfile is automatically appended
+ default_path /bin:/usr/bin:/usr/local/bin
+ default_xserver /usr/bin/X
+-#xserver_arguments -dpi 75
++xserver_arguments -nolisten tcp -br -deferglyphs 16
+
+ # Commands for halt, login, etc.
+ halt_cmd /sbin/shutdown -h now
+@@ -18,7 +18,7 @@
+
+
+ # Activate numlock when slim starts. Valid values: on|off
+-# numlock on
++numlock on
+
+ # Hide the mouse cursor (note: does not work with some WMs).
+ # Valid values: true|false
+@@ -33,7 +33,8 @@
+ # to adjust the command according to your preferred shell,
+ # i.e. for freebsd use:
+ # login_cmd exec /bin/sh - ~/.xinitrc %session
+-login_cmd exec /bin/bash -login ~/.xinitrc %session
++# login_cmd exec /bin/bash -login ~/.xinitrc %session
++login_cmd exec /bin/bash -login /usr/share/slim/Xsession %session
+
+ # Commands executed when starting and exiting a session.
+ # They can be used for registering a X11 session with
+@@ -41,20 +42,27 @@
+ #
+ # sessionstart_cmd some command
+ # sessionstop_cmd some command
++sessionstart_cmd /usr/bin/sessreg -a -l :0.0 %user
++sessionstop_cmd /usr/bin/sessreg -d -l :0.0 %user
+
+ # Start in daemon mode. Valid values: yes | no
+ # Note that this can be overriden by the command line
+ # options "-d" and "-nodaemon"
+-# daemon yes
++daemon yes
+
+-# Available sessions (first one is the default).
+-# The current chosen session name is replaced in the login_cmd
++# Available sessions:
++# The current chosen session name replaces %session in the login_cmd
+ # above, so your login command can handle different sessions.
++# If no session is chosen (via F1), %session will be an empty string.
+ # see the xinitrc.sample file shipped with slim sources
+-sessions xfce4,icewm-session,wmaker,blackbox
++#sessions xfce4,icewm-session,wmaker,blackbox
++# Alternatively, read available sessions from a directory:
++sessiondir /etc/X11/Sessions
+
+-# Executed when pressing F11 (requires imagemagick)
++# Executed when pressing F11 (requires media-gfx/imagemagick for import)
++# Alternative is media-gfx/scrot. See Gentoo bug 252241 for more info.
+ screenshot_cmd import -window root /slim.png
++#screenshot_cmd scrot /root/slim.png
+
+ # welcome message. Available variables: %host, %domain
+ welcome_msg Welcome to %host
+@@ -83,8 +88,8 @@
+ # randomly choose from
+ current_theme default
+
+-# Lock file
+-lockfile /var/run/slim.lock
++# Lock file, /etc/init.d/xdm expects slim.pid
++lockfile /var/run/slim.pid
+
+ # Log file
+ logfile /var/log/slim.log
diff --git a/x11-misc/slim/slim-1.3.2-r3.ebuild b/x11-misc/slim/slim-1.3.3.ebuild
index 85542081e707..05cc8891fcc7 100644
--- a/x11-misc/slim/slim-1.3.2-r3.ebuild
+++ b/x11-misc/slim/slim-1.3.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.2-r3.ebuild,v 1.7 2011/08/09 17:38:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.3.ebuild,v 1.1 2012/02/23 15:17:56 axs Exp $
-EAPI=2
+EAPI=4
-inherit toolchain-funcs pam eutils
+inherit cmake-utils pam eutils
DESCRIPTION="Simple Login Manager"
HOMEPAGE="http://slim.berlios.de"
@@ -12,16 +12,19 @@ SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="branding pam"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="branding pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
RDEPEND="x11-libs/libXmu
x11-libs/libX11
x11-libs/libXpm
x11-libs/libXft
- >=media-libs/libpng-1.4
+ media-libs/libpng
virtual/jpeg
x11-apps/sessreg
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
pam? ( virtual/pam )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -29,64 +32,43 @@ DEPEND="${RDEPEND}
PDEPEND="branding? ( >=x11-themes/slim-themes-1.2.3a-r3 )"
src_prepare() {
- # respect C[XX]FLAGS, fix crosscompile,
- # fix linking order for --as-needed"
- sed -i -e "s:^CXX=.*:CXX=$(tc-getCXX) ${CXXFLAGS}:" \
- -e "s:^CC=.*:CC=$(tc-getCC) ${CFLAGS}:" \
- -e "s:^MANDIR=.*:MANDIR=/usr/share/man:" \
- -e "s:^\t\(.*\)\ \$(LDFLAGS)\ \(.*\):\t\1\ \2\ \$(LDFLAGS):g" \
- -e "s:-I/usr/include/libpng12:$(pkg-config --cflags-only-I libpng):" \
- -e "s:-lpng12:$(pkg-config --libs-only-l libpng):" \
- -r -e "s:^LDFLAGS=(.*):LDFLAGS=\1 ${LDFLAGS}:" \
- Makefile || die "sed failed in Makefile"
# Our Gentoo-specific config changes
- epatch "${FILESDIR}"/${PN}-1.3.2-r2-config.diff
+ epatch "${FILESDIR}"/${P}-config.diff
if use elibc_FreeBSD; then
- sed -i -e "s/CUSTOM=-DHAVE_SHADOW/CUSTOM=-DNEEDS_BASENAME/" Makefile \
- || die "sed failed in Makefile"
- epatch "${FILESDIR}"/${PN}-1.3.2-bsd-install.patch
+ sed -i -e 's/"-DHAVE_SHADOW"/"-DNEEDS_BASENAME"/' CMakeLists.txt \
+ || die
fi
if use branding; then
sed -i -e 's/ default/ slim-gentoo-simple/' slim.conf || die
fi
- # Gentoo bug 297655
- epatch "${FILESDIR}"/14509-fix-keyboard-in-tty-from-which-${PN}-is-lauched.patch
- # Upstream bug #15287
+ # Upstream bug #15287 (still not fixed in codebase)
epatch "${FILESDIR}"/15287-fix-pam-authentication-with-pam_unix2.patch
- # Gentoo Bug 261713
- epatch "${FILESDIR}"/261713-restart-xserver-if-killed.patch
- # Gentoo bug 261359, upstream 15326
- epatch "${FILESDIR}"/261359-fix-SIGTERM-freeze.patch
- # Gentoo bug 346037
- epatch "${FILESDIR}"/346037-stop_setting_host_for_pam_ck_connector_so.patch
- # Gentoo bug 378505
- epatch "${FILESDIR}"/${P}-libpng15.patch
}
-src_compile() {
- if use pam ; then
- emake USE_PAM=1 || die "emake failed."
- else
- emake || die "emake failed."
- fi
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use pam USE_PAM)
+ $(cmake-utils_use consolekit USE_CONSOLEKIT)
+ )
+
+ cmake-utils_src_configure
}
src_install() {
+ cmake-utils_src_install
+
if use pam ; then
- emake USE_PAM=1 DESTDIR="${D}" install || die "emake install failed."
pamd_mimic system-local-login slim auth account session
- else
- emake DESTDIR="${D}" install || die "emake install failed."
fi
insinto /usr/share/slim
- newins "${FILESDIR}/Xsession" Xsession || die "newins failed"
+ newins "${FILESDIR}/Xsession-r3" Xsession
insinto /etc/logrotate.d
- newins "${FILESDIR}/slim.logrotate" slim || die "newins failed"
+ newins "${FILESDIR}/slim.logrotate" slim
dodoc xinitrc.sample ChangeLog README TODO THEMES
}
@@ -110,9 +92,14 @@ pkg_postinst() {
elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
elog "accordingly."
elog
+ ewarn "Please note that slim now supports consolekit directly. Please remove any "
+ ewarn "existing work-arounds (including all calls to 'ck-launch-session' in "
+ ewarn "xinitrc scripts) and enable USE=\"consolekit\""
+ elog
if ! use pam; then
elog "You have merged ${PN} without USE=pam, this will cause ${PN} to fall back to"
elog "the console when restarting your window manager. If this is not"
elog "desired, then please remerge ${PN} with USE=pam"
+ elog
fi
}