summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-12-17 21:57:27 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-12-17 21:57:27 +0000
commit656941a7944e730d7f5a139d5d2d616e93fd9285 (patch)
tree6dda7b7d73ee5d113c1e2c2e94a15a948fb20703 /x11-misc/devilspie2
parentUpdate live ebuild from mercurial to git (thanks Andreas Wiese, bug 447564) (diff)
downloadgentoo-2-656941a7944e730d7f5a139d5d2d616e93fd9285.tar.gz
gentoo-2-656941a7944e730d7f5a139d5d2d616e93fd9285.tar.bz2
gentoo-2-656941a7944e730d7f5a139d5d2d616e93fd9285.zip
version bump
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/ChangeLog7
-rw-r--r--x11-misc/devilspie2/devilspie2-0.27.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-misc/devilspie2/ChangeLog b/x11-misc/devilspie2/ChangeLog
index bf6963a44ad5..c5eea05cef39 100644
--- a/x11-misc/devilspie2/ChangeLog
+++ b/x11-misc/devilspie2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/devilspie2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.1 2012/11/27 23:51:43 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.2 2012/12/17 21:57:27 hasufell Exp $
+
+*devilspie2-0.27 (17 Dec 2012)
+
+ 17 Dec 2012; Julian Ospald <hasufell@gentoo.org> +devilspie2-0.27.ebuild:
+ version bump
*devilspie2-0.26 (27 Nov 2012)
diff --git a/x11-misc/devilspie2/devilspie2-0.27.ebuild b/x11-misc/devilspie2/devilspie2-0.27.ebuild
new file mode 100644
index 000000000000..2a2ee714860a
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.27.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/devilspie2-0.27.ebuild,v 1.1 2012/12/17 21:57:27 hasufell Exp $
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default folder for scripts is ~/.config/devilspie2/"
+}