summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-29 22:15:28 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-29 22:15:28 +0000
commit7f6a8ab2bfa2090cb04ffbd1652b0322373d9432 (patch)
tree87896af12ce948ea40f6fde2050bb8c6833d09c6 /x11-libs
parentVersion bump. (diff)
downloadgentoo-2-7f6a8ab2bfa2090cb04ffbd1652b0322373d9432.tar.gz
gentoo-2-7f6a8ab2bfa2090cb04ffbd1652b0322373d9432.tar.bz2
gentoo-2-7f6a8ab2bfa2090cb04ffbd1652b0322373d9432.zip
Version bump.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-script/ChangeLog7
-rw-r--r--x11-libs/qt-script/qt-script-4.8.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index f8b3f6dece4a..ed7ed375baf4 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.104 2012/03/27 18:55:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.105 2012/03/29 22:15:28 pesa Exp $
+
+*qt-script-4.8.1 (29 Mar 2012)
+
+ 29 Mar 2012; Davide Pesavento <pesa@gentoo.org> +qt-script-4.8.1.ebuild:
+ Version bump.
27 Mar 2012; Johannes Huber <johu@gentoo.org>
-files/qt-script-4.6.2-alpha.patch:
diff --git a/x11-libs/qt-script/qt-script-4.8.1.ebuild b/x11-libs/qt-script/qt-script-4.8.1.ebuild
new file mode 100644
index 000000000000..95cada909b17
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.8.1.ebuild,v 1.1 2012/03/29 22:15:28 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv +jit"
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/script"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt
+ include/QtCore
+ include/QtScript
+ src/3rdparty/javascriptcore
+ src/corelib"
+
+ QCONFIG_ADD="script"
+ QCONFIG_DEFINE="QT_SCRIPT"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ $(qt_use iconv)
+ $(qt_use jit javascript-jit)
+ -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
+ -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
+ -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ # install private headers
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} +
+}