summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-03 17:25:13 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-03 17:25:13 +0000
commit0dcae30c88774ca0e28ce84c9b06f686f19d38c4 (patch)
treedc23d5270c236c8ed9bc795d9efc1ee2a65ec652 /x11-libs/xpa
parentVersion Bump, notified by euscan (diff)
downloadgentoo-2-0dcae30c88774ca0e28ce84c9b06f686f19d38c4.tar.gz
gentoo-2-0dcae30c88774ca0e28ce84c9b06f686f19d38c4.tar.bz2
gentoo-2-0dcae30c88774ca0e28ce84c9b06f686f19d38c4.zip
Version Bump, notified by euscan
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/xpa')
-rw-r--r--x11-libs/xpa/ChangeLog10
-rw-r--r--x11-libs/xpa/xpa-2.1.12.ebuild11
-rw-r--r--x11-libs/xpa/xpa-2.1.13.ebuild58
3 files changed, 73 insertions, 6 deletions
diff --git a/x11-libs/xpa/ChangeLog b/x11-libs/xpa/ChangeLog
index 7e708ab19010..da10b4bc6569 100644
--- a/x11-libs/xpa/ChangeLog
+++ b/x11-libs/xpa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xpa
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.7 2010/07/19 18:35:36 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.8 2011/05/03 17:25:13 jlec Exp $
+
+*xpa-2.1.13 (03 May 2011)
+
+ 03 May 2011; Justin Lecher <jlec@gentoo.org> xpa-2.1.12.ebuild,
+ +xpa-2.1.13.ebuild:
+ Version Bump, notified by euscan
19 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org> -xpa-2.1.10.ebuild,
metadata.xml:
diff --git a/x11-libs/xpa/xpa-2.1.12.ebuild b/x11-libs/xpa/xpa-2.1.12.ebuild
index ca592ad81cb5..bb759e777769 100644
--- a/x11-libs/xpa/xpa-2.1.12.ebuild
+++ b/x11-libs/xpa/xpa-2.1.12.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.12.ebuild,v 1.1 2010/01/31 21:33:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.12.ebuild,v 1.2 2011/05/03 17:25:13 jlec Exp $
EAPI=2
+
inherit eutils autotools
DESCRIPTION="Messaging system providing communication between programs"
-HOMEPAGE="http://hea-www.harvard.edu/RD/xpa"
+HOMEPAGE="http://hea-www.harvard.edu/RD/xpa/"
SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc"
-RDEPEND="dev-lang/tcl
+
+RDEPEND="
+ dev-lang/tcl
x11-libs/libXt
!<sci-astronomy/ds9-5.3"
DEPEND="${RDEPEND}"
diff --git a/x11-libs/xpa/xpa-2.1.13.ebuild b/x11-libs/xpa/xpa-2.1.13.ebuild
new file mode 100644
index 000000000000..148c667fe9df
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.13.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.13.ebuild,v 1.1 2011/05/03 17:25:13 jlec Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="http://hea-www.harvard.edu/RD/xpa/"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-lang/tcl
+ x11-libs/libXt
+ !<sci-astronomy/ds9-5.3"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/$(get_libdir)
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${D}"/usr/$(get_libdir)/libtclxpa* "${D}"/usr/$(get_libdir)/tclxpa/
+
+ dodoc README
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ insinto /usr/share/doc/${PF}/html
+ doins *.html || die
+ fi
+}