summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-03-14 12:03:06 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-03-14 12:03:06 +0000
commitf0cb181c3841360f7cfee0ef6fa35d00e1cd07b2 (patch)
treeb0c930e68491fc7c85b8b2610741a5127b18d3e9 /x11-libs/qwt
parentfix building in gcc4 (diff)
downloadgentoo-2-f0cb181c3841360f7cfee0ef6fa35d00e1cd07b2.tar.gz
gentoo-2-f0cb181c3841360f7cfee0ef6fa35d00e1cd07b2.tar.bz2
gentoo-2-f0cb181c3841360f7cfee0ef6fa35d00e1cd07b2.zip
Some changes to actually make it work right
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-libs/qwt')
-rw-r--r--x11-libs/qwt/ChangeLog5
-rw-r--r--x11-libs/qwt/qwt-5.0.1.ebuild41
2 files changed, 25 insertions, 21 deletions
diff --git a/x11-libs/qwt/ChangeLog b/x11-libs/qwt/ChangeLog
index d50827546896..9fd54413a82f 100644
--- a/x11-libs/qwt/ChangeLog
+++ b/x11-libs/qwt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qwt
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.40 2007/03/13 14:47:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.41 2007/03/14 12:03:06 caleb Exp $
+
+ 14 Mar 2007; Caleb Tennis <caleb@gentoo.org> qwt-5.0.1.ebuild:
+ Some changes to actually make it work right
13 Mar 2007; Raúl Porcel <armin76@gentoo.org> qwt-4.2.0-r1.ebuild:
x86 stable
diff --git a/x11-libs/qwt/qwt-5.0.1.ebuild b/x11-libs/qwt/qwt-5.0.1.ebuild
index b5bad151f74d..13fffcd03a9c 100644
--- a/x11-libs/qwt/qwt-5.0.1.ebuild
+++ b/x11-libs/qwt/qwt-5.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5.0.1.ebuild,v 1.1 2007/03/12 12:31:24 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5.0.1.ebuild,v 1.2 2007/03/14 12:03:06 caleb Exp $
inherit multilib eutils
@@ -21,14 +21,25 @@ src_unpack () {
unpack ${A}
cd ${S}
- find . -type f -name "*.pro" | while read file; do
- sed -e 's/.*no-exceptions.*//g' -i ${file}
- echo >> ${file} "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
- echo >> ${file} "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
- done
- find examples -type f -name "*.pro" | while read file; do
- echo >> ${file} "INCLUDEPATH += /usr/include/qwt"
- done
+
+ qwtconfig=${S}/"qwtconfig.pri"
+ echo > ${qwtconfig} ""
+ echo >> ${qwtconfig} "target.path = /usr/$(get_libdir)"
+ echo >> ${qwtconfig} "headers.path = /usr/include/qwt5"
+ echo >> ${qwtconfig} "doc.path = /usr/share/doc/${PF}"
+ echo >> ${qwtconfig}
+ echo >> ${qwtconfig} "CONFIG += qt warn_on thread"
+ echo >> ${qwtconfig} "CONFIG += release"
+ echo >> ${qwtconfig} "CONFIG += QwtDll QwtPlot QwtWidgets QwtDesigner"
+
+ # Can also do QwtExamples for example building
+
+ echo >> ${qwtconfig} "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
+ echo >> ${qwtconfig} "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
+
+ # They got the version wrong
+ sed -e "s/5.0.0/5.0.1/g" -i "${S}/src/src.pro"
+
}
src_compile () {
@@ -41,15 +52,5 @@ src_compile () {
}
src_install () {
- ls -l lib
- dolib lib/libqwt.so.${QWTVER}
- dosym libqwt.so.${QWTVER} /usr/$(get_libdir)/libqwt.so
- dosym libqwt.so.${QWTVER} /usr/$(get_libdir)/libqwt.so.${QWTVER/.*/}
- use doc && (dodir /usr/share/doc/${PF}
- cp -pPR examples ${D}/usr/share/doc/${PF}/
- dohtml doc/html/*)
- mkdir -p ${D}/usr/include/qwt5/
- install include/* ${D}/usr/include/qwt5/
- insinto /usr/$(get_libdir)/qt4/plugins/designer
- doins designer/plugins/designer/libqwt_designer_plugin.so
+ make INSTALL_ROOT=${D} install
}