summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-12 12:08:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-12 12:08:53 +0000
commite29f8c3eca46372e6a06ab700804c90ff7486d08 (patch)
tree24d31fa34c58858be69d0d2312bacd73ff98331a /x11-drivers/xf86-input-virtualbox
parentRemove old versions that have built_with_use calls. (diff)
downloadgentoo-2-e29f8c3eca46372e6a06ab700804c90ff7486d08.tar.gz
gentoo-2-e29f8c3eca46372e6a06ab700804c90ff7486d08.tar.bz2
gentoo-2-e29f8c3eca46372e6a06ab700804c90ff7486d08.zip
Remove old
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-virtualbox')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.1.4.ebuild91
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild96
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.2.ebuild96
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.4.ebuild96
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.2.ebuild105
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild105
7 files changed, 7 insertions, 590 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index 01fe0a717f42..2398e30fa5a6 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.16 2009/09/10 20:04:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.17 2009/09/12 12:08:53 patrick Exp $
+
+ 12 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ -xf86-input-virtualbox-2.1.4.ebuild, -xf86-input-virtualbox-2.2.0.ebuild,
+ -xf86-input-virtualbox-2.2.2.ebuild, -xf86-input-virtualbox-2.2.4.ebuild,
+ -xf86-input-virtualbox-3.0.2.ebuild, -xf86-input-virtualbox-3.0.4.ebuild:
+ Remove old
*xf86-input-virtualbox-3.0.6 (10 Sep 2009)
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.1.4.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.1.4.ebuild
deleted file mode 100644
index 47ed60446269..000000000000
--- a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.1.4.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.1.4.ebuild,v 1.1 2009/03/03 07:38:47 patrick Exp $
-
-EAPI=2
-
-inherit x-modular eutils
-
-MY_P=VirtualBox-${PV}-OSE
-DESCRIPTION="VirtualBox input driver"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="hal"
-
-RDEPEND="x11-base/xorg-server
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.5
- >=dev-lang/yasm-0.6.2
- sys-devel/dev86
- sys-power/iasl
- x11-proto/inputproto
- x11-proto/randrproto
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/-OSE/_OSE}
-
-src_prepare() {
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- rm -rf kBuild/bin tools
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
- # Fix an upstream typo in Config.kmk
- sed -i \
- -e "2511d" Config.kmk || die "Config.kmk sed failed"
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
- source ./env.sh
-}
-
-src_compile() {
- for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
- /src/VBox/Additions/x11/xmouse ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk failed"
- done
-}
-
-src_install() {
- cd "${S}/out/linux.${ARCH}/release/bin/additions"
- insinto /usr/lib/xorg/modules/input
-
- if has_version ">=x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_15.so vboxmouse_drv.so
- elif has_version ">=x11-base/xorg-server-1.4" \
- && has_version "<x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_14.so vboxmouse_drv.so
- else
- newins vboxmouse_drv_71.so vboxmouse_drv.so
- fi
-
- if use hal; then
- cd "${S}/src/VBox/Additions/linux/installer"
- insinto /usr/share/hal/fdi/information/20thirdparty
- doins 90-vboxguest.fdi
- fi
-}
-
-pkg_postinst() {
- elog "You need to edit the file /etc/X11/xorg.conf and set:"
- elog ""
- elog " Driver \"vboxmouse\""
- elog ""
- elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
- elog ""
-}
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild
deleted file mode 100644
index 3736136208c7..000000000000
--- a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild,v 1.2 2009/04/19 01:24:42 mr_bones_ Exp $
-
-EAPI=2
-
-inherit x-modular eutils
-
-MY_P=VirtualBox-${PV}-OSE
-DESCRIPTION="VirtualBox input driver"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="hal"
-
-RDEPEND="x11-base/xorg-server
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.5-r1
- >=dev-lang/yasm-0.6.2
- sys-devel/dev86
- sys-power/iasl
- x11-proto/inputproto
- x11-proto/randrproto
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/-OSE/_OSE}
-
-src_prepare() {
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- rm -rf kBuild/bin tools
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
- source ./env.sh
-}
-
-src_compile() {
- for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
- /src/VBox/Additions/x11/vboxmouse ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk failed"
- done
-}
-
-src_install() {
- cd "${S}/out/linux.${ARCH}/release/bin/additions"
- insinto /usr/lib/xorg/modules/input
-
- # xorg-server-1.6.x (currently on the official x11 overlay)
- if has_version ">=x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_16.so vboxmouse_drv.so
- # xorg-server-1.5.x
- elif has_version ">=x11-base/xorg-server-1.5" \
- && has_version "<x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_15.so vboxmouse_drv.so
- # xorg-server-1.4.x
- elif has_version ">=x11-base/xorg-server-1.4" \
- && has_version "<x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_14.so vboxmouse_drv.so
- # xorg-server-1.3.x
- else
- newins vboxmouse_drv_71.so vboxmouse_drv.so
- fi
-
- # install hal information file about the mouse driver
- if use hal; then
- cd "${S}/src/VBox/Additions/linux/installer"
- insinto /usr/share/hal/fdi/information/20thirdparty
- doins 90-vboxguest.fdi
- fi
-}
-
-pkg_postinst() {
- elog "You need to edit the file /etc/X11/xorg.conf and set:"
- elog ""
- elog " Driver \"vboxmouse\""
- elog ""
- elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
- elog ""
-}
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.2.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.2.ebuild
deleted file mode 100644
index bf218edabb6e..000000000000
--- a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.2.ebuild,v 1.2 2009/05/04 06:58:20 mr_bones_ Exp $
-
-EAPI=2
-
-inherit x-modular eutils
-
-MY_P=VirtualBox-${PV}-OSE
-DESCRIPTION="VirtualBox input driver"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="hal"
-
-RDEPEND="x11-base/xorg-server
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.5-r1
- >=dev-lang/yasm-0.6.2
- sys-devel/dev86
- sys-power/iasl
- x11-proto/inputproto
- x11-proto/randrproto
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/-OSE/_OSE}
-
-src_prepare() {
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- rm -rf kBuild/bin tools
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
- source ./env.sh
-}
-
-src_compile() {
- for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
- /src/VBox/Additions/x11/vboxmouse ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk failed"
- done
-}
-
-src_install() {
- cd "${S}/out/linux.${ARCH}/release/bin/additions"
- insinto /usr/lib/xorg/modules/input
-
- # xorg-server-1.6.x (currently on the official x11 overlay)
- if has_version ">=x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_16.so vboxmouse_drv.so
- # xorg-server-1.5.x
- elif has_version ">=x11-base/xorg-server-1.5" \
- && has_version "<x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_15.so vboxmouse_drv.so
- # xorg-server-1.4.x
- elif has_version ">=x11-base/xorg-server-1.4" \
- && has_version "<x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_14.so vboxmouse_drv.so
- # xorg-server-1.3.x
- else
- newins vboxmouse_drv_71.so vboxmouse_drv.so
- fi
-
- # install hal information file about the mouse driver
- if use hal; then
- cd "${S}/src/VBox/Additions/linux/installer"
- insinto /usr/share/hal/fdi/information/20thirdparty
- doins 90-vboxguest.fdi
- fi
-}
-
-pkg_postinst() {
- elog "You need to edit the file /etc/X11/xorg.conf and set:"
- elog ""
- elog " Driver \"vboxmouse\""
- elog ""
- elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
- elog ""
-}
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.4.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.4.ebuild
deleted file mode 100644
index e367440eb3ce..000000000000
--- a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.4.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.4.ebuild,v 1.2 2009/06/01 13:31:15 mr_bones_ Exp $
-
-EAPI=2
-
-inherit x-modular eutils
-
-MY_P=VirtualBox-${PV}-OSE
-DESCRIPTION="VirtualBox input driver"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="hal"
-
-RDEPEND="x11-base/xorg-server
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.5-r1
- >=dev-lang/yasm-0.6.2
- sys-devel/dev86
- sys-power/iasl
- x11-proto/inputproto
- x11-proto/randrproto
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/-OSE/_OSE}
-
-src_prepare() {
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- rm -rf kBuild/bin tools
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
- source ./env.sh
-}
-
-src_compile() {
- for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
- /src/VBox/Additions/x11/vboxmouse ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk failed"
- done
-}
-
-src_install() {
- cd "${S}/out/linux.${ARCH}/release/bin/additions"
- insinto /usr/lib/xorg/modules/input
-
- # xorg-server-1.6.x (currently on the official x11 overlay)
- if has_version ">=x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_16.so vboxmouse_drv.so
- # xorg-server-1.5.x
- elif has_version ">=x11-base/xorg-server-1.5" \
- && has_version "<x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_15.so vboxmouse_drv.so
- # xorg-server-1.4.x
- elif has_version ">=x11-base/xorg-server-1.4" \
- && has_version "<x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_14.so vboxmouse_drv.so
- # xorg-server-1.3.x
- else
- newins vboxmouse_drv_71.so vboxmouse_drv.so
- fi
-
- # install hal information file about the mouse driver
- if use hal; then
- cd "${S}/src/VBox/Additions/linux/installer"
- insinto /usr/share/hal/fdi/information/20thirdparty
- doins 90-vboxguest.fdi
- fi
-}
-
-pkg_postinst() {
- elog "You need to edit the file /etc/X11/xorg.conf and set:"
- elog ""
- elog " Driver \"vboxmouse\""
- elog ""
- elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
- elog ""
-}
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.2.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.2.ebuild
deleted file mode 100644
index 32f70824209f..000000000000
--- a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.2.ebuild,v 1.1 2009/07/16 21:40:30 patrick Exp $
-
-EAPI=2
-
-inherit x-modular eutils
-
-MY_P=VirtualBox-${PV}-OSE
-DESCRIPTION="VirtualBox input driver"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="hal"
-
-RDEPEND="x11-base/xorg-server
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.5-r1
- >=dev-lang/yasm-0.6.2
- sys-devel/dev86
- sys-power/iasl
- x11-proto/inputproto
- x11-proto/randrproto
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/-OSE/_OSE}
-
-src_prepare() {
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- rm -rf kBuild/bin tools
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
- source ./env.sh
-}
-
-src_compile() {
- for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
- /src/VBox/Additions/x11/vboxmouse ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk failed"
- done
-}
-
-src_install() {
- cd "${S}/out/linux.${ARCH}/release/bin/additions"
- insinto /usr/lib/xorg/modules/input
-
- # xorg-server-1.6.x (currently on the official x11 overlay)
- if has_version ">=x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_16.so vboxmouse_drv.so
- # xorg-server-1.5.x
- elif has_version ">=x11-base/xorg-server-1.5" \
- && has_version "<x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_15.so vboxmouse_drv.so
- # xorg-server-1.4.x
- elif has_version ">=x11-base/xorg-server-1.4" \
- && has_version "<x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_14.so vboxmouse_drv.so
- # xorg-server-1.3.x
- else
- newins vboxmouse_drv_71.so vboxmouse_drv.so
- fi
-
- # install hal information file about the mouse driver
- if use hal; then
- cd "${S}/src/VBox/Additions/linux/installer"
- insinto /usr/share/hal/fdi/information/20thirdparty
- doins 90-vboxguest.fdi
- fi
-}
-
-pkg_postinst() {
- elog "You need to edit the file /etc/X11/xorg.conf and set:"
- elog ""
- elog " Driver \"vboxmouse\""
- elog ""
- elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
- elog ""
- if has_version ">=x11-base/xorg-server-1.5" ; then
- elog "Starting with 1.5 version, X.Org Server can do mouse auto-detection"
- elog "you may install the hal information file about the mouse driver:"
- elog ""
- elog "/usr/share/hal/fdi/information/20thirdparty/90-vboxguest.fdi"
- elog ""
- elog "dropping it into: /etc/hal/fdi/policy/"
- elog ""
- fi
-}
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild
deleted file mode 100644
index b2532ddecf40..000000000000
--- a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild,v 1.1 2009/08/17 14:32:07 patrick Exp $
-
-EAPI=2
-
-inherit x-modular eutils multilib
-
-MY_P=VirtualBox-${PV}-OSE
-DESCRIPTION="VirtualBox input driver"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="hal"
-
-RDEPEND="x11-base/xorg-server
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- >=dev-util/kbuild-0.1.5-r1
- >=dev-lang/yasm-0.6.2
- sys-devel/dev86
- sys-power/iasl
- x11-proto/inputproto
- x11-proto/randrproto
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/-OSE/_OSE}
-
-src_prepare() {
- # Remove shipped binaries (kBuild,yasm), see bug #232775
- rm -rf kBuild/bin tools
-
- # Disable things unused or splitted into separate ebuilds
- cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
-}
-
-src_configure() {
- # build the user-space tools, warnings are harmless
- ./configure --nofatal \
- --disable-xpcom \
- --disable-sdl-ttf \
- --disable-pulse \
- --disable-alsa \
- --build-headless || die "configure failed"
- source ./env.sh
-}
-
-src_compile() {
- for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
- /src/VBox/Additions/x11/vboxmouse ; do
- cd "${S}"${each}
- MAKE="kmk" emake TOOL_YASM_AS=yasm \
- KBUILD_PATH="${S}/kBuild" \
- || die "kmk failed"
- done
-}
-
-src_install() {
- cd "${S}/out/linux.${ARCH}/release/bin/additions"
- insinto /usr/$(get_libdir)/xorg/modules/input
-
- # xorg-server-1.6.x (currently on the official x11 overlay)
- if has_version ">=x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_16.so vboxmouse_drv.so
- # xorg-server-1.5.x
- elif has_version ">=x11-base/xorg-server-1.5" \
- && has_version "<x11-base/xorg-server-1.6" ; then
- newins vboxmouse_drv_15.so vboxmouse_drv.so
- # xorg-server-1.4.x
- elif has_version ">=x11-base/xorg-server-1.4" \
- && has_version "<x11-base/xorg-server-1.5" ; then
- newins vboxmouse_drv_14.so vboxmouse_drv.so
- # xorg-server-1.3.x
- else
- newins vboxmouse_drv_71.so vboxmouse_drv.so
- fi
-
- # install hal information file about the mouse driver
- if use hal; then
- cd "${S}/src/VBox/Additions/linux/installer"
- insinto /usr/share/hal/fdi/information/20thirdparty
- doins 90-vboxguest.fdi
- fi
-}
-
-pkg_postinst() {
- elog "You need to edit the file /etc/X11/xorg.conf and set:"
- elog ""
- elog " Driver \"vboxmouse\""
- elog ""
- elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
- elog ""
- if has_version ">=x11-base/xorg-server-1.5" ; then
- elog "Starting with 1.5 version, X.Org Server can do mouse auto-detection"
- elog "you may install the hal information file about the mouse driver:"
- elog ""
- elog "/usr/share/hal/fdi/information/20thirdparty/90-vboxguest.fdi"
- elog ""
- elog "dropping it into: /etc/hal/fdi/policy/"
- elog ""
- fi
-}