summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-10-08 19:50:05 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-10-08 19:50:05 +0000
commit0a0ce74225a68e897eb5b61c6ac4bd81109de4f5 (patch)
tree72c694385eb8875f942105166892beeb4270f1f8 /www-servers/tomcat
parentForce old version of sys-apps/hwids which didn't have 60-keyboard.hwdb file y... (diff)
downloadgentoo-2-0a0ce74225a68e897eb5b61c6ac4bd81109de4f5.tar.gz
gentoo-2-0a0ce74225a68e897eb5b61c6ac4bd81109de4f5.tar.bz2
gentoo-2-0a0ce74225a68e897eb5b61c6ac4bd81109de4f5.zip
Dropped vulnerable versions (CVE-2012-3544,CVE-2013-{2067,2071}) for security bug #469434.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'www-servers/tomcat')
-rw-r--r--www-servers/tomcat/ChangeLog7
-rw-r--r--www-servers/tomcat/tomcat-6.0.36.ebuild138
-rw-r--r--www-servers/tomcat/tomcat-7.0.32.ebuild137
-rw-r--r--www-servers/tomcat/tomcat-7.0.39.ebuild137
-rw-r--r--www-servers/tomcat/tomcat-7.0.41.ebuild137
5 files changed, 6 insertions, 550 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 8fcbac45439b..ad1db803d42a 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.323 2013/10/07 19:49:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.324 2013/10/08 19:50:05 tomwij Exp $
+
+ 08 Oct 2013; Tom Wijsman <TomWij@gentoo.org> -tomcat-6.0.36.ebuild,
+ -tomcat-7.0.32.ebuild, -tomcat-7.0.39.ebuild, -tomcat-7.0.41.ebuild:
+ Dropped vulnerable versions (CVE-2012-3544,CVE-2013-{2067,2071}) for security
+ bug #469434.
07 Oct 2013; Agostino Sarubbo <ago@gentoo.org> tomcat-6.0.37.ebuild,
tomcat-7.0.42.ebuild:
diff --git a/www-servers/tomcat/tomcat-6.0.36.ebuild b/www-servers/tomcat/tomcat-6.0.36.ebuild
deleted file mode 100644
index 20a8eb3b2e46..000000000000
--- a/www-servers/tomcat/tomcat-6.0.36.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.36.ebuild,v 1.6 2012/12/07 17:54:48 fordfrog Exp $
-
-EAPI=4
-
-JAVA_PKG_IUSE="source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-2.5/JSP-2.1 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-6/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="6"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="extra-webapps"
-
-RESTRICT="test"
-
-ECJ_SLOT="3.7"
-SAPI_SLOT="2.5"
-
-COMMON_DEP="
- dev-java/eclipse-ecj:${ECJ_SLOT}
- ~dev-java/tomcat-servlet-api-${PV}
- extra-webapps? ( dev-java/jakarta-jstl:0 )"
-RDEPEND="${COMMON_DEP}
- !<dev-java/tomcat-native-1.1.20
- >=virtual/jre-1.5"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.5
- >=dev-java/ant-core-1.8.1:0
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- java-pkg-2_pkg_setup
- enewgroup tomcat 265
- enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-java_prepare() {
- find -name '*.jar' -exec rm -v {} + || die
- epatch "${FILESDIR}/${P}-build.xml.patch"
-
- # For use of catalina.sh in netbeans
- sed -i -e "/^# ----- Execute The Requested Command/ a\
- CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
- bin/catalina.sh || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_DOC_TARGET=""
-EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPI_SLOT},eclipse-ecj-${ECJ_SLOT}"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-src_compile() {
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
- java-pkg-2_src_compile
-}
-
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- local dest="/usr/share/${PN}-${SLOT}"
-
- java-pkg_jarinto "${dest}"/bin
- java-pkg_dojar output/build/bin/*.jar
- exeinto "${dest}"/bin
- doexe output/build/bin/*.sh
-
- java-pkg_jarinto "${dest}"/lib
- java-pkg_dojar output/build/lib/*.jar
-
- # so we don't have to call java-config with --with-dependencies, which might
- # bring in more jars then actually desired.
- java-pkg_addcp "$(java-pkg_getjars eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT})"
-
- dodoc RELEASE-NOTES RUNNING.txt
- #use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
- use source && java-pkg_dosrc java/*
-
- ### Webapps ###
-
- insinto "${dest}"/webapps
- doins -r output/build/webapps/{host-manager,manager,ROOT}
- use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
- ### Config ###
-
- # replace the default pw with a random one, see #92281
- local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
- sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
- insinto "${dest}"
- doins -r output/build/conf
-
- ### rc ###
-
- cp "${FILESDIR}"/tomcat{.conf,.init,-instance-manager.bash} "${T}" || die
- eprefixify "${T}"/tomcat{.conf,.init,-instance-manager.bash}
- sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,.init,-instance-manager.bash} || die
-
- insinto "${dest}"/gentoo
- doins "${T}"/tomcat.conf
- exeinto "${dest}"/gentoo
- doexe "${T}"/tomcat{.init,-instance-manager.bash}
-}
-
-pkg_postinst() {
- elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
- elog "of Tomcat (<6.0.36), you have to migrate your existing instance to work with new Tomcat."
- elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
- elog "To manage Tomcat instances, run:"
- elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
- ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
- ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-# einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}
diff --git a/www-servers/tomcat/tomcat-7.0.32.ebuild b/www-servers/tomcat/tomcat-7.0.32.ebuild
deleted file mode 100644
index e3b456c46dbb..000000000000
--- a/www-servers/tomcat/tomcat-7.0.32.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.32.ebuild,v 1.7 2012/12/07 17:54:48 fordfrog Exp $
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="7"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="3.7"
-SAPI_SLOT="3.0"
-
-COMMON_DEP="
- dev-java/eclipse-ecj:${ECJ_SLOT}
- ~dev-java/tomcat-servlet-api-${PV}
- extra-webapps? ( dev-java/jakarta-jstl:0 )"
-RDEPEND="${COMMON_DEP}
- !<dev-java/tomcat-native-1.1.20
- >=virtual/jre-1.6"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.6
- >=dev-java/ant-core-1.8.1:0
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- java-pkg-2_pkg_setup
- enewgroup tomcat 265
- enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-java_prepare() {
- find -name '*.jar' -exec rm -v {} + || die
- epatch "${FILESDIR}/${P}-build.xml.patch"
-
- # For use of catalina.sh in netbeans
- sed -i -e "/^# ----- Execute The Requested Command/ a\
- CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
- bin/catalina.sh || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPI_SLOT},eclipse-ecj-${ECJ_SLOT}"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-src_compile() {
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
- java-pkg-2_src_compile
-}
-
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- local dest="/usr/share/${PN}-${SLOT}"
-
- java-pkg_jarinto "${dest}"/bin
- java-pkg_dojar output/build/bin/*.jar
- exeinto "${dest}"/bin
- doexe output/build/bin/*.sh
-
- java-pkg_jarinto "${dest}"/lib
- java-pkg_dojar output/build/lib/*.jar
-
- # so we don't have to call java-config with --with-dependencies, which might
- # bring in more jars then actually desired.
- java-pkg_addcp "$(java-pkg_getjars eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT})"
-
- dodoc RELEASE-NOTES RUNNING.txt
- use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
- use source && java-pkg_dosrc java/*
-
- ### Webapps ###
-
- insinto "${dest}"/webapps
- doins -r output/build/webapps/{host-manager,manager,ROOT}
- use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
- ### Config ###
-
- # replace the default pw with a random one, see #92281
- local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
- sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
- insinto "${dest}"
- doins -r output/build/conf
-
- ### rc ###
-
- cp "${FILESDIR}"/tomcat{.conf,.init,-instance-manager.bash} "${T}" || die
- eprefixify "${T}"/tomcat{.conf,.init,-instance-manager.bash}
- sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,.init,-instance-manager.bash} || die
-
- insinto "${dest}"/gentoo
- doins "${T}"/tomcat.conf
- exeinto "${dest}"/gentoo
- doexe "${T}"/tomcat{.init,-instance-manager.bash}
-}
-
-pkg_postinst() {
- elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
- elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
- elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
- elog "To manage Tomcat instances, run:"
- elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
- ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
- ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-# einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}
diff --git a/www-servers/tomcat/tomcat-7.0.39.ebuild b/www-servers/tomcat/tomcat-7.0.39.ebuild
deleted file mode 100644
index 7e580d2e4924..000000000000
--- a/www-servers/tomcat/tomcat-7.0.39.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.39.ebuild,v 1.1 2013/03/28 12:57:59 fordfrog Exp $
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="7"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.2"
-SAPI_SLOT="3.0"
-
-COMMON_DEP="
- dev-java/eclipse-ecj:${ECJ_SLOT}
- ~dev-java/tomcat-servlet-api-${PV}
- extra-webapps? ( dev-java/jakarta-jstl:0 )"
-RDEPEND="${COMMON_DEP}
- !<dev-java/tomcat-native-1.1.24
- >=virtual/jre-1.6"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.6
- >=dev-java/ant-core-1.8.1:0
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- java-pkg-2_pkg_setup
- enewgroup tomcat 265
- enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-java_prepare() {
- find -name '*.jar' -exec rm -v {} + || die
- epatch "${FILESDIR}/${P}-build.xml.patch"
-
- # For use of catalina.sh in netbeans
- sed -i -e "/^# ----- Execute The Requested Command/ a\
- CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
- bin/catalina.sh || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPI_SLOT},eclipse-ecj-${ECJ_SLOT}"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-src_compile() {
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
- java-pkg-2_src_compile
-}
-
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- local dest="/usr/share/${PN}-${SLOT}"
-
- java-pkg_jarinto "${dest}"/bin
- java-pkg_dojar output/build/bin/*.jar
- exeinto "${dest}"/bin
- doexe output/build/bin/*.sh
-
- java-pkg_jarinto "${dest}"/lib
- java-pkg_dojar output/build/lib/*.jar
-
- # so we don't have to call java-config with --with-dependencies, which might
- # bring in more jars then actually desired.
- java-pkg_addcp "$(java-pkg_getjars eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT})"
-
- dodoc RELEASE-NOTES RUNNING.txt
- use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
- use source && java-pkg_dosrc java/*
-
- ### Webapps ###
-
- insinto "${dest}"/webapps
- doins -r output/build/webapps/{host-manager,manager,ROOT}
- use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
- ### Config ###
-
- # replace the default pw with a random one, see #92281
- local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
- sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
- insinto "${dest}"
- doins -r output/build/conf
-
- ### rc ###
-
- cp "${FILESDIR}"/tomcat{.conf,.init,-instance-manager.bash} "${T}" || die
- eprefixify "${T}"/tomcat{.conf,.init,-instance-manager.bash}
- sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,.init,-instance-manager.bash} || die
-
- insinto "${dest}"/gentoo
- doins "${T}"/tomcat.conf
- exeinto "${dest}"/gentoo
- doexe "${T}"/tomcat{.init,-instance-manager.bash}
-}
-
-pkg_postinst() {
- elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
- elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
- elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
- elog "To manage Tomcat instances, run:"
- elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
- ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
- ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-# einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}
diff --git a/www-servers/tomcat/tomcat-7.0.41.ebuild b/www-servers/tomcat/tomcat-7.0.41.ebuild
deleted file mode 100644
index db0c43d036f8..000000000000
--- a/www-servers/tomcat/tomcat-7.0.41.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.41.ebuild,v 1.1 2013/06/11 11:35:01 fordfrog Exp $
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="7"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.2"
-SAPI_SLOT="3.0"
-
-COMMON_DEP="
- dev-java/eclipse-ecj:${ECJ_SLOT}
- ~dev-java/tomcat-servlet-api-${PV}
- extra-webapps? ( dev-java/jakarta-jstl:0 )"
-RDEPEND="${COMMON_DEP}
- !<dev-java/tomcat-native-1.1.24
- >=virtual/jre-1.6"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.6
- >=dev-java/ant-core-1.8.1:0
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- java-pkg-2_pkg_setup
- enewgroup tomcat 265
- enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-java_prepare() {
- find -name '*.jar' -exec rm -v {} + || die
- epatch "${FILESDIR}/${P}-build.xml.patch"
-
- # For use of catalina.sh in netbeans
- sed -i -e "/^# ----- Execute The Requested Command/ a\
- CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
- bin/catalina.sh || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPI_SLOT},eclipse-ecj-${ECJ_SLOT}"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-src_compile() {
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
- java-pkg-2_src_compile
-}
-
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- local dest="/usr/share/${PN}-${SLOT}"
-
- java-pkg_jarinto "${dest}"/bin
- java-pkg_dojar output/build/bin/*.jar
- exeinto "${dest}"/bin
- doexe output/build/bin/*.sh
-
- java-pkg_jarinto "${dest}"/lib
- java-pkg_dojar output/build/lib/*.jar
-
- # so we don't have to call java-config with --with-dependencies, which might
- # bring in more jars then actually desired.
- java-pkg_addcp "$(java-pkg_getjars eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT})"
-
- dodoc RELEASE-NOTES RUNNING.txt
- use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
- use source && java-pkg_dosrc java/*
-
- ### Webapps ###
-
- insinto "${dest}"/webapps
- doins -r output/build/webapps/{host-manager,manager,ROOT}
- use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
- ### Config ###
-
- # replace the default pw with a random one, see #92281
- local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
- sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
- insinto "${dest}"
- doins -r output/build/conf
-
- ### rc ###
-
- cp "${FILESDIR}"/tomcat{.conf,.init,-instance-manager.bash} "${T}" || die
- eprefixify "${T}"/tomcat{.conf,.init,-instance-manager.bash}
- sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,.init,-instance-manager.bash} || die
-
- insinto "${dest}"/gentoo
- doins "${T}"/tomcat.conf
- exeinto "${dest}"/gentoo
- doexe "${T}"/tomcat{.init,-instance-manager.bash}
-}
-
-pkg_postinst() {
- elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
- elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
- elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
- elog "To manage Tomcat instances, run:"
- elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
- ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
- ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-# einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}