summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-04-16 01:43:40 +0000
committerMike Gilbert <floppym@gentoo.org>2013-04-16 01:43:40 +0000
commit2136e0ef8bb3082973492a4b1bdef619ceaa38cf (patch)
treeb4c4b3eaeec9a74477abfa1ca3625f8efdeb7dd0 /www-plugins
parentDev channel bump. (diff)
downloadgentoo-2-2136e0ef8bb3082973492a4b1bdef619ceaa38cf.tar.gz
gentoo-2-2136e0ef8bb3082973492a4b1bdef619ceaa38cf.tar.bz2
gentoo-2-2136e0ef8bb3082973492a4b1bdef619ceaa38cf.zip
Convert live ebuilds into normal ones, bug 457638.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/chrome-binary-plugins/ChangeLog14
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-26.0.1410.63_p192696.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-9998.ebuild)58
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-27.0.1453.47_beta193194.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-9997.ebuild)58
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-28.0.1478.0_alpha194114.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild)58
4 files changed, 115 insertions, 73 deletions
diff --git a/www-plugins/chrome-binary-plugins/ChangeLog b/www-plugins/chrome-binary-plugins/ChangeLog
index 90e7d6baf732..542a7139939d 100644
--- a/www-plugins/chrome-binary-plugins/ChangeLog
+++ b/www-plugins/chrome-binary-plugins/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for www-plugins/chrome-binary-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.7 2013/03/19 23:06:23 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.8 2013/04/16 01:43:40 floppym Exp $
+
+*chrome-binary-plugins-26.0.1410.63_p192696 (16 Apr 2013)
+*chrome-binary-plugins-27.0.1453.47_beta193194 (16 Apr 2013)
+*chrome-binary-plugins-28.0.1478.0_alpha194114 (16 Apr 2013)
+
+ 16 Apr 2013; Mike Gilbert <floppym@gentoo.org>
+ +chrome-binary-plugins-26.0.1410.63_p192696.ebuild,
+ +chrome-binary-plugins-27.0.1453.47_beta193194.ebuild,
+ +chrome-binary-plugins-28.0.1478.0_alpha194114.ebuild,
+ -chrome-binary-plugins-9997.ebuild, -chrome-binary-plugins-9998.ebuild,
+ -chrome-binary-plugins-9999.ebuild:
+ Convert live ebuilds into normal ones, bug 457638.
*chrome-binary-plugins-9997 (19 Mar 2013)
*chrome-binary-plugins-9998 (19 Mar 2013)
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9998.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-26.0.1410.63_p192696.ebuild
index 4fe860e4276c..759b36b48ecd 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9998.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-26.0.1410.63_p192696.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9998.ebuild,v 1.1 2013/03/19 23:06:23 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-26.0.1410.63_p192696.ebuild,v 1.1 2013/04/16 01:43:40 floppym Exp $
EAPI=4
@@ -8,15 +8,41 @@ inherit multilib unpacker
DESCRIPTION="Binary plugins -- native API Flash and PDF -- from Google Chrome for use in Chromium."
HOMEPAGE="http://www.google.com/chrome"
-SLOT="beta"
-URI_BASE="https://dl.google.com/linux/direct/"
-URI_BASE_NAME="google-chrome-${SLOT}_current_"
-SRC_URI="" # URI is left blank on live ebuild
-RESTRICT="bindist mirror strip"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ MY_PV=${PV/_alpha/-r}
+ ;;
+ *_beta*)
+ SLOT="beta"
+ MY_PV=${PV/_beta/-r}
+ ;;
+ *_p*)
+ SLOT="stable"
+ MY_PV=${PV/_p/-r}
+ ;;
+ *)
+ die "Invalid value for \${PV}: ${PV}"
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="
+ amd64? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
+ )
+ x86? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
+ )
+"
LICENSE="google-chrome"
-KEYWORDS="" # KEYWORDS is also left blank on live ebuild
+KEYWORDS="~amd64 ~x86"
IUSE="+flash +pdf"
+RESTRICT="bindist mirror strip"
RDEPEND="www-client/chromium"
@@ -27,23 +53,7 @@ for x in 0 beta stable unstable; do
done
S="${WORKDIR}/opt/google/chrome"
-
-QA_FLAGS_IGNORED="/usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so
- /usr/$(get_libdir)/chromium-browser/libpdf.so"
-
-src_unpack() {
- # We have to do this inside of here, since it's a live ebuild. :-(
-
- if use x86; then
- G_ARCH="i386";
- elif use amd64; then
- G_ARCH="amd64";
- else
- die "This only supports x86 and amd64."
- fi
- wget "${URI_BASE}${URI_BASE_NAME}${G_ARCH}.deb"
- unpack_deb "./${URI_BASE_NAME}${G_ARCH}.deb"
-}
+QA_PREBUILT="*"
src_install() {
local version flapper
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9997.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-27.0.1453.47_beta193194.ebuild
index d6394bd78a9a..6c8f738c04d6 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9997.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-27.0.1453.47_beta193194.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9997.ebuild,v 1.1 2013/03/19 23:06:23 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-27.0.1453.47_beta193194.ebuild,v 1.1 2013/04/16 01:43:40 floppym Exp $
EAPI=4
@@ -8,15 +8,41 @@ inherit multilib unpacker
DESCRIPTION="Binary plugins -- native API Flash and PDF -- from Google Chrome for use in Chromium."
HOMEPAGE="http://www.google.com/chrome"
-SLOT="stable"
-URI_BASE="https://dl.google.com/linux/direct/"
-URI_BASE_NAME="google-chrome-${SLOT}_current_"
-SRC_URI="" # URI is left blank on live ebuild
-RESTRICT="bindist mirror strip"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ MY_PV=${PV/_alpha/-r}
+ ;;
+ *_beta*)
+ SLOT="beta"
+ MY_PV=${PV/_beta/-r}
+ ;;
+ *_p*)
+ SLOT="stable"
+ MY_PV=${PV/_p/-r}
+ ;;
+ *)
+ die "Invalid value for \${PV}: ${PV}"
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="
+ amd64? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
+ )
+ x86? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
+ )
+"
LICENSE="google-chrome"
-KEYWORDS="" # KEYWORDS is also left blank on live ebuild
+KEYWORDS="~amd64 ~x86"
IUSE="+flash +pdf"
+RESTRICT="bindist mirror strip"
RDEPEND="www-client/chromium"
@@ -27,23 +53,7 @@ for x in 0 beta stable unstable; do
done
S="${WORKDIR}/opt/google/chrome"
-
-QA_FLAGS_IGNORED="/usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so
- /usr/$(get_libdir)/chromium-browser/libpdf.so"
-
-src_unpack() {
- # We have to do this inside of here, since it's a live ebuild. :-(
-
- if use x86; then
- G_ARCH="i386";
- elif use amd64; then
- G_ARCH="amd64";
- else
- die "This only supports x86 and amd64."
- fi
- wget "${URI_BASE}${URI_BASE_NAME}${G_ARCH}.deb"
- unpack_deb "./${URI_BASE_NAME}${G_ARCH}.deb"
-}
+QA_PREBUILT="*"
src_install() {
local version flapper
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-28.0.1478.0_alpha194114.ebuild
index 8dcd84115873..4d7455a795e8 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-28.0.1478.0_alpha194114.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild,v 1.7 2013/03/19 23:06:23 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-28.0.1478.0_alpha194114.ebuild,v 1.1 2013/04/16 01:43:40 floppym Exp $
EAPI=4
@@ -8,15 +8,41 @@ inherit multilib unpacker
DESCRIPTION="Binary plugins -- native API Flash and PDF -- from Google Chrome for use in Chromium."
HOMEPAGE="http://www.google.com/chrome"
-SLOT="unstable"
-URI_BASE="https://dl.google.com/linux/direct/"
-URI_BASE_NAME="google-chrome-${SLOT}_current_"
-SRC_URI="" # URI is left blank on live ebuild
-RESTRICT="bindist mirror strip"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ MY_PV=${PV/_alpha/-r}
+ ;;
+ *_beta*)
+ SLOT="beta"
+ MY_PV=${PV/_beta/-r}
+ ;;
+ *_p*)
+ SLOT="stable"
+ MY_PV=${PV/_p/-r}
+ ;;
+ *)
+ die "Invalid value for \${PV}: ${PV}"
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="
+ amd64? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
+ )
+ x86? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
+ )
+"
LICENSE="google-chrome"
-KEYWORDS="" # KEYWORDS is also left blank on live ebuild
+KEYWORDS="~amd64 ~x86"
IUSE="+flash +pdf"
+RESTRICT="bindist mirror strip"
RDEPEND="www-client/chromium"
@@ -27,23 +53,7 @@ for x in 0 beta stable unstable; do
done
S="${WORKDIR}/opt/google/chrome"
-
-QA_FLAGS_IGNORED="/usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so
- /usr/$(get_libdir)/chromium-browser/libpdf.so"
-
-src_unpack() {
- # We have to do this inside of here, since it's a live ebuild. :-(
-
- if use x86; then
- G_ARCH="i386";
- elif use amd64; then
- G_ARCH="amd64";
- else
- die "This only supports x86 and amd64."
- fi
- wget "${URI_BASE}${URI_BASE_NAME}${G_ARCH}.deb"
- unpack_deb "./${URI_BASE_NAME}${G_ARCH}.deb"
-}
+QA_PREBUILT="*"
src_install() {
local version flapper