summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-29 16:59:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-29 16:59:22 +0000
commit65ede371a31c34ea489f9c778c297e30de5a9f30 (patch)
tree0148de58c9bd210c33b9d95053021634da6fceab /www-plugins/gecko-mediaplayer
parentFix bug 286795. (diff)
downloadgentoo-2-65ede371a31c34ea489f9c778c297e30de5a9f30.tar.gz
gentoo-2-65ede371a31c34ea489f9c778c297e30de5a9f30.tar.bz2
gentoo-2-65ede371a31c34ea489f9c778c297e30de5a9f30.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gecko-mediaplayer')
-rw-r--r--www-plugins/gecko-mediaplayer/ChangeLog9
-rw-r--r--www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8-asneeded.patch104
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8.ebuild51
3 files changed, 163 insertions, 1 deletions
diff --git a/www-plugins/gecko-mediaplayer/ChangeLog b/www-plugins/gecko-mediaplayer/ChangeLog
index e9d7aafb3d7a..04c606643938 100644
--- a/www-plugins/gecko-mediaplayer/ChangeLog
+++ b/www-plugins/gecko-mediaplayer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/gecko-mediaplayer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/ChangeLog,v 1.16 2009/09/29 16:39:26 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/ChangeLog,v 1.17 2009/09/29 16:59:21 ssuominen Exp $
+
+*gecko-mediaplayer-0.9.8 (29 Sep 2009)
+
+ 29 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +gecko-mediaplayer-0.9.8.ebuild,
+ +files/gecko-mediaplayer-0.9.8-asneeded.patch:
+ Version bump.
29 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
gecko-mediaplayer-0.9.7-r1.ebuild,
diff --git a/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8-asneeded.patch b/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8-asneeded.patch
new file mode 100644
index 000000000000..831c17c8b904
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/files/gecko-mediaplayer-0.9.8-asneeded.patch
@@ -0,0 +1,104 @@
+diff -ruN gecko-mediaplayer-0.9.8.orig/m4/gconf-2.m4 gecko-mediaplayer-0.9.8/m4/gconf-2.m4
+--- gecko-mediaplayer-0.9.8.orig/m4/gconf-2.m4 1970-01-01 02:00:00.000000000 +0200
++++ gecko-mediaplayer-0.9.8/m4/gconf-2.m4 2009-09-29 19:59:41.000000000 +0300
+@@ -0,0 +1,44 @@
++dnl AM_GCONF_SOURCE_2
++dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
++dnl (i.e. pass to gconftool-2
++dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
++dnl you should install foo.schemas files
++dnl
++
++AC_DEFUN([AM_GCONF_SOURCE_2],
++[
++ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
++ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
++ else
++ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
++ fi
++
++ AC_ARG_WITH([gconf-source],
++ AC_HELP_STRING([--with-gconf-source=sourceaddress],
++ [Config database for installing schema files.]),
++ [GCONF_SCHEMA_CONFIG_SOURCE="$withval"],)
++
++ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
++ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
++
++ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
++ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
++ fi
++
++ AC_ARG_WITH([gconf-schema-file-dir],
++ AC_HELP_STRING([--with-gconf-schema-file-dir=dir],
++ [Directory for installing schema files.]),
++ [GCONF_SCHEMA_FILE_DIR="$withval"],)
++
++ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
++ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
++
++ AC_ARG_ENABLE(schemas-install,
++ AC_HELP_STRING([--disable-schemas-install],
++ [Disable the schemas installation]),
++ [case ${enableval} in
++ yes|no) ;;
++ *) AC_MSG_ERROR([bad value ${enableval} for --enable-schemas-install]) ;;
++ esac])
++ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
++])
+diff -ruN gecko-mediaplayer-0.9.8.orig/src/Makefile.am gecko-mediaplayer-0.9.8/src/Makefile.am
+--- gecko-mediaplayer-0.9.8.orig/src/Makefile.am 2009-06-07 20:05:27.000000000 +0300
++++ gecko-mediaplayer-0.9.8/src/Makefile.am 2009-09-29 19:59:04.000000000 +0300
+@@ -20,6 +20,7 @@
+ -Wall \
+ -g
+
++LIBS = $(GLIB_LIBS) $(DBUS_LIBS) $(GCONF_LIBS)
+
+ COMMONCODE = \
+ ../config.h \
+@@ -52,7 +53,7 @@
+ $(COMMONCODE)
+
+ gecko_mediaplayer_so_CFLAGS = -fPIC
+-gecko_mediaplayer_so_LDFLAGS = -shared $(GLIB_LIBS) $(DBUS_LIBS) $(GCONF_LIBS) -fPIC
++gecko_mediaplayer_so_LDFLAGS = -shared -fPIC
+ gecko_mediaplayer_so_LDADD = libgmlib/libgmlib.a
+
+ gecko_mediaplayer_qt_so_SOURCES = \
+@@ -60,7 +61,7 @@
+ $(COMMONCODE)
+
+ gecko_mediaplayer_qt_so_CFLAGS = -fPIC
+-gecko_mediaplayer_qt_so_LDFLAGS = -shared $(GLIB_LIBS) $(DBUS_LIBS) $(GCONF_LIBS) -fPIC
++gecko_mediaplayer_qt_so_LDFLAGS = -shared -fPIC
+ gecko_mediaplayer_qt_so_LDADD = libgmlib/libgmlib.a
+
+ gecko_mediaplayer_wmp_so_SOURCES = \
+@@ -68,7 +69,7 @@
+ $(COMMONCODE)
+
+ gecko_mediaplayer_wmp_so_CFLAGS = -fPIC
+-gecko_mediaplayer_wmp_so_LDFLAGS = -shared $(GLIB_LIBS) $(DBUS_LIBS) $(GCONF_LIBS) -fPIC
++gecko_mediaplayer_wmp_so_LDFLAGS = -shared -fPIC
+ gecko_mediaplayer_wmp_so_LDADD = libgmlib/libgmlib.a
+
+ gecko_mediaplayer_dvx_so_SOURCES = \
+@@ -76,7 +77,7 @@
+ $(COMMONCODE)
+
+ gecko_mediaplayer_dvx_so_CFLAGS = -fPIC
+-gecko_mediaplayer_dvx_so_LDFLAGS = -shared $(GLIB_LIBS) $(DBUS_LIBS) $(GCONF_LIBS) -fPIC
++gecko_mediaplayer_dvx_so_LDFLAGS = -shared -fPIC
+ gecko_mediaplayer_dvx_so_LDADD = libgmlib/libgmlib.a
+
+ gecko_mediaplayer_rm_so_SOURCES = \
+@@ -84,7 +85,7 @@
+ $(COMMONCODE)
+
+ gecko_mediaplayer_rm_so_CFLAGS = -fPIC
+-gecko_mediaplayer_rm_so_LDFLAGS = -shared $(GLIB_LIBS) $(DBUS_LIBS) $(GCONF_LIBS) -fPIC
++gecko_mediaplayer_rm_so_LDFLAGS = -shared -fPIC
+ gecko_mediaplayer_rm_so_LDADD = libgmlib/libgmlib.a
+
+ indent:
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8.ebuild
new file mode 100644
index 000000000000..e354bd84e7bd
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/gecko-mediaplayer-0.9.8.ebuild,v 1.1 2009/09/29 16:59:21 ssuominen Exp $
+
+EAPI=2
+GCONF_DEBUG=no
+inherit autotools eutils gnome2 multilib
+
+DESCRIPTION="A browser multimedia plugin using gnome-mplayer"
+HOMEPAGE="http://code.google.com/p/gecko-mediaplayer"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gnome"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ net-libs/xulrunner:1.9
+ dev-libs/nspr
+ >=dev-libs/dbus-glib-0.70
+ >=media-video/gnome-mplayer-${PV}
+ gnome? ( >=gnome-base/gconf-2:2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ G2CONF="$(use_enable gnome schemas-install)
+ $(use_with gnome gconf)
+ --with-gio"
+ DOCS="ChangeLog DOCS/tech/javascript.txt"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ # move plugins to correct location and clean up empty dirs
+ dodir /usr/$(get_libdir)/nsbrowser/plugins
+ mv "${D}"/usr/$(get_libdir)/nspr/mozilla/plugins/${PN}* \
+ "${D}"/usr/$(get_libdir)/nsbrowser/plugins || die "plugins move failed"
+ rm -rf "${D}"/usr/$(get_libdir)/nspr
+ rm -rf "${D}"/var
+}