summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2010-04-11 20:31:14 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2010-04-11 20:31:14 +0000
commitb5febd11a3217a5eec094bb4624472d1b87ab572 (patch)
tree6f760ca7fbafc9b111c10aca1f863e56a610ee15 /www-client/links
parentFix building with newer linux-headers where hayes esp no longer exists #30988... (diff)
downloadgentoo-2-b5febd11a3217a5eec094bb4624472d1b87ab572.tar.gz
gentoo-2-b5febd11a3217a5eec094bb4624472d1b87ab572.tar.bz2
gentoo-2-b5febd11a3217a5eec094bb4624472d1b87ab572.zip
2.3_pre1 version bump for bug 304861, thanks to hitachi <mail at konstantinhansen dot de> for
reporting. The UTF-8 patch is no longer applied since UTF-8 text mode terminal support is now present in upstream - if you have problems, please report. (Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'www-client/links')
-rw-r--r--www-client/links/ChangeLog11
-rw-r--r--www-client/links/links-2.3_pre1.ebuild128
-rw-r--r--www-client/links/metadata.xml6
3 files changed, 138 insertions, 7 deletions
diff --git a/www-client/links/ChangeLog b/www-client/links/ChangeLog
index da33cf5b9bf7..495c9fd16b45 100644
--- a/www-client/links/ChangeLog
+++ b/www-client/links/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/links
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.123 2010/02/26 16:29:33 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.124 2010/04/11 20:31:14 vanquirius Exp $
+
+*links-2.3_pre1 (11 Apr 2010)
+
+ 11 Apr 2010; Marcelo Goes <vanquirius@gentoo.org> +links-2.3_pre1.ebuild,
+ metadata.xml:
+ 2.3_pre1 version bump for bug 304861, thanks to hitachi <mail at
+ konstantinhansen dot de> for reporting. The UTF-8 patch is no longer
+ applied since UTF-8 text mode terminal support is now present in upstream
+ - if you have problems, please report.
26 Feb 2010; Fabian Groffen <grobian@gentoo.org> links-2.2.ebuild:
Marked ~x64-macos, thanks Ramon van Alteren, bug #305367
diff --git a/www-client/links/links-2.3_pre1.ebuild b/www-client/links/links-2.3_pre1.ebuild
new file mode 100644
index 000000000000..c4ed3dba5297
--- /dev/null
+++ b/www-client/links/links-2.3_pre1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.3_pre1.ebuild,v 1.1 2010/04/11 20:31:14 vanquirius Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=none
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="links is a fast lightweight text and graphic web-browser"
+HOMEPAGE="http://links.twibright.com/"
+# To handle pre-version ...
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://links.twibright.com/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 directfb fbcon gpm jpeg livecd png sdl ssl svga tiff unicode X zlib"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+# We've also made USE=livecd compile in graphics mode. This closes bug #75685.
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ fbcon? ( >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ sys-libs/gpm )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3
+ >=media-libs/libpng-1.2.1 )
+ X? ( x11-libs/libXext
+ >=media-libs/libpng-1.2.1 )
+ directfb? ( dev-libs/DirectFB )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ sys-libs/ncurses
+ livecd? ( >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ sys-libs/gpm )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack (){
+ unpack ${A}; cd "${S}"
+
+ epatch "${FILESDIR}"/configure-LANG.patch #131440
+
+ if use unicode ; then
+ cd "${S}/intl" && ./gen-intl && cd .. || die "gen-intl failed"
+ cd "${S}/intl" && ./synclang && cd .. || die "synclang failed"
+ fi
+ # Upstream configure produced by broken autoconf-2.13. See #131440 and
+ # #103483#c23
+ eautoconf || die "autoconf failed"
+}
+
+src_compile (){
+ local myconf
+
+ if use X || use fbcon || use directfb || use svga || use livecd; then
+ myconf="${myconf} --enable-graphics"
+ fi
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so
+ # we use the autoconf trick
+ ( use gpm || use fbcon || use livecd ) || export ac_cv_lib_gpm_Gpm_Open="no"
+
+ export LANG=C
+
+ if use fbcon || use livecd; then
+ myconf="${myconf} --with-fb"
+ else
+ myconf="${myconf} --without-fb"
+ fi
+
+ # force --with-libjpeg if livecd flag is set
+ if use livecd; then
+ myconf="${myconf} --with-libjpeg"
+ fi
+
+ # hack to allow cross-compilation
+ export CC="$(tc-getCC)"
+
+ econf \
+ $(use_with X x) \
+ $(use_with png libpng) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_with svga svgalib) \
+ $(use_with directfb) \
+ $(use_with ssl) \
+ $(use_with sdl) \
+ $(use_with zlib) \
+ $(use_with bzip2) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+
+ # Only install links icon if X driver was compiled in ...
+ use X && doicon graphics/links.xpm
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README SITES TODO
+ dohtml doc/links_cal/*
+
+ # Install a compatibility symlink links2:
+ dosym links /usr/bin/links2
+}
+
+pkg_postinst() {
+ if use svga ; then
+ elog "You had the svga USE flag enabled, but for security reasons"
+ elog "the links2 binary is NOT setuid by default. In order to"
+ elog "enable links2 to work in SVGA, please change the permissions"
+ elog "of /usr/bin/links2 to enable suid."
+ fi
+}
diff --git a/www-client/links/metadata.xml b/www-client/links/metadata.xml
index 5ad3840dbed3..fe240adddc2c 100644
--- a/www-client/links/metadata.xml
+++ b/www-client/links/metadata.xml
@@ -3,13 +3,7 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>las0mbra@ig.com.br</email>
- <name>Ingo -LaSombra- Hoffmann</name>
- <description>Ingo is the third party maintainer</description>
-</maintainer>
-<maintainer>
<email>vanquirius@gentoo.org</email>
<name>Marcelo Goes</name>
- <description>Marcelo is the official Gentoo maintainer</description>
</maintainer>
</pkgmetadata>