summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-30 07:57:59 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-30 07:57:59 +0000
commitf6be679fe9a422e20fcc0d523adae286097d1f90 (patch)
tree8baee214d2995e9779cd2d2a9241fe396a514634 /www-client/dwb/dwb-9999.ebuild
parentLeechcraft changed license since 0.5.95 (diff)
downloadgentoo-2-f6be679fe9a422e20fcc0d523adae286097d1f90.tar.gz
gentoo-2-f6be679fe9a422e20fcc0d523adae286097d1f90.tar.bz2
gentoo-2-f6be679fe9a422e20fcc0d523adae286097d1f90.zip
Fix compile with >=json-c-0.11 (bug #467940), fix compile on uclibc and other systems without execinfo.h (bug #465170), and add dep on gnutls.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-client/dwb/dwb-9999.ebuild')
-rw-r--r--www-client/dwb/dwb-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/www-client/dwb/dwb-9999.ebuild b/www-client/dwb/dwb-9999.ebuild
index b7752420ae8e..c0fdfcb9537f 100644
--- a/www-client/dwb/dwb-9999.ebuild
+++ b/www-client/dwb/dwb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-9999.ebuild,v 1.6 2013/04/08 15:17:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-9999.ebuild,v 1.7 2013/04/30 07:57:58 radhermit Exp $
EAPI=5
@@ -10,7 +10,6 @@ EGIT_REPO_URI="https://bitbucket.org/portix/dwb.git"
DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
HOMEPAGE="http://portix.bitbucket.org/dwb/"
-SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
@@ -19,6 +18,7 @@ IUSE="examples gtk3"
RDEPEND=">=net-libs/libsoup-2.32:2.4
dev-libs/json-c
+ net-libs/gnutls
!gtk3? (
>=net-libs/webkit-gtk-1.8.0:2
x11-libs/gtk+:2
@@ -38,6 +38,11 @@ src_compile() {
local myconf
use gtk3 && myconf+=" GTK=3"
+ # uclibc and other systems don't have execinfo.h (bug #465170)
+ if ! (echo '#include <execinfo.h>' | $(tc-getCC) -E - &>/dev/null) ; then
+ myconf+=" WITHOUT_EXECINFO=1"
+ fi
+
emake CC="$(tc-getCC)" ${myconf}
}