summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-04-20 18:46:24 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-04-20 18:46:24 +0000
commit8dead13c50c879c6773b4828ec68c4ef3c81c55a (patch)
treec9ff3367ac9ad82297cd00d5bc63012dcd35894d /www-apps/mythweb
parentAdding experimental trunk ebuild (diff)
downloadgentoo-2-8dead13c50c879c6773b4828ec68c4ef3c81c55a.tar.gz
gentoo-2-8dead13c50c879c6773b4828ec68c4ef3c81c55a.tar.bz2
gentoo-2-8dead13c50c879c6773b4828ec68c4ef3c81c55a.zip
Adding experimental trunk ebuild
(Portage version: 2.1.2.4)
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/files/digest-mythweb-0.21_pre132850
-rw-r--r--www-apps/mythweb/mythweb-0.21_pre13285.ebuild48
3 files changed, 55 insertions, 1 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 7d2a2ffff3bc..02a6ed8e65fe 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.31 2007/04/20 01:49:18 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.32 2007/04/20 18:46:24 cardoe Exp $
+
+*mythweb-0.21_pre13285 (20 Apr 2007)
+
+ 20 Apr 2007; Doug Goldstein <cardoe@gentoo.org>
+ +mythweb-0.21_pre13285.ebuild:
+ Adding experimental trunk ebuild
20 Apr 2007; Doug Goldstein <cardoe@gentoo.org>
-mythweb-0.19_p10505.ebuild:
diff --git a/www-apps/mythweb/files/digest-mythweb-0.21_pre13285 b/www-apps/mythweb/files/digest-mythweb-0.21_pre13285
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/www-apps/mythweb/files/digest-mythweb-0.21_pre13285
diff --git a/www-apps/mythweb/mythweb-0.21_pre13285.ebuild b/www-apps/mythweb/mythweb-0.21_pre13285.ebuild
new file mode 100644
index 000000000000..97219d7cb59f
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.21_pre13285.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.21_pre13285.ebuild,v 1.1 2007/04/20 18:46:24 cardoe Exp $
+
+inherit mythtv webapp depend.php
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+S="${WORKDIR}/mythplugins-${MY_PV}/${PN}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if has_version 'dev-lang/php' ; then
+ require_php_with_use session mysql pcre posix
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/.."
+ mythtv-fixes_patch
+ cd "${S}"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README TODO
+
+ dodir ${MY_HTDOCSDIR}/data
+
+ cp -R [[:lower:]]* .htaccess ${D}${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/data
+
+ webapp_configfile ${MY_HTDOCSDIR}/.htaccess
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-0.20.txt
+
+ webapp_src_install
+}