summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-21 08:41:24 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-21 08:41:24 +0000
commitdaaac208f8356c925a10ee96d6ae0a1c87f5636c (patch)
treee0fd0b76293ef2fc5fef79d066d5396d5b66822e /www-apache
parentVersion bump (diff)
downloadgentoo-2-daaac208f8356c925a10ee96d6ae0a1c87f5636c.tar.gz
gentoo-2-daaac208f8356c925a10ee96d6ae0a1c87f5636c.tar.bz2
gentoo-2-daaac208f8356c925a10ee96d6ae0a1c87f5636c.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/ChangeLog8
-rw-r--r--www-apache/passenger/files/passenger-3.0.8-gentoo.patch35
-rw-r--r--www-apache/passenger/passenger-3.0.8.ebuild82
3 files changed, 124 insertions, 1 deletions
diff --git a/www-apache/passenger/ChangeLog b/www-apache/passenger/ChangeLog
index c61502e084e5..449957dc80de 100644
--- a/www-apache/passenger/ChangeLog
+++ b/www-apache/passenger/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/passenger
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.36 2011/06/24 18:28:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.37 2011/08/21 08:41:24 graaff Exp $
+
+*passenger-3.0.8 (21 Aug 2011)
+
+ 21 Aug 2011; Hans de Graaff <graaff@gentoo.org> +passenger-3.0.8.ebuild,
+ +files/passenger-3.0.8-gentoo.patch:
+ Version bump.
24 Jun 2011; Hans de Graaff <graaff@gentoo.org> -passenger-3.0.2.ebuild:
Remove old version.
diff --git a/www-apache/passenger/files/passenger-3.0.8-gentoo.patch b/www-apache/passenger/files/passenger-3.0.8-gentoo.patch
new file mode 100644
index 000000000000..6ca33dd32812
--- /dev/null
+++ b/www-apache/passenger/files/passenger-3.0.8-gentoo.patch
@@ -0,0 +1,35 @@
+--- build/config.rb.~1~ 2010-10-01 12:22:34.000000000 +0200
++++ build/config.rb 2010-11-02 10:56:25.309314070 +0100
+@@ -17,12 +17,8 @@
+ OPTIMIZE = boolean_option("OPTIMIZE")
+ CC = string_option("CC", "gcc")
+ CXX = string_option("CXX", "g++")
+ # TODO: consider -fcommon
+-if OPTIMIZE
+- OPTIMIZATION_FLAGS = "#{PlatformInfo.debugging_cflags} -O2 -DBOOST_DISABLE_ASSERTS".strip
+-else
+- OPTIMIZATION_FLAGS = "#{PlatformInfo.debugging_cflags} -DPASSENGER_DEBUG -DBOOST_DISABLE_ASSERTS".strip
+-end
++OPTIMIZATION_FLAGS = "#{ENV['CXXFLAGS']} -DBOOST_DISABLE_ASSERTS".strip
+
+ # Extra compiler flags that should always be passed to the C/C++ compiler.
+ # Should be included last in the command string, even after PlatformInfo.portability_cflags.
+--- build/packaging.rb.~1~ 2010-10-10 20:52:03.000000000 +0200
++++ build/packaging.rb 2010-11-02 11:03:56.944938507 +0100
+@@ -87,13 +87,13 @@
+ require 'rbconfig'
+ require 'fileutils'
+ include Config
+- fakeroot = "pkg/fakeroot"
++ fakeroot = ENV['DISTDIR']
+
+ # We don't use CONFIG['archdir'] and the like because we want
+ # the files to be installed to /usr, and the Ruby interpreter
+ # on the packaging machine might be in /usr/local.
+- fake_libdir = "#{fakeroot}/usr/lib/ruby/#{CONFIG['ruby_version']}"
+- fake_native_support_dir = "#{fakeroot}/usr/lib/ruby/#{CONFIG['ruby_version']}/#{CONFIG['arch']}"
++ fake_libdir = "#{fakeroot}/#{CONFIG['sitedir']}/#{CONFIG['ruby_version']}"
++ fake_native_support_dir = "#{fakeroot}/#{CONFIG['sitedir']}/#{CONFIG['ruby_version']}/#{CONFIG['arch']}"
+ fake_agents_dir = "#{fakeroot}#{NATIVELY_PACKAGED_AGENTS_DIR}"
+ fake_helper_scripts_dir = "#{fakeroot}#{NATIVELY_PACKAGED_HELPER_SCRIPTS_DIR}"
+ fake_docdir = "#{fakeroot}#{NATIVELY_PACKAGED_DOCDIR}"
diff --git a/www-apache/passenger/passenger-3.0.8.ebuild b/www-apache/passenger/passenger-3.0.8.ebuild
new file mode 100644
index 000000000000..bcc9c478d6a0
--- /dev/null
+++ b/www-apache/passenger/passenger-3.0.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-3.0.8.ebuild,v 1.1 2011/08/21 08:41:24 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit apache-module flag-o-matic ruby-ng
+
+DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="http://modrails.com/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+ruby_add_rdepend "
+ >=dev-ruby/daemon_controller-0.2.5
+ >=dev-ruby/fastthread-1.0.1
+ >=dev-ruby/rack-1.0.0"
+
+CDEPEND=">=dev-libs/libev-3.90 net-misc/curl[ssl]"
+
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}
+ doc? ( >=app-text/asciidoc-8.6.5[highlight] )"
+
+APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+need_apache2_2
+
+pkg_setup() {
+ use debug && append-flags -DPASSENGER_DEBUG
+}
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.8-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-3.0.0-ldflags.patch
+
+ # Use sed here so that we can dynamically set the documentation directory.
+ sed -i -e "s:/usr/share/doc/phusion-passenger:/usr/share/doc/${P}:" \
+ -e "s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:" \
+ -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+ lib/phusion_passenger.rb || die
+ sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" ext/common/ResourceLocator.h || die
+
+ # Don't install a tool that won't work in our setup.
+ sed -i -e '/passenger-install-apache2-module/d' lib/phusion_passenger/packaging.rb || die
+ rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
+
+ # Make sure we use the system-provided version.
+ rm -rf ext/libev || die "Unable to remove vendored libev."
+}
+
+each_ruby_compile() {
+ append-flags -fno-strict-aliasing
+
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
+ rake apache2 native_support || die "rake failed"
+
+ if use doc; then
+ rake doc || die "rake doc failed"
+ fi
+}
+
+each_ruby_install() {
+ DISTDIR="${D}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
+ rake fakeroot || die "rake failed"
+
+ # TODO: this will create a mess when multiple RUBY_TARGETS have been
+ # selected.
+ APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
+ apache-module_src_install
+}