summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-27 00:22:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-27 00:22:22 +0000
commit4e83f939588bacc4e106e1dbab42d2d5f8397ec7 (patch)
tree9deaf99951d421e92eea6680a3c7040942d15440 /www-apache/mod_mono/mod_mono-2.6.ebuild
parentFixed dependency formatting (see Documentation/CODE in kde overlay for refere... (diff)
downloadgentoo-2-4e83f939588bacc4e106e1dbab42d2d5f8397ec7.tar.gz
gentoo-2-4e83f939588bacc4e106e1dbab42d2d5f8397ec7.tar.bz2
gentoo-2-4e83f939588bacc4e106e1dbab42d2d5f8397ec7.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_mono/mod_mono-2.6.ebuild')
-rw-r--r--www-apache/mod_mono/mod_mono-2.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/www-apache/mod_mono/mod_mono-2.6.ebuild b/www-apache/mod_mono/mod_mono-2.6.ebuild
new file mode 100644
index 000000000000..7fe366af360c
--- /dev/null
+++ b/www-apache/mod_mono/mod_mono-2.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_mono/mod_mono-2.6.ebuild,v 1.1 2010/02/27 00:22:22 patrick Exp $
+
+EAPI=2
+
+# DRAGONS: Watch the order of these.
+
+inherit apache-module multilib eutils go-mono mono
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="Apache module for Mono."
+HOMEPAGE="http://www.go-mono.com/"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="aspnet2 debug"
+
+DEPEND="=dev-dotnet/xsp-${GO_MONO_REL_PV}*"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="2.2/70_${PN}"
+APACHE2_MOD_DEFINE="MONO"
+
+DOCFILES="AUTHORS ChangeLog COPYING INSTALL NEWS README"
+
+need_apache2
+
+src_prepare() {
+ sed -e "s:@LIBDIR@:$(get_libdir):" "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
+ > "${WORKDIR}/${APACHE2_MOD_CONF##*/}.conf" || die
+ go-mono_src_prepare
+ use aspnet2 && epatch "${FILESDIR}/mono_auto_application_aspnet2.patch"
+}
+
+src_configure() {
+ export LIBS="$(pkg-config --libs apr-1)"
+ go-mono_src_configure \
+ $(use_enable debug) \
+ --with-apxs="${APXS}" \
+ --with-apr-config="/usr/bin/apr-1-config" \
+ --with-apu-config="/usr/bin/apu-1-config" \
+ || die "econf failed"
+}
+src_compile() {
+ go-mono_src_compile
+}
+
+src_install() {
+ go-mono_src_install
+ find "${D}" -name 'mod_mono.conf' -delete || die "failed to remove mod_mono.conf"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${WORKDIR}/${APACHE2_MOD_CONF##*/}.conf" "${APACHE2_MOD_CONF##*/}.conf" \
+ || die "internal ebuild error: '${FILESDIR}/${APACHE2_MOD_CONF}.conf' not found"
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+
+ elog "To enable mod_mono, add \"-D MONO\" to your Apache's"
+ elog "conf.d configuration file. Additionally, to view sample"
+ elog "ASP.NET applications, add \"-D MONO_DEMO\" too."
+ elog ""
+ elog "If you want mod_mono to handle AutoHosting requests using"
+ elog "ASP.NET 2.0 engine, enable the aspnet2 USE flag."
+}