summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-09-30 19:40:46 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-09-30 19:40:46 +0000
commitb494c5ffdaa1a8c856c390828179bc6f784b15d8 (patch)
treea13078c7f5fe3f3228650ef7c9277635dda8f07c /sys-process
parentLinux patch 3.12.29 (diff)
downloadgentoo-2-b494c5ffdaa1a8c856c390828179bc6f784b15d8.tar.gz
gentoo-2-b494c5ffdaa1a8c856c390828179bc6f784b15d8.tar.bz2
gentoo-2-b494c5ffdaa1a8c856c390828179bc6f784b15d8.zip
Fix ncurses linking, bug 509452
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog6
-rw-r--r--sys-process/htop/files/htop-1.0.3-tinfo.patch62
-rw-r--r--sys-process/htop/htop-1.0.3.ebuild4
3 files changed, 70 insertions, 2 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 6714071bf28e..0c7c44ebb0fc 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.141 2014/05/02 23:05:38 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.142 2014/09/30 19:40:46 idl0r Exp $
+
+ 30 Sep 2014; Christian Ruppert <idl0r@gentoo.org> htop-1.0.3.ebuild,
+ +files/htop-1.0.3-tinfo.patch:
+ Fix ncurses linking, bug 509452
*htop-1.0.3 (02 May 2014)
diff --git a/sys-process/htop/files/htop-1.0.3-tinfo.patch b/sys-process/htop/files/htop-1.0.3-tinfo.patch
new file mode 100644
index 000000000000..62a887baf376
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.3-tinfo.patch
@@ -0,0 +1,62 @@
+diff --git a/Makefile.am b/Makefile.am
+index 820e2e5..85f49e9 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,6 +36,8 @@ SUFFIXES = .h
+ BUILT_SOURCES = $(myhtopheaders)
+ htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h
+
++htop_LDADD = $(NCURSES_LIBS)
++
+ profile:
+ $(MAKE) all CFLAGS="-pg" AM_CPPFLAGS="-pg -O2 -DNDEBUG"
+
+diff --git a/configure.ac b/configure.ac
+index 2b934e8..3593885 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,6 +20,7 @@ AM_PROG_CC_C_O
+ AC_DISABLE_SHARED
+ AC_ENABLE_STATIC
+ AC_PROG_LIBTOOL
++PKG_PROG_PKG_CONFIG
+
+ # Checks for libraries.
+ AC_CHECK_LIB([m], [ceil], [], [missing_libraries="$missing_libraries libm"])
+@@ -89,20 +90,24 @@ fi
+
+ AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
+ if test "x$enable_unicode" = xyes; then
+- AC_CHECK_LIB([ncursesw], [refresh], [], [
+- missing_libraries="$missing_libraries libncursesw"
+- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ PKG_CHECK_MODULES([NCURSES], [ncursesw],[
++ AC_CHECK_LIB([ncursesw], [refresh], [], [
++ missing_libraries="$missing_libraries libncursesw"
++ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ ])
++ AC_CHECK_HEADERS([ncursesw/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
+ ])
+- AC_CHECK_HEADERS([ncursesw/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
+ else
+- AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
+- AC_CHECK_HEADERS([curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
++ PKG_CHECK_MODULES([NCURSES], [ncurses],[
++ AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
++ AC_CHECK_HEADERS([curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
++ ])
+ fi
+
+ if test ! -z "$missing_libraries"; then
diff --git a/sys-process/htop/htop-1.0.3.ebuild b/sys-process/htop/htop-1.0.3.ebuild
index ac68b51452e6..1ce6aa99a1d6 100644
--- a/sys-process/htop/htop-1.0.3.ebuild
+++ b/sys-process/htop/htop-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.3.ebuild,v 1.1 2014/05/02 23:05:38 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.3.ebuild,v 1.2 2014/09/30 19:40:46 idl0r Exp $
EAPI=5
@@ -29,6 +29,8 @@ CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
# config.h problems
AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=("${FILESDIR}/${P}-tinfo.patch")
+
pkg_setup() {
if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
echo