summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-03-16 16:53:46 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-03-16 16:53:46 +0000
commit67f82ef2bbb0eb7edcb49fa1030898975227bc7a (patch)
tree8c5a31ff74744a01d666d17d47e3e5f3bc6a74d0 /sys-process
parentFix bug #408231. Set RDEPEND. Move preparation stuff to src_prepare(). Respec... (diff)
downloadgentoo-2-67f82ef2bbb0eb7edcb49fa1030898975227bc7a.tar.gz
gentoo-2-67f82ef2bbb0eb7edcb49fa1030898975227bc7a.tar.bz2
gentoo-2-67f82ef2bbb0eb7edcb49fa1030898975227bc7a.zip
Fixed parallel make issue (bug #408375)
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/ChangeLog6
-rw-r--r--sys-process/at/at-3.1.13-r1.ebuild4
-rw-r--r--sys-process/at/files/at-3.1.13-parallel-make-fix.patch11
3 files changed, 19 insertions, 2 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index f72b81f3eef7..b6df0dcc3791 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/at
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.38 2012/03/13 23:17:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.39 2012/03/16 16:53:46 polynomial-c Exp $
+
+ 16 Mar 2012; Lars Wendler <polynomial-c@gentoo.org> at-3.1.13-r1.ebuild,
+ +files/at-3.1.13-parallel-make-fix.patch:
+ Fixed parallel make issue (bug #408375).
13 Mar 2012; Jeroen Roovers <jer@gentoo.org> at-3.1.13-r1.ebuild:
Stable for HPPA (bug #407947).
diff --git a/sys-process/at/at-3.1.13-r1.ebuild b/sys-process/at/at-3.1.13-r1.ebuild
index e593202f3eb6..381829914b48 100644
--- a/sys-process/at/at-3.1.13-r1.ebuild
+++ b/sys-process/at/at-3.1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13-r1.ebuild,v 1.7 2012/03/13 23:17:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13-r1.ebuild,v 1.8 2012/03/16 16:53:46 polynomial-c Exp $
EAPI=4
@@ -34,6 +34,8 @@ src_prepare() {
# fix parallel make issues, bug #244884
epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
epatch "${FILESDIR}"/${P}-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
eautoconf
}
diff --git a/sys-process/at/files/at-3.1.13-parallel-make-fix.patch b/sys-process/at/files/at-3.1.13-parallel-make-fix.patch
new file mode 100644
index 000000000000..dec02e42310c
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-parallel-make-fix.patch
@@ -0,0 +1,11 @@
+--- at-3.1.13_orig/Makefile.in 2011-06-25 14:43:14.000000000 +0200
++++ at-3.1.13/Makefile.in 2012-03-16 17:23:26.210267660 +0100
+@@ -73,7 +73,7 @@
+ atd: $(RUNOBJECTS)
+ $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
+
+-y.tab.c y.tab.h: parsetime.y
++%.tab.c %.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+ lex.yy.c: parsetime.l