summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-29 17:52:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-29 17:52:59 +0000
commit5ca371b52496fd46254cf705095e87fd7520bf74 (patch)
tree2b9002948d17591b3827e99367e7e92e02beb22b /sys-process
parentapp-crypt/aesutil: Cleanup ebuild, add myself as maintainer. Add to crypto herd. (diff)
downloadgentoo-2-5ca371b52496fd46254cf705095e87fd7520bf74.tar.gz
gentoo-2-5ca371b52496fd46254cf705095e87fd7520bf74.tar.bz2
gentoo-2-5ca371b52496fd46254cf705095e87fd7520bf74.zip
Version bump (bug #361105).
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop/ChangeLog8
-rw-r--r--sys-process/iotop/iotop-0.4.3.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-process/iotop/ChangeLog b/sys-process/iotop/ChangeLog
index 3740cf5a8cc2..c86cb886be10 100644
--- a/sys-process/iotop/ChangeLog
+++ b/sys-process/iotop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/iotop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.42 2011/03/22 11:13:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.43 2011/03/29 17:52:59 arfrever Exp $
+
+*iotop-0.4.3 (29 Mar 2011)
+
+ 29 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +iotop-0.4.3.ebuild:
+ Version bump (bug #361105).
*iotop-0.4.2 (22 Mar 2011)
diff --git a/sys-process/iotop/iotop-0.4.3.ebuild b/sys-process/iotop/iotop-0.4.3.ebuild
new file mode 100644
index 000000000000..1011c1ad88c7
--- /dev/null
+++ b/sys-process/iotop/iotop-0.4.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.4.3.ebuild,v 1.1 2011/03/29 17:52:59 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils linux-info
+
+DESCRIPTION="Iotop has a top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="http://guichaz.free.fr/iotop//files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+DOCS="NEWS README THANKS"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ doman iotop.1 || die "doman failed"
+}