summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-09-14 18:07:07 +0000
committerRick Farina <zerochaos@gentoo.org>2012-09-14 18:07:07 +0000
commita165bd508135e6b40b0417ef521498efa308cc33 (patch)
tree02e196e37594bcaf90c02da56362dd529b217750 /sys-power
parentinclude www-misc/torbrowser-profile in the www-client/torbrowser mask (diff)
downloadgentoo-2-a165bd508135e6b40b0417ef521498efa308cc33.tar.gz
gentoo-2-a165bd508135e6b40b0417ef521498efa308cc33.tar.bz2
gentoo-2-a165bd508135e6b40b0417ef521498efa308cc33.zip
my attempt to clarify kconfig requirements, and adjust SND_HDA stuff based on complain in bug 434824
(Portage version: 2.1.11.16/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog6
-rw-r--r--sys-power/powertop/powertop-2.1-r1.ebuild28
2 files changed, 29 insertions, 5 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index cdebf934cc84..595aff631754 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.64 2012/09/14 14:24:15 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.65 2012/09/14 18:07:07 zerochaos Exp $
+
+ 14 Sep 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild:
+ my attempt to clarify kconfig requirements, and adjust SND_HDA stuff based on
+ complain in bug 434824
14 Sep 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild:
make kconfig checks non-fatal to accomodate builders who don't use powertop
diff --git a/sys-power/powertop/powertop-2.1-r1.ebuild b/sys-power/powertop/powertop-2.1-r1.ebuild
index b9518d2e7b83..d8e32ff6bbfd 100644
--- a/sys-power/powertop/powertop-2.1-r1.ebuild
+++ b/sys-power/powertop/powertop-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.4 2012/09/14 14:24:15 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.5 2012/09/14 18:07:07 zerochaos Exp $
EAPI="4"
@@ -40,7 +40,9 @@ DOCS=( TODO README )
pkg_setup() {
einfo "Warning: enabling all suggested kconfig params may have performance impacts"
- CONFIG_CHECK="
+ linux_config_exists
+ linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK="~SND_HDA_POWER_SAVE"
+ CONFIG_CHECK+="
~X86_MSR
~DEBUG_FS
~PERF_EVENTS
@@ -52,12 +54,30 @@ pkg_setup() {
~CPU_FREQ_GOV_ONDEMAND
~SND_HDA_POWER_SAVE
~USB_SUSPEND
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
~TIMER_STATS
~EVENT_POWER_TRACING_DEPRECATED
~TRACING
"
- ewarn "If you see any warning about missing kernel config options"
- ewarn "your bug will most likely be ignored. Thanks in advance."
+ einfo "Below are likely critical failures:"
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ einfo "Below are warnings only, however bugs may be ignored if you don't enable full support in the kernel:"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
linux-info_pkg_setup
}