summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-29 09:44:10 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-29 09:44:10 +0000
commit66dd206ae2bcdb27df285c6ead8341c49c2bda94 (patch)
treeb7a62b45ba3beea2bba058959a12a8e8c58055df /sys-kernel
parentDrop broken PIE from older version. (diff)
downloadgentoo-2-66dd206ae2bcdb27df285c6ead8341c49c2bda94.tar.gz
gentoo-2-66dd206ae2bcdb27df285c6ead8341c49c2bda94.tar.bz2
gentoo-2-66dd206ae2bcdb27df285c6ead8341c49c2bda94.zip
Pull in linux/types.h in linux/serial.h #252721.
(Portage version: 2.2_rc18/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/ChangeLog8
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.28-r1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 27b171100c7f..6ee9f4d146c9 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.278 2008/12/27 11:14:16 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.279 2008/12/29 09:44:09 vapier Exp $
+
+*linux-headers-2.6.28-r1 (29 Dec 2008)
+
+ 29 Dec 2008; Mike Frysinger <vapier@gentoo.org>
+ +linux-headers-2.6.28-r1.ebuild:
+ Pull in linux/types.h in linux/serial.h #252721.
27 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
linux-headers-2.6.28.ebuild:
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.28-r1.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.28-r1.ebuild
new file mode 100644
index 000000000000..ced55922dadb
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-2.6.28-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.28-r1.ebuild,v 1.1 2008/12/29 09:44:10 vapier Exp $
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arm cris hppa m68k mips ia64 ppc ppc64 s390 sh sparc x86"
+inherit kernel-2
+detect_version
+
+PATCH_VER="2"
+SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.lzma"
+[[ -n ${PATCH_VER} ]] && SRC_URI="${SRC_URI} mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.lzma"
+
+KEYWORDS="-* ~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh -sparc ~x86"
+
+DEPEND="app-arch/lzma-utils"
+RDEPEND=""
+
+S=${WORKDIR}/gentoo-headers-base-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+ # workaround #244640
+ mkdir arch/sparc64
+ touch arch/sparc64/Makefile
+}
+
+src_install() {
+ kernel-2_src_install
+ cd "${D}"
+ egrep -r \
+ -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
+ -e '\<([us](8|16|32|64))\>' \
+ .
+ headers___fix $(find -type f)
+
+ egrep -l -r -e '__[us](8|16|32|64)' "${D}" | xargs grep -L linux/types.h
+
+ # hrm, build system sucks
+ find "${D}" '(' -name '.install' -o -name '*.cmd' ')' -print0 | xargs -0 rm -f
+
+ # provided by libdrm (for now?)
+ rm -rf "${D}"/usr/include/drm
+}
+
+src_test() {
+ emake ARCH=$(tc-arch-kernel) headers_check || die
+}