summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2011-11-09 08:19:21 +0000
committerStratos Psomadakis <psomas@gentoo.org>2011-11-09 08:19:21 +0000
commitdac6359ff525772e5086dc9f1f2db0897d3a5c8f (patch)
tree29213c206f37b8dfa92942ed4a1715c51716a687 /sys-kernel/rt-sources
parentand another header as well (diff)
downloadgentoo-2-dac6359ff525772e5086dc9f1f2db0897d3a5c8f.tar.gz
gentoo-2-dac6359ff525772e5086dc9f1f2db0897d3a5c8f.tar.bz2
gentoo-2-dac6359ff525772e5086dc9f1f2db0897d3a5c8f.zip
Version bump
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/ChangeLog8
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.0.8_p23.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index 6396d3fac2b9..aa20a54e4753 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.5 2011/11/08 09:07:24 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.6 2011/11/09 08:19:21 psomas Exp $
+
+*rt-sources-3.0.8_p23 (09 Nov 2011)
+
+ 09 Nov 2011; Stratos Psomadakis <psomas@gentoo.org>
+ +rt-sources-3.0.8_p23.ebuild:
+ Version bump
*rt-sources-3.0.8_p22 (08 Nov 2011)
diff --git a/sys-kernel/rt-sources/rt-sources-3.0.8_p23.ebuild b/sys-kernel/rt-sources/rt-sources-3.0.8_p23.ebuild
new file mode 100644
index 000000000000..dcf904256141
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.0.8_p23.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".gz"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+
+CKV="$(get_version_component_range 1-3)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+RT_PATCHSET="${PV/*_p}"
+RT_KERNEL="${PV/_p[0-9]*}"
+RT_KERNEL="${RT_KERNEL/_/-}"
+RT_FILE="patch-${RT_KERNEL}-rt${RT_PATCHSET}.patch${COMPRESSTYPE}"
+RT_URI="http://dev.gentoo.org/~psomas/${RT_FILE}"
+
+DESCRIPTION="Real-time patchset for the Linux Kernel"
+HOMEPAGE="https://tglx.de/~tglx/rt/"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="deblob"
+
+KV_FULL="${PVR/_p/-rt}"
+EXTRAVERSION="-rt${RT_PATCHSET}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${RT_FILE}"
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."