summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-16 23:48:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-16 23:48:36 +0000
commit35e7e08b44226f02c62f30cddbc9714a79806b86 (patch)
treedfff67d132c55d0d71c568dcdfa31401692786ae /sys-kernel/amd-ucode
parentx86 stable per bug 351745 (diff)
downloadgentoo-2-35e7e08b44226f02c62f30cddbc9714a79806b86.tar.gz
gentoo-2-35e7e08b44226f02c62f30cddbc9714a79806b86.tar.bz2
gentoo-2-35e7e08b44226f02c62f30cddbc9714a79806b86.zip
Add an ebuild to install AMD's CPUs microcode which can be loaded directly by the kernel.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/amd-ucode')
-rw-r--r--sys-kernel/amd-ucode/ChangeLog11
-rw-r--r--sys-kernel/amd-ucode/amd-ucode-2011.01.11.ebuild54
-rw-r--r--sys-kernel/amd-ucode/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/sys-kernel/amd-ucode/ChangeLog b/sys-kernel/amd-ucode/ChangeLog
new file mode 100644
index 000000000000..0b8b84ed9cce
--- /dev/null
+++ b/sys-kernel/amd-ucode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-kernel/amd-ucode
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/amd-ucode/ChangeLog,v 1.1 2011/01/16 23:48:36 flameeyes Exp $
+
+*amd-ucode-2011.01.11 (16 Jan 2011)
+
+ 16 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +amd-ucode-2011.01.11.ebuild, +metadata.xml:
+ Add an ebuild to install AMD's CPUs microcode which can be loaded directly by
+ the kernel.
+
diff --git a/sys-kernel/amd-ucode/amd-ucode-2011.01.11.ebuild b/sys-kernel/amd-ucode/amd-ucode-2011.01.11.ebuild
new file mode 100644
index 000000000000..806acfece42d
--- /dev/null
+++ b/sys-kernel/amd-ucode/amd-ucode-2011.01.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/amd-ucode/amd-ucode-2011.01.11.ebuild,v 1.1 2011/01/16 23:48:36 flameeyes Exp $
+
+inherit versionator linux-info
+
+MY_P="${PN}-$(replace_all_version_separators -)"
+
+DESCRIPTION="AMD Family 10h, 11h and 14h microcode patch data"
+HOMEPAGE="http://www.amd64.org/support/microcode.html"
+SRC_URI="http://www.amd64.org/pub/microcode/${MY_P}.tar"
+
+LICENSE="amd-ucode"
+SLOT="0"
+IUSE=""
+
+# only meaningful for x86 and x86-64
+KEYWORDS="-* ~amd64 ~x86"
+
+# The license does not allow us to mirror the content.
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~MICROCODE_AMD"
+ERROR_MICROCODE_AMD="Your kernel needs to support AMD microcode loading. You're suggested to build it as a module as it doesn't require a reboot to reload the microcode, that way."
+
+src_install() {
+ insinto /lib/firmware/amd-ucode
+ doins microcode_amd.bin || die
+
+ # INSTALL file also has instructions to load it, so install it as
+ # part of the documentation.
+ dodoc README INSTALL || die
+}
+
+pkg_postinst() {
+ elog "The microcode will be updated next time the microcode kernel code"
+ elog "will be executed; you can issue the following command to force a"
+ elog "reload, if you built the support as modules:"
+ elog ""
+ elog " modprobe -r microcode && modprobe microcode"
+ elog ""
+ elog "If you didn't build the microcode support as a module, you should"
+ elog "rebuild your kernel with the new microcode embedded."
+
+ if linux_config_exists && ! linux_chkconfig_module MICROCODE; then
+ ewarn ""
+ ewarn "You're suggested to build CPU microcode update support as module"
+ ewarn "as there is currently no automatic way to load in the updated"
+ ewarn "microcode when it is built-in in the kernel."
+ ewarn ""
+ fi
+}
diff --git a/sys-kernel/amd-ucode/metadata.xml b/sys-kernel/amd-ucode/metadata.xml
new file mode 100644
index 000000000000..2d083ce3bc66
--- /dev/null
+++ b/sys-kernel/amd-ucode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>