summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Edgar <rocket@gentoo.org>2005-04-04 19:22:43 +0000
committerEric Edgar <rocket@gentoo.org>2005-04-04 19:22:43 +0000
commitb57253d918365a8324dee8506cab2a8841b3c3af (patch)
treeb309cd9a0d75231182b8252cb9455ff35e4c77c3 /sys-fs/lvm2/lvm2-2.00.33-r4.ebuild
parentStable x86. (diff)
downloadgentoo-2-b57253d918365a8324dee8506cab2a8841b3c3af.tar.gz
gentoo-2-b57253d918365a8324dee8506cab2a8841b3c3af.tar.bz2
gentoo-2-b57253d918365a8324dee8506cab2a8841b3c3af.zip
Adding digests to cvs
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-fs/lvm2/lvm2-2.00.33-r4.ebuild')
-rw-r--r--sys-fs/lvm2/lvm2-2.00.33-r4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/lvm2/lvm2-2.00.33-r4.ebuild b/sys-fs/lvm2/lvm2-2.00.33-r4.ebuild
new file mode 100644
index 000000000000..5f0a80034b59
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.00.33-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.00.33-r4.ebuild,v 1.1 2005/04/04 19:22:43 rocket Exp $
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ppc64 ~alpha ~hppa"
+IUSE="readline nolvmstatic"
+
+DEPEND=">=sys-fs/device-mapper-1.00.17"
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+ use nolvmstatic || myconf="--enable-static_link"
+
+ econf $(use_enable readline) ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin" staticdir="${D}/sbin" confdir="${D}/etc/lvm"
+ mv -f "${D}/sbin/lvm.static" "${D}/sbin/lvm"
+
+ dodoc COPYING* INSTALL README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh lvm-start.sh
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh
+}