summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-27 00:51:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-27 00:51:55 +0000
commit4ccebef654d67099949c389d2a26ec845e5d88a8 (patch)
tree7eb5158ca285428daa7dd4917612e5b1143869eb /sys-devel/patch
parenttaking over as maintainer as well (diff)
downloadgentoo-2-4ccebef654d67099949c389d2a26ec845e5d88a8.tar.gz
gentoo-2-4ccebef654d67099949c389d2a26ec845e5d88a8.tar.bz2
gentoo-2-4ccebef654d67099949c389d2a26ec845e5d88a8.zip
sync fixes with 2.5.9-r1
(Portage version: 2.1_pre2)
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild32
1 files changed, 10 insertions, 22 deletions
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index 05480c391221..2b8f6af87818 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.23 2005/03/04 04:52:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.24 2005/12/27 00:51:55 vapier Exp $
inherit flag-o-matic
@@ -19,30 +19,18 @@ DEPEND=""
src_compile() {
strip-flags
- CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
- # workaround for hardened on amd64, 1st part
- if use amd64 && is-ldflags -pie; then
- einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
- filter-ldflags -pie
- append-flags -fPIC
- LDFLAGS_PIE="1"
- fi
- ac_cv_sys_long_file_names=yes \
- ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- # workaround for hardened on amd64, 2nd part
- if [ "${LDFLAGS_PIE}" = "1" ]; then
- einfo "Patching Makefile..."
- sed -i -e 's/^LDFLAGS =/& -pie/' Makefile || die "Patching Makefile failed!"
- fi
+ append-flags -DLINUX -D_XOPEN_SOURCE=500
use static && append-ldflags -static
- emake LDFLAGS="${LDFLAGS}" || die "emake failed"
+
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ ac_cv_sys_long_file_names=yes econf ${myconf} || die
+
+ emake || die "emake failed"
}
src_install() {
einstall || die
- if ! use build ; then
- dodoc AUTHORS ChangeLog NEWS README
- else
- rm -rf ${D}/usr/share/man
- fi
+ dodoc AUTHORS ChangeLog NEWS README
+ use build && rm -r "${D}"/usr/share
}