summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-03-22 16:28:14 +0000
committerPeter Volkov <pva@gentoo.org>2011-03-22 16:28:14 +0000
commitdedabcac7605bd2e0463543cffb6a73d981a888c (patch)
treed305d427a430a7f17366331be540750220d9f279 /sys-cluster
parentAdd lambda patch back (diff)
downloadgentoo-2-dedabcac7605bd2e0463543cffb6a73d981a888c.tar.gz
gentoo-2-dedabcac7605bd2e0463543cffb6a73d981a888c.tar.bz2
gentoo-2-dedabcac7605bd2e0463543cffb6a73d981a888c.zip
Version bump, bug 350806 thank Fabian Fingerle for report and Dennis Schridde for initial work. Sync 9999 ebuild. Drop unused.
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog11
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.24.1-r1.ebuild93
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.26.2.ebuild (renamed from sys-cluster/vzctl/vzctl-3.0.24.ebuild)15
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild19
4 files changed, 25 insertions, 113 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 6279e7a699e9..04b8154af326 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/vzctl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.73 2010/09/10 07:46:45 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.74 2011/03/22 16:28:14 pva Exp $
+
+*vzctl-3.0.26.2 (22 Mar 2011)
+
+ 22 Mar 2011; Peter Volkov <pva@gentoo.org> -vzctl-3.0.24.ebuild,
+ -vzctl-3.0.24.1-r1.ebuild, +vzctl-3.0.26.2.ebuild, vzctl-9999.ebuild:
+ Version bump, bug 350806 thank Fabian Fingerle for report and Dennis Schridde
+ for initial work. Sync 9999 ebuild. Drop unused.
*vzctl-3.0.24.2 (10 Sep 2010)
diff --git a/sys-cluster/vzctl/vzctl-3.0.24.1-r1.ebuild b/sys-cluster/vzctl/vzctl-3.0.24.1-r1.ebuild
deleted file mode 100644
index 4964990d32d5..000000000000
--- a/sys-cluster/vzctl/vzctl-3.0.24.1-r1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.24.1-r1.ebuild,v 1.1 2010/08/30 11:55:45 pva Exp $
-
-EAPI="2"
-
-inherit bash-completion eutils
-
-DESCRIPTION="OpenVZ ConTainers control utility"
-HOMEPAGE="http://openvz.org/"
-SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
-IUSE="bash-completion"
-
-RDEPEND="
- net-firewall/iptables
- sys-apps/ed
- sys-apps/iproute2
- sys-fs/vzquota
- virtual/cron"
-
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- # Set default OSTEMPLATE on gentoo
- sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
- epatch "${FILESDIR}/${P}-vzpostup.patch"
-}
-
-src_configure() {
- econf \
- --localstatedir=/var \
- --enable-cron \
- --enable-udev \
- $(use_enable bash-completion bashcomp) \
- --enable-logrotate
-}
-
-src_install() {
- make DESTDIR="${D}" install install-gentoo || die "make install failed"
-
- # install the bash-completion script into the right location
- rm -rf "${D}"/etc/bash_completion.d
- dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
-
- # We need to keep some dirs
- keepdir /vz/{dump,lock,root,private,template/cache}
- keepdir /etc/vz/names /var/lib/vzctl/veip
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- local conf_without_OSTEMPLATE
- for file in \
- $(find "${ROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
- if ! grep '^OSTEMPLATE' $file > /dev/null; then
- conf_without_OSTEMPLATE+=" $file"
- fi
- done
-
- if [[ -n ${conf_without_OSTEMPLATE} ]]; then
- ewarn
- ewarn "OSTEMPLATE default was changed from redhat-like to gentoo."
- ewarn "This means that any VEID.conf files without explicit or correct"
- ewarn "OSTEMPLATE set will use gentoo scripts instead of redhat."
- ewarn "Please check the following configs:"
- for file in ${conf_without_OSTEMPLATE}; do
- ewarn "${file}"
- done
- ewarn
- fi
-
- ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
- ewarn "following code to /etc/conf.d/net:"
- ewarn " postup() {"
- ewarn " /usr/sbin/vzifup-post \${IFACE}"
- ewarn " }"
-
- elog "NOTE: Starting with vzctl-3.0.22 the mechanism for choosing the"
- elog "interfaces to send ARP requests to has been improved (see description"
- elog "of NEIGHBOUR_DEVS in vz.conf(5) man page). In case CT IP addresses"
- elog "are not on the same subnet as HN IPs, it may lead to such CTs being"
- elog "unreachable from the outside world."
- elog
- elog "The solution is to set up a device route(s) for the network your CTs are"
- elog "in. For more details, see http://bugzilla.openvz.org/show_bug.cgi?id=771#c1"
- elog
- elog "The old vzctl behavior can be restored by setting NEIGHBOUR_DEVS to any"
- elog 'value other than "detect" in /etc/vz/vz.conf.'
-}
diff --git a/sys-cluster/vzctl/vzctl-3.0.24.ebuild b/sys-cluster/vzctl/vzctl-3.0.26.2.ebuild
index 698b2261b592..662eda570dbd 100644
--- a/sys-cluster/vzctl/vzctl-3.0.24.ebuild
+++ b/sys-cluster/vzctl/vzctl-3.0.26.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.24.ebuild,v 1.2 2010/07/02 15:11:05 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.26.2.ebuild,v 1.1 2011/03/22 16:28:14 pva Exp $
-EAPI="2"
+EAPI="4"
inherit bash-completion eutils
@@ -32,18 +32,17 @@ src_prepare() {
src_configure() {
econf \
--localstatedir=/var \
- --enable-cron \
--enable-udev \
$(use_enable bash-completion bashcomp) \
--enable-logrotate
}
src_install() {
- make DESTDIR="${D}" install install-gentoo || die "make install failed"
+ emake DESTDIR="${D}" install install-gentoo
# install the bash-completion script into the right location
- rm -rf "${D}"/etc/bash_completion.d
- dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+ rm -rf "${ED}"/etc/bash_completion.d
+ dobashcompletion etc/bash_completion.d/vzctl.sh vzctl
# We need to keep some dirs
keepdir /vz/{dump,lock,root,private,template/cache}
@@ -54,7 +53,7 @@ pkg_postinst() {
bash-completion_pkg_postinst
local conf_without_OSTEMPLATE
for file in \
- $(find "${ROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ $(find "${EROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
if ! grep '^OSTEMPLATE' $file > /dev/null; then
conf_without_OSTEMPLATE+=" $file"
fi
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
index 9739686ed99d..878f72541c08 100644
--- a/sys-cluster/vzctl/vzctl-9999.ebuild
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.5 2010/06/29 09:26:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.6 2011/03/22 16:28:14 pva Exp $
-EAPI="2"
+EAPI="4"
inherit bash-completion autotools git
@@ -33,18 +33,17 @@ src_prepare() {
src_configure() {
econf \
--localstatedir=/var \
- --enable-cron \
--enable-udev \
- --enable-logrotate \
- $(use_enable bash-completion bashcomp)
+ $(use_enable bash-completion bashcomp) \
+ --enable-logrotate
}
src_install() {
- make DESTDIR="${D}" install install-gentoo || die "make install failed"
+ emake DESTDIR="${D}" install install-gentoo
# install the bash-completion script into the right location
- rm -rf "${D}"/etc/bash_completion.d
- dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+ rm -rf "${ED}"/etc/bash_completion.d
+ dobashcompletion etc/bash_completion.d/vzctl.sh vzctl
# We need to keep some dirs
keepdir /vz/{dump,lock,root,private,template/cache}
@@ -55,7 +54,7 @@ pkg_postinst() {
bash-completion_pkg_postinst
local conf_without_OSTEMPLATE
for file in \
- $(find "${ROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ $(find "${EROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
if ! grep '^OSTEMPLATE' $file > /dev/null; then
conf_without_OSTEMPLATE+=" $file"
fi