summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-01-27 18:24:46 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-01-27 18:24:46 +0000
commit713a6df6cfdcf14ee0d47512d53c3a263c2d339c (patch)
tree846de233a134fad08cba1150ae1ff3b8756d86f4 /sys-cluster
parentUpdate HOMEPAGE, bug 537928. Update ebuild to EAPI 5. Specify LICENSE more pr... (diff)
downloadgentoo-2-713a6df6cfdcf14ee0d47512d53c3a263c2d339c.tar.gz
gentoo-2-713a6df6cfdcf14ee0d47512d53c3a263c2d339c.tar.bz2
gentoo-2-713a6df6cfdcf14ee0d47512d53c3a263c2d339c.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/libquo/ChangeLog7
-rw-r--r--sys-cluster/libquo/libquo-1.2.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-cluster/libquo/ChangeLog b/sys-cluster/libquo/ChangeLog
index 1f2ae4bc05e0..60ccecacab09 100644
--- a/sys-cluster/libquo/ChangeLog
+++ b/sys-cluster/libquo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/libquo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libquo/ChangeLog,v 1.2 2015/01/06 21:56:20 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libquo/ChangeLog,v 1.3 2015/01/27 18:24:46 ottxor Exp $
+
+*libquo-1.2.3 (27 Jan 2015)
+
+ 27 Jan 2015; Christoph Junghans <ottxor@gentoo.org> +libquo-1.2.3.ebuild:
+ version bump
*libquo-1.2.2 (06 Jan 2015)
diff --git a/sys-cluster/libquo/libquo-1.2.3.ebuild b/sys-cluster/libquo/libquo-1.2.3.ebuild
new file mode 100644
index 000000000000..f9cb6b2c0aa9
--- /dev/null
+++ b/sys-cluster/libquo/libquo-1.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libquo/libquo-1.2.3.ebuild,v 1.1 2015/01/27 18:24:46 ottxor Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/losalamos/${PN}.git http://github.com/losalamos/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="http://losalamos.github.io/${PN}/dists/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="run-time tuning of process binding policies made easy"
+HOMEPAGE="http://losalamos.github.io/libquo/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="fortran static-libs"
+
+DEPEND="
+ virtual/mpi[fortran?]
+ sys-process/numactl
+ sys-apps/hwloc[numa,xml]
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-utils_src_configure CC=mpicc FC=$(usex fortran mpif90 false)
+}