summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Smirnov <civil@gentoo.org>2014-04-09 21:39:01 +0000
committerVladimir Smirnov <civil@gentoo.org>2014-04-09 21:39:01 +0000
commit0a5703eb08390eed37a356743aa4f538867b0707 (patch)
treea324342ca252928fe4c08e821ff30e59ae057760 /sys-cluster/ploop
parentbump stable patches, fix bug #505714, XSA-89 (diff)
downloadgentoo-2-0a5703eb08390eed37a356743aa4f538867b0707.tar.gz
gentoo-2-0a5703eb08390eed37a356743aa4f538867b0707.tar.bz2
gentoo-2-0a5703eb08390eed37a356743aa4f538867b0707.zip
Version bump, requested by proxy maintainer
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xA832680F)
Diffstat (limited to 'sys-cluster/ploop')
-rw-r--r--sys-cluster/ploop/ChangeLog7
-rw-r--r--sys-cluster/ploop/ploop-1.11.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-cluster/ploop/ChangeLog b/sys-cluster/ploop/ChangeLog
index 37407e6015f8..2db633140e89 100644
--- a/sys-cluster/ploop/ChangeLog
+++ b/sys-cluster/ploop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ploop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.26 2014/01/14 13:58:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.27 2014/04/09 21:39:01 civil Exp $
+
+*ploop-1.11 (09 Apr 2014)
+
+ 09 Apr 2014; Vladimir Smirnov <civil@gentoo.org> +ploop-1.11.ebuild:
+ Version bump, requested by proxy maintainer
14 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ploop-1.9.ebuild:
Stable for x86, wrt bug #495946
diff --git a/sys-cluster/ploop/ploop-1.11.ebuild b/sys-cluster/ploop/ploop-1.11.ebuild
new file mode 100644
index 000000000000..3719d156cfd1
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.11.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.11.ebuild,v 1.1 2014/04/09 21:39:01 civil Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="
+ dev-libs/libxml2
+ virtual/pkgconfig
+ "
+
+RDEPEND="dev-libs/libxml2
+ !<sys-cluster/vzctl-4.5
+ sys-block/parted
+ sys-fs/e2fsprogs
+ sys-process/lsof
+ sys-apps/findutils
+ "
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+}
+
+pkg_postinst() {
+ elog "Warning - API changes"
+ elog "1. This version requires running vzkernel >= 2.6.32-042stab79.5 and vzctl-4.5 ot above"
+ elog "2. DiskDescriptor.xml created by older ploop versions will be converted to new format"
+ elog "3. If you have use --diskquota parameter on gentoo CT, please install sys-fs/quota on CT. "
+ elog "[3] is gentoo specific messages (due to stage3 not contain quota tools) "
+ elog ""
+ elog ""
+ elog "If you use OpenRC init system, please add tmpfiles.setup service in boot runlevel"
+ elog "Otherwise, openvz container won't work properly!"
+
+}