summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-24 10:07:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-24 10:07:41 +0000
commit9c426f6492028f70866dd3b55fb5b40959799c3c (patch)
tree74f14900542aec599abf341bbce4860388607126 /sys-auth
parentversion bump. 4.0 is still beta, so use 3.7 in production. this is a security... (diff)
downloadgentoo-2-9c426f6492028f70866dd3b55fb5b40959799c3c.tar.gz
gentoo-2-9c426f6492028f70866dd3b55fb5b40959799c3c.tar.bz2
gentoo-2-9c426f6492028f70866dd3b55fb5b40959799c3c.zip
USE="static-libs" and convert to prune_libtool_files() function. Remove -Werror from AM_INIT_AUTOMAKE for compability with sys-devel/automake >= 1.12 wrt #423255 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libyubikey/ChangeLog9
-rw-r--r--sys-auth/libyubikey/libyubikey-1.6.ebuild23
2 files changed, 21 insertions, 11 deletions
diff --git a/sys-auth/libyubikey/ChangeLog b/sys-auth/libyubikey/ChangeLog
index 77e21b750cb8..a5671c3fcc6d 100644
--- a/sys-auth/libyubikey/ChangeLog
+++ b/sys-auth/libyubikey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/libyubikey
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libyubikey/ChangeLog,v 1.1 2010/10/23 16:38:54 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libyubikey/ChangeLog,v 1.2 2012/06/24 10:07:41 ssuominen Exp $
+
+ 24 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> libyubikey-1.6.ebuild:
+ USE="static-libs" and convert to prune_libtool_files() function. Remove
+ -Werror from AM_INIT_AUTOMAKE for compability with sys-devel/automake >= 1.12
+ wrt #423255 by Diego Elio Pettenò.
*libyubikey-1.6 (23 Oct 2010)
diff --git a/sys-auth/libyubikey/libyubikey-1.6.ebuild b/sys-auth/libyubikey/libyubikey-1.6.ebuild
index 9c3c3fe21c03..e2b29e96dc1d 100644
--- a/sys-auth/libyubikey/libyubikey-1.6.ebuild
+++ b/sys-auth/libyubikey/libyubikey-1.6.ebuild
@@ -1,26 +1,31 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libyubikey/libyubikey-1.6.ebuild,v 1.1 2010/10/23 16:38:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libyubikey/libyubikey-1.6.ebuild,v 1.2 2012/06/24 10:07:41 ssuominen Exp $
-EAPI=2
-inherit eutils autotools
+EAPI=4
+inherit autotools eutils
DESCRIPTION="Yubico C low-level library"
-SRC_URI="http://yubico-c.googlecode.com/files/${P}.tar.gz"
HOMEPAGE="http://code.google.com/p/yubico-c/"
+SRC_URI="http://yubico-c.googlecode.com/files/${P}.tar.gz"
KEYWORDS="~amd64"
SLOT="0"
LICENSE="BSD-2"
-IUSE=""
+IUSE="static-libs"
src_prepare() {
epatch "${FILESDIR}"/${P}-rpath.patch
+ sed -i -e '/AM_INIT_AUTOMAKE/s: -Werror::' configure.ac || die #423255
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS || die
- find "${D}" -name '*.la' -delete || die
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ prune_libtool_files
}