summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-09 20:25:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-09 20:25:26 +0000
commitd68576cc1692f24a481e8ba520152e3707a205d0 (patch)
tree8ba4160cb8e328642e1fcfe6eb91ec8d6ec4687f /sys-apps
parentVersion bump mercurial to 2.5.1. (diff)
downloadgentoo-2-d68576cc1692f24a481e8ba520152e3707a205d0.tar.gz
gentoo-2-d68576cc1692f24a481e8ba520152e3707a205d0.tar.bz2
gentoo-2-d68576cc1692f24a481e8ba520152e3707a205d0.zip
Version bump; this version generates thw hwdb.bin file straight in the package, rather than in postinst, so that the file is no longer orphaned.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key D4301342)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog9
-rw-r--r--sys-apps/hwids/hwids-20130209.1.ebuild (renamed from sys-apps/hwids/hwids-20130131.ebuild)19
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild21
3 files changed, 19 insertions, 30 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 9820e65c8411..ee8a1db65fca 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.79 2013/02/07 19:18:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.80 2013/02/09 20:25:26 flameeyes Exp $
+
+*hwids-20130209.1 (09 Feb 2013)
+
+ 09 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20130209.1.ebuild,
+ -hwids-20130131.ebuild, hwids-99999999.ebuild:
+ Version bump; this version generates thw hwdb.bin file straight in the
+ package, rather than in postinst, so that the file is no longer orphaned.
07 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
-hwids-20130131-r1.ebuild, hwids-99999999.ebuild:
diff --git a/sys-apps/hwids/hwids-20130131.ebuild b/sys-apps/hwids/hwids-20130209.1.ebuild
index ae3c4d397d2c..dcc74f3bb888 100644
--- a/sys-apps/hwids/hwids-20130131.ebuild
+++ b/sys-apps/hwids/hwids-20130209.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130131.ebuild,v 1.1 2013/01/31 16:04:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130209.1.ebuild,v 1.1 2013/02/09 20:25:26 flameeyes Exp $
EAPI=5
inherit udev eutils
@@ -14,7 +14,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux"
IUSE="+udev"
-DEPEND="udev? ( dev-lang/perl !=sys-fs/udev-196 )"
+DEPEND="udev? (
+ dev-lang/perl
+ >=virtual/udev-197-r1
+)"
RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"
@@ -31,15 +34,3 @@ src_install() {
HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
DESTDIR="${D}"
}
-
-pkg_postinst() {
- # until udev introduces a way to compile the database at a given
- # location, rather than just /, we can't do much on offset root.
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
- fi
-
- if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
- udevadm hwdb --update
- fi
-}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index f97a8d6ea109..a600f6ba5693 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.17 2013/02/07 19:18:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.18 2013/02/09 20:25:26 flameeyes Exp $
EAPI=5
inherit udev eutils git-2
@@ -14,8 +14,11 @@ SLOT="0"
KEYWORDS=""
IUSE="+udev"
-DEPEND="net-misc/curl
- udev? ( dev-lang/perl )"
+DEPEND="udev? (
+ net-misc/curl
+ dev-lang/perl
+ >=virtual/udev-197-r1
+)"
RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"
@@ -34,15 +37,3 @@ src_install() {
HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
DESTDIR="${D}"
}
-
-pkg_postinst() {
- # until udev introduces a way to compile the database at a given
- # location, rather than just /, we can't do much on offset root.
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
- fi
-
- if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
- udevadm hwdb --update
- fi
-}