summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-02 22:25:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-02 22:25:55 +0000
commit2a0db10ddebf6c2871d3e9151c412c105db0a05c (patch)
tree6edb15289328364024e260be8b38de639d3d6373 /sys-apps/x86info
parentTaking direct maintainership. (diff)
downloadgentoo-2-2a0db10ddebf6c2871d3e9151c412c105db0a05c.tar.gz
gentoo-2-2a0db10ddebf6c2871d3e9151c412c105db0a05c.tar.bz2
gentoo-2-2a0db10ddebf6c2871d3e9151c412c105db0a05c.zip
Version bump #103577 by Ulrich Mueller.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog7
-rw-r--r--sys-apps/x86info/files/digest-x86info-1.151
-rw-r--r--sys-apps/x86info/x86info-1.15.ebuild48
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 1a7e3fff3c52..5b2aedb668ce 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.8 2005/08/24 00:33:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.9 2005/09/02 22:25:55 vapier Exp $
+
+*x86info-1.15 (02 Sep 2005)
+
+ 02 Sep 2005; Mike Frysinger <vapier@gentoo.org> +x86info-1.15.ebuild:
+ Version bump #103577 by Ulrich Mueller.
*x86info-1.14 (24 Aug 2005)
diff --git a/sys-apps/x86info/files/digest-x86info-1.15 b/sys-apps/x86info/files/digest-x86info-1.15
new file mode 100644
index 000000000000..ef7177c5f7ac
--- /dev/null
+++ b/sys-apps/x86info/files/digest-x86info-1.15
@@ -0,0 +1 @@
+MD5 9707e11ee1727f940fb2dd6fb3033037 x86info-1.15.tgz 51448
diff --git a/sys-apps/x86info/x86info-1.15.ebuild b/sys-apps/x86info/x86info-1.15.ebuild
new file mode 100644
index 000000000000..9948c5a8442e
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.15.ebuild,v 1.1 2005/09/02 22:25:55 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.12b-pic.patch
+}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info
+
+ dodoc TODO README ChangeLog
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}