summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-30 12:22:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-30 12:22:44 +0000
commita4d4134fde6a5d9f7833c26f57d1d5868ae624e6 (patch)
treec704d2ed36de134162793cae07fe17b6ca6093e0 /sys-apps/roccat-tools
parentAdd new roccat devices by Dmitry Pisklov. Bug #492810 (diff)
downloadgentoo-2-a4d4134fde6a5d9f7833c26f57d1d5868ae624e6.tar.gz
gentoo-2-a4d4134fde6a5d9f7833c26f57d1d5868ae624e6.tar.bz2
gentoo-2-a4d4134fde6a5d9f7833c26f57d1d5868ae624e6.zip
Version bump by Dmitry Pisklov <dpisklov@gmail.com>. Bug #492810
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'sys-apps/roccat-tools')
-rw-r--r--sys-apps/roccat-tools/ChangeLog9
-rw-r--r--sys-apps/roccat-tools/files/README.gentoo3
-rw-r--r--sys-apps/roccat-tools/roccat-tools-1.0.0.ebuild72
-rw-r--r--sys-apps/roccat-tools/roccat-tools-1.1.0.ebuild72
4 files changed, 155 insertions, 1 deletions
diff --git a/sys-apps/roccat-tools/ChangeLog b/sys-apps/roccat-tools/ChangeLog
index ad3ecb9c0dea..0f7192bbe46a 100644
--- a/sys-apps/roccat-tools/ChangeLog
+++ b/sys-apps/roccat-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/roccat-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.2 2013/09/09 02:28:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.3 2013/11/30 12:22:44 hwoarang Exp $
+
+*roccat-tools-1.1.0 (30 Nov 2013)
+*roccat-tools-1.0.0 (30 Nov 2013)
+
+ 30 Nov 2013; Markos Chandras <hwoarang@gentoo.org> +roccat-tools-1.0.0.ebuild,
+ +roccat-tools-1.1.0.ebuild, files/README.gentoo:
+ Version bump by Dmitry Pisklov <dpisklov@gmail.com>. Bug #492810
09 Sep 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Fix maintainer spelling
diff --git a/sys-apps/roccat-tools/files/README.gentoo b/sys-apps/roccat-tools/files/README.gentoo
index 8f1b3a974674..55bc7407e314 100644
--- a/sys-apps/roccat-tools/files/README.gentoo
+++ b/sys-apps/roccat-tools/files/README.gentoo
@@ -12,3 +12,6 @@ To allow udev to detect your device without reboot, run
* and replace the group name with your choice.
* In addition, you need to enable CONFIG_INPUT_UINPUT in your kernel
+
+* Do a logout/login to apply your new group ownership and replug your device
+* and everything should work as expected.
diff --git a/sys-apps/roccat-tools/roccat-tools-1.0.0.ebuild b/sys-apps/roccat-tools/roccat-tools-1.0.0.ebuild
new file mode 100644
index 000000000000..25bb8347be4a
--- /dev/null
+++ b/sys-apps/roccat-tools/roccat-tools-1.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-1.0.0.ebuild,v 1.1 2013/11/30 12:22:44 hwoarang Exp $
+
+EAPI=5
+
+inherit readme.gentoo cmake-utils gnome2-utils udev
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_INPUT_DEVICES="
+ input_devices_roccat_arvo
+ input_devices_roccat_isku
+ input_devices_roccat_iskufx
+ input_devices_roccat_kone
+ input_devices_roccat_koneplus
+ input_devices_roccat_konepure
+ input_devices_roccat_konepureoptical
+ input_devices_roccat_konextd
+ input_devices_roccat_kovaplus
+ input_devices_roccat_lua
+ input_devices_roccat_pyra
+ input_devices_roccat_savu
+ input_devices_roccat_ryos
+"
+IUSE="${IUSE_INPUT_DEVICES}"
+
+REQUIRED_USE="input_devices_roccat_konextd? ( input_devices_roccat_koneplus )"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+ virtual/udev[gudev]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local UDEVDIR="$(udev_get_udevdir)"/rules.d
+ local MODELS=${INPUT_DEVICES//roccat_/}
+ mycmakeargs=( -DDEVICES=${MODELS// /;} \
+ -DUDEVDIR="${UDEVDIR/"//"//}" )
+ cmake-utils_src_configure
+}
+src_install() {
+ cmake-utils_src_install
+ local stat_dir=/var/lib/roccat
+ keepdir $stat_dir
+ fowners root:roccat $stat_dir
+ fperms 2770 $stat_dir
+ readme.gentoo_src_install
+}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst() {
+ enewgroup roccat
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sys-apps/roccat-tools/roccat-tools-1.1.0.ebuild b/sys-apps/roccat-tools/roccat-tools-1.1.0.ebuild
new file mode 100644
index 000000000000..614c919ca551
--- /dev/null
+++ b/sys-apps/roccat-tools/roccat-tools-1.1.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-1.1.0.ebuild,v 1.1 2013/11/30 12:22:44 hwoarang Exp $
+
+EAPI=5
+
+inherit readme.gentoo cmake-utils gnome2-utils udev
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_INPUT_DEVICES="
+ input_devices_roccat_arvo
+ input_devices_roccat_isku
+ input_devices_roccat_iskufx
+ input_devices_roccat_kone
+ input_devices_roccat_koneplus
+ input_devices_roccat_konepure
+ input_devices_roccat_konepureoptical
+ input_devices_roccat_konextd
+ input_devices_roccat_kovaplus
+ input_devices_roccat_lua
+ input_devices_roccat_pyra
+ input_devices_roccat_savu
+ input_devices_roccat_ryos
+"
+IUSE="${IUSE_INPUT_DEVICES}"
+
+REQUIRED_USE="input_devices_roccat_konextd? ( input_devices_roccat_koneplus )"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ media-libs/libcanberra
+ virtual/libusb:1
+ dev-libs/dbus-glib
+ virtual/udev[gudev]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local UDEVDIR="$(udev_get_udevdir)"/rules.d
+ local MODELS=${INPUT_DEVICES//roccat_/}
+ mycmakeargs=( -DDEVICES=${MODELS// /;} \
+ -DUDEVDIR="${UDEVDIR/"//"//}" )
+ cmake-utils_src_configure
+}
+src_install() {
+ cmake-utils_src_install
+ local stat_dir=/var/lib/roccat
+ keepdir $stat_dir
+ fowners root:roccat $stat_dir
+ fperms 2770 $stat_dir
+ readme.gentoo_src_install
+}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst() {
+ enewgroup roccat
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}