summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2006-02-08 19:09:59 +0000
committerJoel Martin <kanaka@gentoo.org>2006-02-08 19:09:59 +0000
commit418b92368e33a87f02839bd5bbd56ff8d1fd64d5 (patch)
tree1adab95c40ad5ff9fda183eb1e3db86fc4cfac03 /sys-apps/pciutils
parentModified patchset to work with useflag bigpatch (See bug #122100) (diff)
downloadgentoo-2-418b92368e33a87f02839bd5bbd56ff8d1fd64d5.tar.gz
gentoo-2-418b92368e33a87f02839bd5bbd56ff8d1fd64d5.tar.bz2
gentoo-2-418b92368e33a87f02839bd5bbd56ff8d1fd64d5.zip
Do not strip in makefile, this break cross-compile.
(Portage version: 2.0.53)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/Manifest2
-rw-r--r--sys-apps/pciutils/pciutils-2.2.0-r1.ebuild6
3 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 1b5fa916e512..27e10fd69882 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pciutils
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.69 2005/12/24 15:41:00 hansmi Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.70 2006/02/08 19:09:59 kanaka Exp $
+
+ 08 Feb 2006; Joel Martin <kanaka@gentoo.org> pciutils-2.2.0-r1.ebuild:
+ Do not strip in makefile, this break cross-compile.
24 Dec 2005; Michael Hanselmann <hansmi@gentoo.org>
pciutils-2.2.0-r1.ebuild:
diff --git a/sys-apps/pciutils/Manifest b/sys-apps/pciutils/Manifest
index 038601c19e52..5763d0a7bb86 100644
--- a/sys-apps/pciutils/Manifest
+++ b/sys-apps/pciutils/Manifest
@@ -11,4 +11,4 @@ MD5 f4d220c568a00c1ceafe6dc129ae6e95 files/pciutils-2.1.11-sysfs.patch 10374
MD5 cf455fe33057e081ba7aaec93e481642 files/pciutils-2.2.0-shared-lib.patch 496
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 61778080ed55196416ece68570ba885a pciutils-2.1.11-r5.ebuild 2298
-MD5 9eb53d5c8c8a991b6df900cdead1e8bc pciutils-2.2.0-r1.ebuild 1657
+MD5 f83f0dfd0ac32913c960480d553c3aef pciutils-2.2.0-r1.ebuild 1779
diff --git a/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
index 72e427e2989d..38ff9dd11135 100644
--- a/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
+++ b/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.11 2005/12/24 15:41:00 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.12 2006/02/08 19:09:59 kanaka Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -26,9 +26,11 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
# Set Gentoo paths
+ # and do not strip (breaks cross-compile), portage handles stripping
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e '/^IDSDIR=/s:=.*:=$(PREFIX)/share/misc:' \
+ -e '/INSTALL.* -s lspci /s: -s lspci : lspci :' \
Makefile || die
# Make sure we respect $AR / $RANLIB