summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-10-19 22:04:02 +0000
committerZack Welch <zwelch@gentoo.org>2002-10-19 22:04:02 +0000
commit981eccaf303f5f9fa4db3d56d06369aebd8accf1 (patch)
treee9c2b5a54b40243a24cb5fce371262b3b927d605 /sys-apps/hotplug
parentnew ebuild. (diff)
downloadgentoo-2-981eccaf303f5f9fa4db3d56d06369aebd8accf1.tar.gz
gentoo-2-981eccaf303f5f9fa4db3d56d06369aebd8accf1.tar.bz2
gentoo-2-981eccaf303f5f9fa4db3d56d06369aebd8accf1.zip
Fixes bug 8074 in new ebuild 20020401-r1. Also adds new ebuild
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/ChangeLog16
-rw-r--r--sys-apps/hotplug/files/hotplug-20020401-net.agent-gentoo.diff48
-rw-r--r--sys-apps/hotplug/files/hotplug-20020401-usb.agent-gentoo.diff14
-rw-r--r--sys-apps/hotplug/files/hotplug-20020826-net.agent-gentoo.diff48
-rw-r--r--sys-apps/hotplug/files/hotplug-20020826-usb.agent-gentoo.diff14
5 files changed, 135 insertions, 5 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 72719aadd45e..c8bb59b8f5c5 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,8 +1,17 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.5 2002/08/11 13:22:59 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.6 2002/10/19 22:04:02 zwelch Exp $
-*hotplug-200200401 (5 May 2002)
+*hotplug-20020826 (18 Oct 2002)
+ 18 Oct 2002; Zach Welch <zwelch@gentoo.org> hotplug-20020826.build :
+ New version; includes gentoo agent fixes in hotplug-20020401-r1
+
+*hotplug-20020401-r1 (18 Oct 2002)
+
+ 18 Oct 2002; Zach Welch <zwelch@gentoo.org> hotplug-20020401-r1.ebuild :
+ Fixed bug 8074. Fix similar bug in usb.agent. Bump ebuild rev!!
+
+*hotplug-20020401 (5 May 2002)
11 Aug 2002; phoen][x <phoenix@gentoo.org> hotplug-20020401.ebuild :
Fixed bug 6183.
@@ -12,11 +21,9 @@
14 Jul 2002; phoen][x <phoenix@gentoo.org> hotplug-20020401.ebuild :
Added KEYWORDS, SLOT.
-
New version
11 May 2002; Wout Mertens <wmertens@gentoo.org> files/hotplug.rc :
-
Fixed error condition detection
*hotplug-20020114 (24 Feb 2002)
@@ -25,6 +32,5 @@
Added KEYWORDS, SLOT.
24 Feb 2002; Bruce A. Locke <blocke@shivan.org> hotplug-20020114.ebuild :
-
Hotplug ebuild contributed by folokai@earthlink.net (Scott Worley)
diff --git a/sys-apps/hotplug/files/hotplug-20020401-net.agent-gentoo.diff b/sys-apps/hotplug/files/hotplug-20020401-net.agent-gentoo.diff
new file mode 100644
index 000000000000..638f48f3ab8f
--- /dev/null
+++ b/sys-apps/hotplug/files/hotplug-20020401-net.agent-gentoo.diff
@@ -0,0 +1,48 @@
+diff -auNr hotplug-2002_08_26-orig/etc/hotplug/net.agent hotplug-2002_08_26/etc/hotplug/net.agent
+--- hotplug-2002_08_26-orig/etc/hotplug/net.agent 2001-09-19 17:14:00.000000000 -0700
++++ hotplug-2002_08_26/etc/hotplug/net.agent 2002-10-18 11:58:57.000000000 -0700
+@@ -40,8 +40,12 @@
+ # we can't do much here without distro-specific knowledge
+ # such as whether/how to invoke DHCP, set up bridging, etc.
+
++ # handle gentoo init script style
++ if [ -x /etc/init.d/net.$INTERFACE ]; then
++ debug_mesg invoke /etc/init.d/net.$INTERFACE start
++ exec /etc/init.d/net.$INTERFACE start
+ # RedHat and similar
+- if [ -x /sbin/ifup ]; then
++ elif [ -x /sbin/ifup ]; then
+ debug_mesg invoke ifup $INTERFACE
+ exec /sbin/ifup $INTERFACE
+ else
+@@ -52,6 +56,30 @@
+ mesg $1 $ACTION event not handled
+ ;;
+
++unregister)
++ case $INTERFACE in
++ # interfaces that are unregistered after being "down" (?)
++ ppp*|ippp*|isdn*|plip*|lo*|irda*)
++ debug_mesg assuming $INTERFACE is already down
++ exit 0
++ ;;
++ *)
++ # handle gentoo init script style
++ if [ -x /etc/init.d/net.$INTERFACE ]; then
++ debug_mesg invoke /etc/init.d/net.$INTERFACE stop
++ exec /etc/init.d/net.$INTERFACE stop
++ # RedHat and similar
++ elif [ -x /sbin/ifdown ]; then
++ debug_mesg invoke ifdown $INTERFACE
++ exec /sbin/ifdown $INTERFACE
++ else
++ mesg "how do I bring interfaces down on this distro?"
++ fi
++ ;;
++ esac
++ mesg $1 $ACTION event not handled
++ ;;
++
+ *)
+ debug_mesg NET $ACTION event not supported
+ exit 1 ;;
diff --git a/sys-apps/hotplug/files/hotplug-20020401-usb.agent-gentoo.diff b/sys-apps/hotplug/files/hotplug-20020401-usb.agent-gentoo.diff
new file mode 100644
index 000000000000..a756ba7d335f
--- /dev/null
+++ b/sys-apps/hotplug/files/hotplug-20020401-usb.agent-gentoo.diff
@@ -0,0 +1,14 @@
+diff -auNr hotplug-2002_08_26-orig/etc/hotplug/usb.agent hotplug-2002_08_26/etc/hotplug/usb.agent
+--- hotplug-2002_08_26-orig/etc/hotplug/usb.agent 2002-08-13 14:59:32.000000000 -0700
++++ hotplug-2002_08_26/etc/hotplug/usb.agent 2002-10-18 14:26:22.000000000 -0700
+@@ -56,8 +57,8 @@
+ # $Id: hotplug-20020401-usb.agent-gentoo.diff,v 1.1 2002/10/19 22:04:02 zwelch Exp $
+ #
+
+-if [ -f /etc/sysconfig/usb ]; then
+- . /etc/sysconfig/usb
++if [ -f /etc/conf.d/usb ]; then
++ . /etc/conf.d/usb
+ fi
+
+ cd /etc/hotplug
diff --git a/sys-apps/hotplug/files/hotplug-20020826-net.agent-gentoo.diff b/sys-apps/hotplug/files/hotplug-20020826-net.agent-gentoo.diff
new file mode 100644
index 000000000000..638f48f3ab8f
--- /dev/null
+++ b/sys-apps/hotplug/files/hotplug-20020826-net.agent-gentoo.diff
@@ -0,0 +1,48 @@
+diff -auNr hotplug-2002_08_26-orig/etc/hotplug/net.agent hotplug-2002_08_26/etc/hotplug/net.agent
+--- hotplug-2002_08_26-orig/etc/hotplug/net.agent 2001-09-19 17:14:00.000000000 -0700
++++ hotplug-2002_08_26/etc/hotplug/net.agent 2002-10-18 11:58:57.000000000 -0700
+@@ -40,8 +40,12 @@
+ # we can't do much here without distro-specific knowledge
+ # such as whether/how to invoke DHCP, set up bridging, etc.
+
++ # handle gentoo init script style
++ if [ -x /etc/init.d/net.$INTERFACE ]; then
++ debug_mesg invoke /etc/init.d/net.$INTERFACE start
++ exec /etc/init.d/net.$INTERFACE start
+ # RedHat and similar
+- if [ -x /sbin/ifup ]; then
++ elif [ -x /sbin/ifup ]; then
+ debug_mesg invoke ifup $INTERFACE
+ exec /sbin/ifup $INTERFACE
+ else
+@@ -52,6 +56,30 @@
+ mesg $1 $ACTION event not handled
+ ;;
+
++unregister)
++ case $INTERFACE in
++ # interfaces that are unregistered after being "down" (?)
++ ppp*|ippp*|isdn*|plip*|lo*|irda*)
++ debug_mesg assuming $INTERFACE is already down
++ exit 0
++ ;;
++ *)
++ # handle gentoo init script style
++ if [ -x /etc/init.d/net.$INTERFACE ]; then
++ debug_mesg invoke /etc/init.d/net.$INTERFACE stop
++ exec /etc/init.d/net.$INTERFACE stop
++ # RedHat and similar
++ elif [ -x /sbin/ifdown ]; then
++ debug_mesg invoke ifdown $INTERFACE
++ exec /sbin/ifdown $INTERFACE
++ else
++ mesg "how do I bring interfaces down on this distro?"
++ fi
++ ;;
++ esac
++ mesg $1 $ACTION event not handled
++ ;;
++
+ *)
+ debug_mesg NET $ACTION event not supported
+ exit 1 ;;
diff --git a/sys-apps/hotplug/files/hotplug-20020826-usb.agent-gentoo.diff b/sys-apps/hotplug/files/hotplug-20020826-usb.agent-gentoo.diff
new file mode 100644
index 000000000000..7d7ea5957f00
--- /dev/null
+++ b/sys-apps/hotplug/files/hotplug-20020826-usb.agent-gentoo.diff
@@ -0,0 +1,14 @@
+diff -auNr hotplug-2002_08_26-orig/etc/hotplug/usb.agent hotplug-2002_08_26/etc/hotplug/usb.agent
+--- hotplug-2002_08_26-orig/etc/hotplug/usb.agent 2002-08-13 14:59:32.000000000 -0700
++++ hotplug-2002_08_26/etc/hotplug/usb.agent 2002-10-18 14:26:22.000000000 -0700
+@@ -57,8 +57,8 @@
+ # $Id: hotplug-20020826-usb.agent-gentoo.diff,v 1.1 2002/10/19 22:04:02 zwelch Exp $
+ #
+
+-if [ -f /etc/sysconfig/usb ]; then
+- . /etc/sysconfig/usb
++if [ -f /etc/conf.d/usb ]; then
++ . /etc/conf.d/usb
+ fi
+
+ cd /etc/hotplug