summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-07 05:55:00 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-07 05:55:00 +0000
commitb13865d3948cd7c302db0bb261e82062fde3533a (patch)
tree13ee6560c79aed7823f4a2a7c6f5d20a141310f2 /sys-apps/groff
parentAdapt to changes in pexpect and pytest: drop pypy2_0 support, #491404 (diff)
downloadgentoo-2-b13865d3948cd7c302db0bb261e82062fde3533a.tar.gz
gentoo-2-b13865d3948cd7c302db0bb261e82062fde3533a.tar.bz2
gentoo-2-b13865d3948cd7c302db0bb261e82062fde3533a.zip
Fix parallel build with gropdf #487276 by Jimmy C. Chau.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog6
-rw-r--r--sys-apps/groff/files/groff-1.22.2-parallel-mom.patch96
-rw-r--r--sys-apps/groff/groff-1.22.2.ebuild3
3 files changed, 103 insertions, 2 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 4a50d4ed194c..23d44c8d6d77 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/groff
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.139 2013/10/09 17:11:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.140 2013/12/07 05:55:00 vapier Exp $
+
+ 07 Dec 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/groff-1.22.2-parallel-mom.patch, groff-1.22.2.ebuild:
+ Fix parallel build with gropdf #487276 by Jimmy C. Chau.
09 Oct 2013; Agostino Sarubbo <ago@gentoo.org> groff-1.22.2.ebuild:
Stable for sparc, wrt bug #386335
diff --git a/sys-apps/groff/files/groff-1.22.2-parallel-mom.patch b/sys-apps/groff/files/groff-1.22.2-parallel-mom.patch
new file mode 100644
index 000000000000..7cf3c22295d5
--- /dev/null
+++ b/sys-apps/groff/files/groff-1.22.2-parallel-mom.patch
@@ -0,0 +1,96 @@
+From 9f3af719383ab525c86ee0f514e268ef8494330a Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 6 Dec 2013 20:40:10 -0500
+Subject: [PATCH] fix parallel build w/gropdf and mom examples
+
+The contrib/mom/examples/ directory uses the helper script from
+src/devices/gropdf/. Currently though, parallel builds might fail
+like so:
+
+...
+make[2]: Entering directory `.../groff-1.22.2/contrib/mom'
+GROFF_COMMAND_PREFIX= GROFF_BIN_PATH="`echo .../groff-1.22.2/src/roff/groff .../groff-1.22.2/src/roff/troff .../groff-1.22.2/src/devices/grops .../groff-1.22.2/src/devices/gropdf | sed -e 's| *|:|g'`" PDFMOM_BIN_PATH=".../groff-1.22.2/src/devices/gropdf" .../groff-1.22.2/src/devices/gropdf/pdfmom -F.../groff-1.22.2/font -F.../groff-1.22.2/font -M.../groff-1.22.2/tmac -M.../groff-1.22.2/tmac -M. examples/letter.mom >examples/letter.pdf
+GROFF_COMMAND_PREFIX= GROFF_BIN_PATH="`echo .../groff-1.22.2/src/roff/groff .../groff-1.22.2/src/roff/troff .../groff-1.22.2/src/devices/grops .../groff-1.22.2/src/devices/gropdf | sed -e 's| *|:|g'`" PDFMOM_BIN_PATH=".../groff-1.22.2/src/devices/gropdf" .../groff-1.22.2/src/devices/gropdf/pdfmom -F.../groff-1.22.2/font -F.../groff-1.22.2/font -M.../groff-1.22.2/tmac -M.../groff-1.22.2/tmac -M. examples/mom-pdf.mom >examples/mom-pdf.pdf
+/bin/sh: .../groff-1.22.2/src/devices/gropdf/pdfmom: No such file or directory
+make[2]: *** [examples/letter.pdf] Error 127
+/bin/sh: .../groff-1.22.2/src/devices/gropdf/pdfmom: No such file or directory
+make[2]: *** [examples/mom-pdf.pdf] Error 127
+make[2]: Leaving directory `.../groff-1.22.2/contrib/mom'
+make[1]: *** [contrib/mom] Error 2
+...
+make[2]: Entering directory `.../groff-1.22.2/src/devices/gropdf'
+sed -f .../groff-1.22.2/arch/misc/shdeps.sed \
+ -e "s|@VERSION@|1.22.2|" \
+ -e "s|@PERLPATH@|/usr/bin/perl|" ./pdfmom.pl >pdfmom
+
+The top level makefile tries to account for this in general with OTHERDIRS,
+but looks like src/devices/gropdf/ was added to this variable (which holds
+contrib/mom/ too) because gropdf installs a shell script, and the other
+prog vars require it to be a dir of things to compile.
+
+Declare a new prog var for holding shell scripts.
+
+URL: http://crbug.com/324116
+URL: https://bugs.gentoo.org/487276
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+
+2013-12-06 Mike Frysinger <vapier@gentoo.org>
+
+ * Makefile.in (SHPROGDIRS): Declare.
+ (PROGDIRS): Add $(SHPROGDIRS).
+ (OTHERDIRS): Delete src/devices/gropdf.
+ ($(SHPROGDIRS):): Add to existing rule.
+ ($(OTHERDIRS):): Depend on $(SHPROGDIRS).
+---
+ Makefile.in | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index a794de7..8e478af 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -602,12 +602,15 @@ CCPROGDIRS=\
+ src/utils/addftinfo
+ CPROGDIRS=\
+ src/utils/pfbtops
++SHPROGDIRS=\
++ src/devices/gropdf
+ PROGDEPDIRS=\
+ arch/misc
+ PROGDIRS=\
+ $(PROGDEPDIRS) \
+ $(CCPROGDIRS) \
+ $(CPROGDIRS) \
++ $(SHPROGDIRS) \
+ $(XPROGDIRS)
+ DEVDIRS=\
+ font/devps \
+@@ -637,7 +640,6 @@ OTHERDIRS=\
+ contrib/glilypond \
+ contrib/hdtbl \
+ contrib/pdfmark \
+- src/devices/gropdf \
+ font/devpdf \
+ contrib/mom \
+ contrib/gdiffmk
+@@ -778,7 +780,7 @@ $(CCPROGDIRS): FORCE $(LIBDIRS)
+ -f $(top_srcdir)/Makefile.ccpg \
+ -f Makefile.dep $(do)
+
+-$(DEVDIRS) $(XDEVDIRS) $(OTHERDEVDIRS) $(TTYDEVDIRS): FORCE $(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS)
++$(DEVDIRS) $(XDEVDIRS) $(OTHERDEVDIRS) $(TTYDEVDIRS) $(SHPROGDIRS): FORCE $(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS)
+ @$(ENVSETUP); \
+ if test $(srcdir) = .; then \
+ srcdir=.; \
+@@ -809,7 +811,7 @@ $(GNULIBDIRS): FORCE
+ $(MAKE) ACLOCAL=: AUTOCONF=: AUTOHEADER=: AUTOMAKE=: $(do) ;; \
+ esac
+
+-$(OTHERDIRS): $(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS)
++$(OTHERDIRS): $(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS) $(SHPROGDIRS)
+
+ $(INCDIRS) $(PROGDEPDIRS) $(OTHERDIRS): FORCE
+ @$(ENVSETUP); \
+--
+1.8.4.3
+
diff --git a/sys-apps/groff/groff-1.22.2.ebuild b/sys-apps/groff/groff-1.22.2.ebuild
index 0758fd308d0b..fcfc31842ee4 100644
--- a/sys-apps/groff/groff-1.22.2.ebuild
+++ b/sys-apps/groff/groff-1.22.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.22.2.ebuild,v 1.10 2013/10/09 17:11:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.22.2.ebuild,v 1.11 2013/12/07 05:55:00 vapier Exp $
EAPI="4"
@@ -32,6 +32,7 @@ DOCS=( BUG-REPORT ChangeLog MORE.STUFF NEWS PROBLEMS PROJECTS README REVISION TO
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+ epatch "${FILESDIR}"/${PN}-1.22.2-parallel-mom.patch #487276
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then