summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-20 22:45:01 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-20 22:45:01 +0000
commit1c7fd2b1af46558717d8be4d0dad5cc6c12360e5 (patch)
treeb8d5dec001c5482df01c447d30312461e6c478ae /sci-visualization/spyview
parentVersion bump. Remove USE=doc for now as this would pull in many dependencies ... (diff)
downloadgentoo-2-1c7fd2b1af46558717d8be4d0dad5cc6c12360e5.tar.gz
gentoo-2-1c7fd2b1af46558717d8be4d0dad5cc6c12360e5.tar.bz2
gentoo-2-1c7fd2b1af46558717d8be4d0dad5cc6c12360e5.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/spyview')
-rw-r--r--sci-visualization/spyview/ChangeLog8
-rw-r--r--sci-visualization/spyview/spyview-20110803.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-visualization/spyview/ChangeLog b/sci-visualization/spyview/ChangeLog
index 2735d1627015..abc715d76bb9 100644
--- a/sci-visualization/spyview/ChangeLog
+++ b/sci-visualization/spyview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/spyview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.16 2011/07/13 20:12:30 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.17 2011/08/20 22:45:01 dilfridge Exp $
+
+*spyview-20110803 (20 Aug 2011)
+
+ 20 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +spyview-20110803.ebuild:
+ Version bump
13 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-spyview-20100810.ebuild:
diff --git a/sci-visualization/spyview/spyview-20110803.ebuild b/sci-visualization/spyview/spyview-20110803.ebuild
new file mode 100644
index 000000000000..a023b34f3cca
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20110803.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/spyview-20110803.ebuild,v 1.1 2011/08/20 22:45:01 dilfridge Exp $
+
+EAPI=4
+
+inherit base flag-o-matic eutils multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.42
+ media-libs/netpbm
+ media-libs/libpng:1.2
+ x11-libs/fltk:1
+ app-text/ghostscript-gpl
+ virtual/glu
+"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/spyview-2011-08-03-15_33
+
+src_prepare() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L$(dirname $(fltk-config --libs))
+
+ base_src_prepare
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview --docdir=/usr/share/doc/${PF}
+}