summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-17 18:02:42 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-17 18:02:42 +0000
commitc82143ca5a1b8b8c2327d49efc187fc7264d4c73 (patch)
tree44273d5f9b8f97bcfc9f676b79be3ba39042db83 /sci-physics
parentInitial import to the main tree from the science overlay (diff)
downloadgentoo-2-c82143ca5a1b8b8c2327d49efc187fc7264d4c73.tar.gz
gentoo-2-c82143ca5a1b8b8c2327d49efc187fc7264d4c73.tar.bz2
gentoo-2-c82143ca5a1b8b8c2327d49efc187fc7264d4c73.zip
New use flag to trigger external herwig library
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/cernlib-montecarlo/ChangeLog11
-rw-r--r--sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r2.ebuild (renamed from sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006.ebuild)52
-rw-r--r--sci-physics/cernlib-montecarlo/files/cernlib-montecarlo-2006-noherwig.pach52
-rw-r--r--sci-physics/cernlib-montecarlo/metadata.xml4
4 files changed, 89 insertions, 30 deletions
diff --git a/sci-physics/cernlib-montecarlo/ChangeLog b/sci-physics/cernlib-montecarlo/ChangeLog
index bab18bfabea7..f0ac414f8122 100644
--- a/sci-physics/cernlib-montecarlo/ChangeLog
+++ b/sci-physics/cernlib-montecarlo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/cernlib-montecarlo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/ChangeLog,v 1.5 2008/09/05 07:46:26 opfer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/ChangeLog,v 1.6 2009/04/17 18:02:42 bicatali Exp $
+
+*cernlib-montecarlo-2006-r2 (17 Apr 2009)
+
+ 17 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/cernlib-montecarlo-2006-noherwig.pach, metadata.xml,
+ -cernlib-montecarlo-2006.ebuild, +cernlib-montecarlo-2006-r2.ebuild:
+ New use flag to trigger external herwig library
05 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
cernlib-montecarlo-2006.ebuild:
diff --git a/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006.ebuild b/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r2.ebuild
index a8ab8cae75a9..2ab5a9d4a4eb 100644
--- a/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006.ebuild
+++ b/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r2.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006.ebuild,v 1.4 2008/09/05 07:46:26 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r2.ebuild,v 1.1 2009/04/17 18:02:42 bicatali Exp $
-inherit eutils multilib fortran
+EAPI=2
+inherit eutils toolchain-funcs
DEB_PN=mclibs
DEB_PV=${PV}.dfsg.2
-DEB_PR=1
+DEB_PR=5
DEB_P=${DEB_PN}_${DEB_PV}
DESCRIPTION="Monte-carlo library and tools for the cernlib"
@@ -17,12 +18,12 @@ SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE=""
+IUSE="+herwig"
RDEPEND="x11-libs/openmotif
- virtual/lapack
dev-lang/cfortran
- sci-physics/cernlib"
+ sci-physics/cernlib
+ herwig? ( !sci-physics/herwig )"
DEPEND="${RDEPEND}
virtual/latex-base
@@ -31,42 +32,37 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
-FORTRAN="gfortran g77 ifc"
-
-src_unpack() {
- unpack ${A}
- epatch "${DEB_P}-${DEB_PR}".diff
-
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${WORKDIR}/${DEB_P}-${DEB_PR}.diff"
cd "${S}"
cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
sed -i \
-e 's:/usr/local:/usr:g' \
Makefile || die "sed'ing the Makefile failed"
einfo "Applying Debian patches"
- emake -j1 \
- DEB_BUILD_OPTIONS="${FORTRANC} ${nostrip}" \
- patch || die "make patch failed"
+ emake -j1 patch || die "debian patch failed"
+
+ use herwig || epatch "${FILESDIR}"/${P}-noherwig.patch
# since we depend on cfortran, do not use the one from cernlib
- # (adapted from debian/cernlib-debian.mk)
- mv -f src/include/cfortran/cfortran.h \
- src/include/cfortran/cfortran.h.disabled
- # create local LaTeX cache directory
- mkdir -p .texmf-var
+ rm -f src/include/cfortran/cfortran.h
}
src_compile() {
- emake -j1 \
- DEB_BUILD_OPTIONS="${FORTRANC} nostrip" \
- || die "emake failed"
+ VARTEXFONTS="${T}"/fonts
+ emake -j1 cernlib-indep cernlib-arch || die "emake failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
}
src_install() {
- emake \
- DEB_BUILD_OPTIONS="${FORTRANC} nostrip" \
- DESTDIR="${D}" \
- install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
cd "${S}"/debian
dodoc changelog README.* deadpool.txt copyright || die "dodoc failed"
newdoc add-ons/README README.add-ons || die "newdoc failed"
diff --git a/sci-physics/cernlib-montecarlo/files/cernlib-montecarlo-2006-noherwig.pach b/sci-physics/cernlib-montecarlo/files/cernlib-montecarlo-2006-noherwig.pach
new file mode 100644
index 000000000000..d0cb42d1ba42
--- /dev/null
+++ b/sci-physics/cernlib-montecarlo/files/cernlib-montecarlo-2006-noherwig.pach
@@ -0,0 +1,52 @@
+diff --git a/mclibs-2006.dfsg.2.orig/Makefile b/mclibs-2006.dfsg.2.orig/Makefile
+index f3c89fd..780499e 100644
+--- a/mclibs-2006.dfsg.2.orig/Makefile
++++ b/mclibs-2006.dfsg.2.orig/Makefile
+@@ -89,9 +89,6 @@ install-includes:
+ done ; \
+ done
+
+- # install some symlinks, e.g. herwig$$version -> herwig
+- rm -f $(DESTDIR)$(includedir)/herwig && \
+- ln -sf herwig59 $(DESTDIR)$(includedir)/herwig
+ rm -rf $(DESTDIR)$(includedir)/isajet758
+ mv $(DESTDIR)$(includedir)/isajet $(DESTDIR)$(includedir)/isajet758
+ ln -sf isajet758 $(DESTDIR)$(includedir)/isajet
+@@ -128,14 +125,12 @@ install-arch: install-includes
+ fi
+
+ # ... and mclibs documentation
+- for dir in cojets eurodec herwig isajet pdflib ; do \
++ for dir in cojets eurodec isajet pdflib ; do \
+ install -d -m 0755 $(MCDOC)/$$dir ; \
+ done
+ install -p -m 0644 $(CERN_DOCDIR)/cojets.txt $(MCDOC)/cojets/
+ install -p -m 0644 $(CERN_DOCDIR)/isa* $(MCDOC)/isajet/
+ install -p -m 0644 $(CERN_DOCDIR)/eurodec.txt $(MCDOC)/eurodec/
+- install -p -m 0644 $(CVSCOSRC)/mclibs/herwig/doc/herwig59 \
+- $(MCDOC)/herwig/herwig59.txt
+ install -p -m 0644 $(CVSCOSRC)/mclibs/pdf/dpdf/pdfdoc.doc \
+ $(MCDOC)/pdflib/pdfdoc.txt
+
+diff --git a/mclibs-2006.dfsg.2.orig/src/mclibs/Imakefile b/mclibs-2006.dfsg.2.orig/src/mclibs/Imakefile
+index 0c9867d..0f04f1b 100644
+--- a/mclibs-2006.dfsg.2.orig/src/mclibs/Imakefile
++++ b/mclibs-2006.dfsg.2.orig/src/mclibs/Imakefile
+@@ -6,7 +6,7 @@
+ to them and their dependents. They have already been purged from
+ Debianized source code. Also, re-order libs so that dependent ones
+ come after dependees. */
+-LIBDIRS= cojets eurodec pdf photos herwig isajet
++LIBDIRS= cojets eurodec pdf photos isajet
+
+ SUBDIRS = $(LIBDIRS)
+
+@@ -16,7 +16,7 @@ InstallLibSubdirs($(LIBDIRS))
+ InstallSharedLibSubdirs($(LIBDIRS))
+
+ /* Again, purge Pythia, Jetset and dependents. */
+-INCLUDEDIRS= cojets eurodec herwig isajet pdf
++INCLUDEDIRS= cojets eurodec isajet pdf
+
+ InstallIncludeSubdirs($(INCLUDEDIRS))
+
diff --git a/sci-physics/cernlib-montecarlo/metadata.xml b/sci-physics/cernlib-montecarlo/metadata.xml
index 44b82fa188e8..cacbb7ee6b3f 100644
--- a/sci-physics/cernlib-montecarlo/metadata.xml
+++ b/sci-physics/cernlib-montecarlo/metadata.xml
@@ -9,4 +9,8 @@
The libraries of Ariadne, Fritiof, Jetset, Lepto, and Pythia are not
available for Gentoo: see cernlib Debian packaging for explanation.
</longdescription>
+<use>
+ <flag name="herwig">Build Herwig internal event generator, newer version
+ available in <pkg>sci-physics/herwig</pkg></flag>
+</use>
</pkgmetadata>