summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-10-16 17:37:25 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-10-16 17:37:25 +0000
commitaac07d7afc5bf1c2419bdafe0b7204173c1db5ee (patch)
treea90ee6e15f781cccf70c6dbcb97c181a03b0e1c1 /sci-physics/root/files/root-5.26.00-make-3.82.patch
parentStable for HPPA (bug #338878). (diff)
downloadgentoo-2-aac07d7afc5bf1c2419bdafe0b7204173c1db5ee.tar.gz
gentoo-2-aac07d7afc5bf1c2419bdafe0b7204173c1db5ee.tar.bz2
gentoo-2-aac07d7afc5bf1c2419bdafe0b7204173c1db5ee.zip
Fix building with gmake-3.82 wrt 333083. Thanks to Diego for reporting.
(Portage version: 2.2_rc94/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/root/files/root-5.26.00-make-3.82.patch')
-rw-r--r--sci-physics/root/files/root-5.26.00-make-3.82.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-5.26.00-make-3.82.patch b/sci-physics/root/files/root-5.26.00-make-3.82.patch
new file mode 100644
index 000000000000..dc6d8a0189e3
--- /dev/null
+++ b/sci-physics/root/files/root-5.26.00-make-3.82.patch
@@ -0,0 +1,36 @@
+http://root.cern.ch/viewcvs?view=rev&revision=35096
+https://savannah.cern.ch/bugs/?func=detailitem&item_id=72166
+
+--- root-5.26.00d/Makefile
++++ root-5.26.00d/Makefile
+@@ -544,6 +544,30 @@
+ .PRECIOUS: include/%.h
+
+ # special rules (need to be defined before generic ones)
++cint/cint/lib/dll_stl/G__%.o: cint/cint/lib/dll_stl/G__%.cxx
++ $(MAKEDEP) -R -f$(patsubst %.o,%.d,$@) -Y -w 1000 -- \
++ $(CXXFLAGS) $(DICTFLAGS) -D__cplusplus -I$(CINTDIR)/lib/prec_stl \
++ -I$(CINTDIR)/stl -I$(CINTDIR)/inc -- $<
++ $(CXX) $(NOOPT) $(CXXFLAGS) $(DICTFLAGS) -I. -I$(CINTDIR)/inc $(CXXOUT)$@ -c $<
++
++cint/cint/lib/dll_stl/G__c_%.o: cint/cint/lib/dll_stl/G__c_%.c
++ $(MAKEDEP) -R -f$(patsubst %.o,%.d,$@) -Y -w 1000 -- \
++ $(CFLAGS) $(DICTFLAGS) -I$(CINTDIR)/lib/prec_stl \
++ -I$(CINTDIR)/stl -I$(CINTDIR)/inc -- $<
++ $(CC) $(NOOPT) $(CFLAGS) $(DICTFLAGS) -I. -I$(CINTDIR)/inc $(CXXOUT)$@ -c $<
++
++cint/cint/lib/G__%.o: cint/cint/lib/G__%.cxx
++ $(MAKEDEP) -R -f$(patsubst %.o,%.d,$@) -Y -w 1000 -- \
++ $(CXXFLAGS) $(DICTFLAGS) -D__cplusplus -I$(CINTDIR)/lib/prec_stl \
++ -I$(CINTDIR)/stl -I$(CINTDIR)/inc -- $<
++ $(CXX) $(NOOPT) $(CXXFLAGS) $(DICTFLAGS) -I. -I$(CINTDIR)/inc $(CXXOUT)$@ -c $<
++
++cint/cint/lib/G__c_%.o: cint/cint/lib/G__c_%.c
++ $(MAKEDEP) -R -f$(patsubst %.o,%.d,$@) -Y -w 1000 -- \
++ $(CFLAGS) $(DICTFLAGS) -I$(CINTDIR)/lib/prec_stl \
++ -I$(CINTDIR)/stl -I$(CINTDIR)/inc -- $<
++ $(CC) $(NOOPT) $(CFLAGS) $(DICTFLAGS) -I. -I$(CINTDIR)/inc $(CXXOUT)$@ -c $<
++
+ G__%.o: G__%.cxx
+ $(MAKEDEP) -R -f$(patsubst %.o,%.d,$@) -Y -w 1000 -- \
+ $(CXXFLAGS) $(DICTFLAGS) -D__cplusplus -I$(CINTDIR)/lib/prec_stl \