summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-04-20 13:32:20 +0000
committerThomas Kahle <tomka@gentoo.org>2012-04-20 13:32:20 +0000
commit96dd621cbadb6588cd635ab4124d44e79a61150f (patch)
treeb1576b22a7be9f5d214e0ded0862fed26265a0d7 /sci-mathematics
parentMarked stable on AMD64 based on arch testing by Elijah "Armageddon" El Lazkan... (diff)
downloadgentoo-2-96dd621cbadb6588cd635ab4124d44e79a61150f.tar.gz
gentoo-2-96dd621cbadb6588cd635ab4124d44e79a61150f.tar.bz2
gentoo-2-96dd621cbadb6588cd635ab4124d44e79a61150f.zip
Bump to 2.12
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/polymake/ChangeLog10
-rw-r--r--sci-mathematics/polymake/files/polymake-2.12-soname.patch12
-rw-r--r--sci-mathematics/polymake/polymake-2.12.ebuild82
3 files changed, 102 insertions, 2 deletions
diff --git a/sci-mathematics/polymake/ChangeLog b/sci-mathematics/polymake/ChangeLog
index c3aeff905e9c..0e5b7aba9bce 100644
--- a/sci-mathematics/polymake/ChangeLog
+++ b/sci-mathematics/polymake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/polymake
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.8 2011/12/26 08:32:49 tomka Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.9 2012/04/20 13:32:19 tomka Exp $
+
+*polymake-2.12 (20 Apr 2012)
+
+ 20 Apr 2012; Thomas Kahle <tomka@gentoo.org>
+ +files/polymake-2.12-soname.patch, +polymake-2.12.ebuild:
+ Bump to 2.12
26 Dec 2011; Thomas Kahle <tomka@gentoo.org> polymake-2.11.ebuild,
files/polymake-2.11-drop-jreality.patch:
diff --git a/sci-mathematics/polymake/files/polymake-2.12-soname.patch b/sci-mathematics/polymake/files/polymake-2.12-soname.patch
new file mode 100644
index 000000000000..d4d2ea7b6086
--- /dev/null
+++ b/sci-mathematics/polymake/files/polymake-2.12-soname.patch
@@ -0,0 +1,12 @@
+diff -U 3 -dHrN polymake-2.12.orig/support/corelib.make polymake-2.12/support/corelib.make
+--- polymake-2.12.orig/support/corelib.make 2012-04-19 15:57:15.326930563 -0400
++++ polymake-2.12/support/corelib.make 2012-04-19 16:01:53.862264223 -0400
+@@ -90,7 +90,7 @@
+ ifneq (${LDcallableFlags},none)
+ # no explicit dependence on XSObjects here because they are built in compile-xs using the Makefile generated by xsubpp
+ ${CallableLib} : ${SharedObjects} ${CallableSharedObjects} ${GlueObjects} ${CallableGlueObjects} ${XXSObjects} $(patsubst %,${SourceDir}/perl/%.xs,${XSModules})
+- ${CXX} ${LDcallableFlags} -o $@ ${SharedObjects} ${CallableSharedObjects} ${GlueObjects} ${CallableGlueObjects} ${XXSObjects} ${XSObjects} ${LDFLAGS} ${PERLccdlflags} -lmpfr -lgmp ${LIBXML2_LIBS} ${LIBS} -L${PERLarchlib}/CORE -lperl
++ ${CXX} ${LDcallableFlags} -Wl,-soname,libpolymake.so.0 -o $@ ${SharedObjects} ${CallableSharedObjects} ${GlueObjects} ${CallableGlueObjects} ${XXSObjects} ${XSObjects} ${LDFLAGS} ${PERLccdlflags} -lmpfr -lgmp ${LIBXML2_LIBS} ${LIBS} -L${PERLarchlib}/CORE -lperl
+ else
+ ${CallableLib} : ${GlueObjects} ${XXSObjects} $(patsubst %,${SourceDir}/perl/%.xs,${XSModules})
+ endif
diff --git a/sci-mathematics/polymake/polymake-2.12.ebuild b/sci-mathematics/polymake/polymake-2.12.ebuild
new file mode 100644
index 000000000000..2e948dd717a3
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.12.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.12.ebuild,v 1.1 2012/04/20 13:32:19 tomka Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic
+
+MY_PV=${PV}-rc3
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${PN}-${MY_PV}.tar.bz2"
+HOMEPAGE="http://polymake.org"
+
+IUSE="libpolymake"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/gmp
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # embedded jreality is a precompiled desaster (bug #346073)
+ epatch "${FILESDIR}/${PN}"-2.11-drop-jreality.patch
+ # Assign a soname
+ epatch "${FILESDIR}/${P}"-soname.patch
+ rm -rf java_build/jreality
+
+ # Don't strip
+ sed -i '/system "strip $to"/d' support/install.pl || die
+
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+}
+
+src_configure () {
+ export CXXOPT=$(get-flag -O)
+ local myconf
+ if use libpolymake ; then
+ # WTF: If we leave myconf as the empty string here
+ # then configure will fail.
+ myconf="--without-prereq"
+ else
+ # --with-callable is not supported :(
+ myconf="--without-callable"
+ fi
+ echo ${myconf}
+ # Configure does not accept --host, therefore econf cannot be used
+ ./configure --prefix="${EPREFIX}/usr" \
+ --without-java \
+ --without-prereq \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
+ "${myconf}" || die
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst(){
+ elog "Polymake uses Perl Modules compiled during install."
+ elog "You have to reinstall polymake after an upgrade of Perl."
+ elog " "
+ elog "This version of polymake does not ship docs. Sorry."
+ elog "Help can be found on http://www.opt.tu-darmstadt.de/polymake_doku/ "
+ elog " "
+ elog "Visualization in polymake is via jreality which ships pre-compiled"
+ elog "binary libraries. Until this situation is resolved, support for"
+ elog "jreality has been dropped. Please contribute to Bug #346073 to "
+ elog "make jreality available in Gentoo."
+}