summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-15 19:25:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-15 19:25:21 +0000
commit617cde93b60b4564cb06a9adead317d770efe7c3 (patch)
tree0ebf32b5ff3b39319dffc886cef62eecfb1d43d0 /sci-mathematics
parentFix compability with dev-libs/libcdio-paranoia. (diff)
downloadgentoo-2-617cde93b60b4564cb06a9adead317d770efe7c3.tar.gz
gentoo-2-617cde93b60b4564cb06a9adead317d770efe7c3.tar.bz2
gentoo-2-617cde93b60b4564cb06a9adead317d770efe7c3.zip
fix build with camlp4, bug #450954
(Portage version: 2.2.0_alpha153/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog6
-rw-r--r--sci-mathematics/coq/coq-8.4_p1.ebuild6
-rw-r--r--sci-mathematics/coq/files/coq-8.4_p1-camlp4.patch17
3 files changed, 27 insertions, 2 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 509d73e5c405..8ce95bc34f95 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.75 2013/01/07 02:30:46 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.76 2013/01/15 19:25:21 aballier Exp $
+
+ 15 Jan 2013; Alexis Ballier <aballier@gentoo.org> coq-8.4_p1.ebuild,
+ +files/coq-8.4_p1-camlp4.patch:
+ fix build with camlp4, bug #450954
*coq-8.4_p1 (07 Jan 2013)
diff --git a/sci-mathematics/coq/coq-8.4_p1.ebuild b/sci-mathematics/coq/coq-8.4_p1.ebuild
index f219f9874f30..250282989e1b 100644
--- a/sci-mathematics/coq/coq-8.4_p1.ebuild
+++ b/sci-mathematics/coq/coq-8.4_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p1.ebuild,v 1.1 2013/01/07 02:30:46 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p1.ebuild,v 1.2 2013/01/15 19:25:21 aballier Exp $
EAPI="4"
@@ -34,6 +34,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}/${P}-camlp4.patch"
+}
+
src_configure() {
ocaml_lib=`ocamlc -where`
local myconf="--prefix /usr
diff --git a/sci-mathematics/coq/files/coq-8.4_p1-camlp4.patch b/sci-mathematics/coq/files/coq-8.4_p1-camlp4.patch
new file mode 100644
index 000000000000..bc60b9f56f4c
--- /dev/null
+++ b/sci-mathematics/coq/files/coq-8.4_p1-camlp4.patch
@@ -0,0 +1,17 @@
+Upstream rev 16121
+https://bugs.gentoo.org/show_bug.cgi?id=450954
+
+Index: coq-8.4pl1/scripts/coqmktop.ml
+===================================================================
+--- coq-8.4pl1.orig/scripts/coqmktop.ml
++++ coq-8.4pl1/scripts/coqmktop.ml
+@@ -45,8 +45,7 @@ let camlp4topobjs =
+ [ "Camlp4Top.cmo";
+ "Camlp4Parsers/Camlp4OCamlRevisedParser.cmo";
+ "Camlp4Parsers/Camlp4OCamlParser.cmo";
+- "Camlp4Parsers/Camlp4GrammarParser.cmo";
+- "q_util.cmo"; "q_coqast.cmo" ]
++ "Camlp4Parsers/Camlp4GrammarParser.cmo" ]
+ let topobjs = camlp4topobjs
+
+ let gramobjs = []