summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-07-31 13:12:56 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-07-31 13:12:56 +0000
commitf36ecebab1692eb383e443d2e1a0b352b02ae5aa (patch)
tree9b08416d0e3d499e2a837d9a6e336ad9ec3449bd /sci-mathematics/qtoctave
parentMarked stable on AMD64 as requested by Arfrever Frehtes Taifersar Arahesis <a... (diff)
downloadgentoo-2-f36ecebab1692eb383e443d2e1a0b352b02ae5aa.tar.gz
gentoo-2-f36ecebab1692eb383e443d2e1a0b352b02ae5aa.tar.bz2
gentoo-2-f36ecebab1692eb383e443d2e1a0b352b02ae5aa.zip
Added gcc-4.4 compatibility patch (fixes bug #274039).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/qtoctave')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog7
-rw-r--r--sci-mathematics/qtoctave/files/qtoctave-0.8.1-gcc4.4.patch8
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild9
3 files changed, 22 insertions, 2 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index 7fba3280c537..b25cacd81d57 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/qtoctave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.4 2009/02/20 18:14:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.5 2009/07/31 13:12:55 markusle Exp $
+
+ 31 Jul 2009; Markus Dittrich <markusle@gentoo.org> qtoctave-0.8.1.ebuild,
+ +files/qtoctave-0.8.1-gcc4.4.patch:
+ Added gcc-4.4 compatibility patch (fixes bug #274039).
+ Thanks much to Naohiro Aota for providing the fix.
20 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> qtoctave-0.8.1.ebuild:
Update ebuild to use cmake-utils eclass correctly.
diff --git a/sci-mathematics/qtoctave/files/qtoctave-0.8.1-gcc4.4.patch b/sci-mathematics/qtoctave/files/qtoctave-0.8.1-gcc4.4.patch
new file mode 100644
index 000000000000..4bc26f858cb5
--- /dev/null
+++ b/sci-mathematics/qtoctave/files/qtoctave-0.8.1-gcc4.4.patch
@@ -0,0 +1,8 @@
+diff -Naur qtoctave-0.8.1/qtoctave/src/search_dialog.cpp qtoctave-0.8.1.new/qtoctave/src/search_dialog.cpp
+--- qtoctave-0.8.1/qtoctave/src/search_dialog.cpp 2008-09-21 05:00:30.000000000 -0400
++++ qtoctave-0.8.1.new/qtoctave/src/search_dialog.cpp 2009-07-31 09:04:20.000000000 -0400
+@@ -1,3 +1,4 @@
++#include <cstdio>
+ #include "search_dialog.h"
+
+ SearchDialog::SearchDialog(QWidget *parent): QDialog(parent)
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
index 3a8c1e36acce..17db532e66d2 100644
--- a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.3 2009/02/20 18:14:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.4 2009/07/31 13:12:55 markusle Exp $
EAPI="1"
@@ -24,6 +24,13 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.4.patch
+}
+
src_compile() {
mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
cmake-utils_src_compile