summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-02 23:52:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-02 23:52:23 +0000
commitc86421e49d66727c837a02170b6e83adbd821b83 (patch)
treeb9b6f5cb066cb5bc393417bde9233f4c5804ceee /sci-mathematics/gretl
parentFix ChangeLog entries. (diff)
downloadgentoo-2-c86421e49d66727c837a02170b6e83adbd821b83.tar.gz
gentoo-2-c86421e49d66727c837a02170b6e83adbd821b83.tar.bz2
gentoo-2-c86421e49d66727c837a02170b6e83adbd821b83.zip
Version bump with fix to sandbox violation when sourceview is on, closing bug #252574
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/gretl')
-rw-r--r--sci-mathematics/gretl/ChangeLog12
-rw-r--r--sci-mathematics/gretl/files/gretl-1.8.0-ldflags.patch80
-rw-r--r--sci-mathematics/gretl/gretl-1.7.9.ebuild8
-rw-r--r--sci-mathematics/gretl/gretl-1.8.0.ebuild (renamed from sci-mathematics/gretl/gretl-1.7.7.ebuild)43
4 files changed, 114 insertions, 29 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index de3a74807337..8cdfdc563bfc 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/gretl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.16 2008/10/08 21:50:26 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.17 2009/02/02 23:52:23 bicatali Exp $
+
+*gretl-1.8.0 (02 Feb 2009)
+
+ 02 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/gretl-1.8.0-ldflags.patch, -gretl-1.7.7.ebuild, gretl-1.7.9.ebuild,
+ +gretl-1.8.0.ebuild:
+ Version bump with fix to sandbox violation when sourceview is on, closing
+ bug #252574
*gretl-1.7.9 (08 Oct 2008)
diff --git a/sci-mathematics/gretl/files/gretl-1.8.0-ldflags.patch b/sci-mathematics/gretl/files/gretl-1.8.0-ldflags.patch
new file mode 100644
index 000000000000..ab0960e44247
--- /dev/null
+++ b/sci-mathematics/gretl/files/gretl-1.8.0-ldflags.patch
@@ -0,0 +1,80 @@
+diff -Nur gretl-1.8.0.orig/cli/Makefile.in gretl-1.8.0/cli/Makefile.in
+--- gretl-1.8.0.orig/cli/Makefile.in 2008-03-24 12:46:11.000000000 +0000
++++ gretl-1.8.0/cli/Makefile.in 2009-02-02 23:48:16.880402952 +0000
+@@ -3,6 +3,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+
+@@ -51,7 +52,7 @@
+ $(CC) $(CFLAGS) -MM $< > .deps/$*.d
+
+ $(CLI): .deps $(OBJS)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(GRETLLIB) $(READLINE_LIBS)
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(OBJS) $(GRETLLIB) $(READLINE_LIBS)
+
+ .deps:
+ mkdir $@
+diff -Nur gretl-1.8.0.orig/gui2/Makefile.in gretl-1.8.0/gui2/Makefile.in
+--- gretl-1.8.0.orig/gui2/Makefile.in 2008-12-11 18:44:33.000000000 +0000
++++ gretl-1.8.0/gui2/Makefile.in 2009-02-02 23:20:16.989339642 +0000
+@@ -7,6 +7,7 @@
+ libdir = @libdir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+@@ -164,7 +165,7 @@
+ $(CC) $(CFLAGS) -MM $< > .deps/$*.d
+
+ $(PROG): .deps $(OBJS) $(HACK_OBJ) $(GTKSOURCEVIEW_LITE)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS) $(HACK_OBJ) $(LIBS) $(INETLIB) $(CARBONLIB)
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(OBJS) $(HACK_OBJ) $(LIBS) $(INETLIB) $(CARBONLIB)
+
+ $(HACK_OBJ): $(HACK_SRC) $(HACK_HDR)
+ $(CC) $(CFLAGS) $(GTK_CFLAGS) -c $<
+diff -Nur gretl-1.8.0.orig/lib/Makefile.in gretl-1.8.0/lib/Makefile.in
+--- gretl-1.8.0.orig/lib/Makefile.in 2008-12-14 17:35:18.000000000 +0000
++++ gretl-1.8.0/lib/Makefile.in 2009-02-02 23:21:00.017863458 +0000
+@@ -6,6 +6,7 @@
+ bindir = @bindir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+@@ -231,7 +232,7 @@
+ $(CC) $(CFLAGS) -MM -MT $*.lo $< > .deps/$*.d
+
+ $(LIBGRETL): .deps $(LOBJS) $(AUX_LOBJ)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(AUX_LOBJ) \
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LOBJS) $(AUX_LOBJ) \
+ -rpath $(prefix)/lib $(LIBS) \
+ -version-info $(CURRENT):$(REVISION):$(AGE)
+
+diff -Nur gretl-1.8.0.orig/plugin/Makefile.in gretl-1.8.0/plugin/Makefile.in
+--- gretl-1.8.0.orig/plugin/Makefile.in 2008-12-09 15:49:20.000000000 +0000
++++ gretl-1.8.0/plugin/Makefile.in 2009-02-02 23:21:36.595339921 +0000
+@@ -7,6 +7,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ MAKE = @MAKE@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+@@ -47,7 +48,7 @@
+
+ LIBTOOL = ../libtool
+ COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
+-LINK = $(LIBTOOL) --mode=link $(CC) -module -avoid-version -rpath $(plugindir)
++LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -module -avoid-version -rpath $(plugindir)
+
+ GRETLINC = -I$(topsrc)/lib/src
+ GRETLLIB = ../lib/libgretl-1.0.la
diff --git a/sci-mathematics/gretl/gretl-1.7.9.ebuild b/sci-mathematics/gretl/gretl-1.7.9.ebuild
index c7fd9d8a6e97..9779e76d4714 100644
--- a/sci-mathematics/gretl/gretl-1.7.9.ebuild
+++ b/sci-mathematics/gretl/gretl-1.7.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.7.9.ebuild,v 1.1 2008/10/08 21:50:26 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.7.9.ebuild,v 1.2 2009/02/02 23:52:23 bicatali Exp $
USE_EINSTALL=true
EAPI=2
@@ -82,9 +82,9 @@ src_compile() {
src_install() {
if use gnome; then
- gnome2_src_install gnome_prefix="${D}"/usr
+ gnome2_src_install gnome_prefix="${D}"/usr svprefix="${D}usr"
else
- einstall || die "einstall failed"
+ einstall svprefix="${D}usr" || die "einstall failed"
fi
if use gtk && ! use gnome; then
doicon gnome/gretl.png
diff --git a/sci-mathematics/gretl/gretl-1.7.7.ebuild b/sci-mathematics/gretl/gretl-1.8.0.ebuild
index 2d0de62fd502..eac74dca96a7 100644
--- a/sci-mathematics/gretl/gretl-1.7.7.ebuild
+++ b/sci-mathematics/gretl/gretl-1.8.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.7.7.ebuild,v 1.1 2008/08/30 16:59:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.8.0.ebuild,v 1.1 2009/02/02 23:52:23 bicatali Exp $
USE_EINSTALL=true
-EAPI=1
+EAPI=2
inherit eutils gnome2 elisp-common
DESCRIPTION="Regression, econometrics and time-series library"
@@ -26,8 +26,12 @@ RDEPEND="dev-libs/libxml2
readline? ( sys-libs/readline )
gmp? ( dev-libs/gmp )
accessibility? ( app-accessibility/flite )
- gtk? ( >=x11-libs/gtk+-2.10:2 )
- gnome? ( gnome-base/libgnomeui
+ gtk? ( sci-visualization/gnuplot[gd]
+ media-libs/gd[png]
+ x11-libs/gtk+:2 )
+ gnome? ( sci-visualization/gnuplot[gd]
+ media-libs/gd[png]
+ gnome-base/libgnomeui
gnome-base/libgnomeprint:2.2
gnome-base/libgnomeprintui:2.2
gnome-base/gconf:2 )
@@ -40,22 +44,13 @@ DEPEND="${RDEPEND}
SITEFILE=50${PN}-gentoo.el
-pkg_setup() {
- if use gtk && ! built_with_use sci-visualization/gnuplot gd; then
- eerror "gretl gtk GUI needs gnuplot with gd and gd with png"
- die "Please install gnuplot with gd and png use flags enabled"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7.5-locale.patch
- epatch "${FILESDIR}"/${PN}-1.7.6-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-1.8.0-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-1.7.9-nls.patch
}
-src_compile() {
-
+src_configure() {
local myconf
if use gtk; then
myconf="--enable-gui"
@@ -73,8 +68,10 @@ src_compile() {
$(use_with odbc) \
$(use_with accessibility audio) \
${myconf} \
- LAPACK_LIBS="$(pkg-config --libs lapack)" \
- || die "econf failed"
+ LAPACK_LIBS="$(pkg-config --libs lapack)"
+}
+
+src_compile() {
emake || die "emake failed"
@@ -85,13 +82,13 @@ src_compile() {
src_install() {
if use gnome; then
- gnome2_src_install gnome_prefix="${D}"/usr
+ gnome2_src_install gnome_prefix="${D}"/usr svprefix="${D}usr"
else
- einstall || die "einstall failed"
+ einstall svprefix="${D}usr"
fi
if use gtk && ! use gnome; then
doicon gnome/gretl.png
- make_desktop_entry gretlx11 gretl
+ make_desktop_entry gretl_x11 gretl
fi
if use emacs; then
elisp-install ${PN} utils/emacs/gretl.{el,elc} \