summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-08 21:50:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-08 21:50:27 +0000
commitad62efa52a8befa38031c1e6231315cacb4f5d17 (patch)
tree23da74dc1d6fd437bb176c226eee43e7d23003c3 /sci-mathematics/gretl
parentamd64/x86 stable, bug #240516 (diff)
downloadgentoo-2-ad62efa52a8befa38031c1e6231315cacb4f5d17.tar.gz
gentoo-2-ad62efa52a8befa38031c1e6231315cacb4f5d17.tar.bz2
gentoo-2-ad62efa52a8befa38031c1e6231315cacb4f5d17.zip
Version bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics/gretl')
-rw-r--r--sci-mathematics/gretl/ChangeLog8
-rw-r--r--sci-mathematics/gretl/files/gretl-1.7.9-nls.patch13
-rw-r--r--sci-mathematics/gretl/gretl-1.7.9.ebuild (renamed from sci-mathematics/gretl/gretl-1.7.6.ebuild)37
3 files changed, 37 insertions, 21 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index 665fdcb41cf9..de3a74807337 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.15 2008/08/30 16:59:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.16 2008/10/08 21:50:26 bicatali Exp $
+
+*gretl-1.7.9 (08 Oct 2008)
+
+ 08 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/gretl-1.7.9-nls.patch, -gretl-1.7.6.ebuild, +gretl-1.7.9.ebuild:
+ Version bump
*gretl-1.7.7 (30 Aug 2008)
diff --git a/sci-mathematics/gretl/files/gretl-1.7.9-nls.patch b/sci-mathematics/gretl/files/gretl-1.7.9-nls.patch
new file mode 100644
index 000000000000..a961c2dcdf06
--- /dev/null
+++ b/sci-mathematics/gretl/files/gretl-1.7.9-nls.patch
@@ -0,0 +1,13 @@
+--- gui2/gui_recode.c.orig 2008-09-22 17:29:52.000000000 +0100
++++ gui2/gui_recode.c 2008-10-08 21:19:22.000000000 +0100
+@@ -285,6 +285,10 @@
+ return ret;
+ }
+
++#else
++gchar *my_filename_from_utf8 (char *fname) { return fname; }
++gchar *my_filename_to_utf8 (const char *fname) { return g_strdup(fname); }
++int maybe_recode_gp_file_to_utf8 (const char *fname) { return 1; }
+ #endif /* ENABLE_NLS */
+
+
diff --git a/sci-mathematics/gretl/gretl-1.7.6.ebuild b/sci-mathematics/gretl/gretl-1.7.9.ebuild
index 0439a47be0f9..c7fd9d8a6e97 100644
--- a/sci-mathematics/gretl/gretl-1.7.6.ebuild
+++ b/sci-mathematics/gretl/gretl-1.7.9.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.7.6.ebuild,v 1.1 2008/08/08 13:41:13 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.7.9.ebuild,v 1.1 2008/10/08 21:50:26 bicatali Exp $
USE_EINSTALL=true
-EAPI=1
+EAPI=2
inherit eutils gnome2 elisp-common
DESCRIPTION="Regression, econometrics and time-series library"
@@ -26,8 +26,12 @@ RDEPEND="dev-libs/libxml2
readline? ( sys-libs/readline )
gmp? ( dev-libs/gmp )
accessibility? ( app-accessibility/flite )
- gtk? ( >=x11-libs/gtk+-2.10:2 )
- gnome? ( gnome-base/libgnomeui
+ gtk? ( sci-visualization/gnuplot[gd]
+ media-libs/gd[png]
+ x11-libs/gtk+:2 )
+ gnome? ( sci-visualization/gnuplot[gd]
+ media-libs/gd[png]
+ gnome-base/libgnomeui
gnome-base/libgnomeprint:2.2
gnome-base/libgnomeprintui:2.2
gnome-base/gconf:2 )
@@ -40,22 +44,13 @@ DEPEND="${RDEPEND}
SITEFILE=50${PN}-gentoo.el
-pkg_setup() {
- if use gtk && ! built_with_use sci-visualization/gnuplot gd; then
- eerror "gretl gtk GUI needs gnuplot with gd and gd with png"
- die "Please install gnuplot with gd and png use flags enabled"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7.5-locale.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-1.7.6-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-1.7.9-nls.patch
}
-src_compile() {
-
+src_configure() {
local myconf
if use gtk; then
myconf="--enable-gui"
@@ -73,8 +68,10 @@ src_compile() {
$(use_with odbc) \
$(use_with accessibility audio) \
${myconf} \
- LAPACK_LIBS="$(pkg-config --libs lapack)" \
- || die "econf failed"
+ LAPACK_LIBS="$(pkg-config --libs lapack)"
+}
+
+src_compile() {
emake || die "emake failed"
@@ -91,7 +88,7 @@ src_install() {
fi
if use gtk && ! use gnome; then
doicon gnome/gretl.png
- make_desktop_entry gretlx11 gretl
+ make_desktop_entry gretl_x11 gretl
fi
if use emacs; then
elisp-install ${PN} utils/emacs/gretl.{el,elc} \