summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-16 20:35:15 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-16 20:35:15 +0000
commit29c1f5d88e2f6ca397f4a306350b896f5de59d7a (patch)
treed109a69d5fda5e93950431f79dae79a8c378f5de /sci-libs
parentFix LICENSE, bug 449946. (diff)
downloadgentoo-2-29c1f5d88e2f6ca397f4a306350b896f5de59d7a.tar.gz
gentoo-2-29c1f5d88e2f6ca397f4a306350b896f5de59d7a.tar.bz2
gentoo-2-29c1f5d88e2f6ca397f4a306350b896f5de59d7a.zip
sci-libs/pgplot: Add fix for tk8.6, #451614, thanks Juergen Rose for the patch
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pgplot/ChangeLog6
-rw-r--r--sci-libs/pgplot/files/pgplot-tk86.patch47
-rw-r--r--sci-libs/pgplot/metadata.xml4
-rw-r--r--sci-libs/pgplot/pgplot-5.2.2-r5.ebuild5
4 files changed, 57 insertions, 5 deletions
diff --git a/sci-libs/pgplot/ChangeLog b/sci-libs/pgplot/ChangeLog
index 8df8bd0a76c7..e00cca1b1bfc 100644
--- a/sci-libs/pgplot/ChangeLog
+++ b/sci-libs/pgplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/pgplot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.28 2013/01/13 12:40:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.29 2013/01/16 20:35:15 jlec Exp $
+
+ 16 Jan 2013; Justin Lecher <jlec@gentoo.org> +files/pgplot-tk86.patch,
+ pgplot-5.2.2-r5.ebuild, metadata.xml:
+ Add fix for tk8.6, #451614, thanks Juergen Rose for the patch
13 Jan 2013; Markus Meier <maekke@gentoo.org> pgplot-5.2.2-r5.ebuild:
add ~arm, bug #449762
diff --git a/sci-libs/pgplot/files/pgplot-tk86.patch b/sci-libs/pgplot/files/pgplot-tk86.patch
new file mode 100644
index 000000000000..bc0023eb90d2
--- /dev/null
+++ b/sci-libs/pgplot/files/pgplot-tk86.patch
@@ -0,0 +1,47 @@
+--- drivers/xtk/tkpgplot.c.ORIG 2000-12-13 03:16:28.000000000 +0100
++++ drivers/xtk/tkpgplot.c 2013-01-15 11:02:27.221231471 +0100
+@@ -417,7 +417,7 @@
+ /*
+ * If Tk_Init() hasn't been called, then there won't be a main window
+ * yet. In such cases, Tk_MainWindow() places a suitable error message
+- * in interp->result.
++ * in Tcl_GetStringResult(interp).
+ */
+ if(!main_w)
+ return TCL_ERROR;
+@@ -2136,7 +2136,7 @@
+ tkpg->border = bd;
+ tkpg_draw_3d_border(tkpg);
+ } else {
+- fprintf(stderr, "Tk_Get3DBorder failed: %s\n", tkpg->interp->result);
++ fprintf(stderr, "Tk_Get3DBorder failed: %s\n", Tcl_GetStringResult(tkpg->interp));
+ };
+ }
+
+@@ -2261,7 +2261,7 @@
+ * argv char ** The array of 'argc' configuration arguments.
+ * Output:
+ * return int TCL_ERROR and the context of the error
+- * is recorded in interp->result.
++ * is recorded in Tcl_GetStringResult(result).
+ */
+ static int tkpg_scrollbar_error(TkPgplot *tkpg, Tcl_Interp *interp,
+ char *widget, char *view, int argc,
+@@ -2586,7 +2586,7 @@
+ * Output:
+ * return Tk_Window The top-level window of the path, or NULL if
+ * it doesn't exist. In the latter case an error
+- * message will have been appended to interp->result.
++ * message will have been appended to Tcl_GetStringResult(interp).
+ */
+ static Tk_Window tkpg_toplevel_of_path(Tcl_Interp *interp, Tk_Window main_w,
+ char *path)
+@@ -2630,7 +2630,7 @@
+ free(first);
+ /*
+ * If the window doesn't exist, Tk_NameToWindow() is documented to place
+- * an error message in interp->result, so just return the error condition.
++ * an error message in Tcl_GetStringResult(interp), so just return the error condition.
+ */
+ if(!w)
+ return NULL;
diff --git a/sci-libs/pgplot/metadata.xml b/sci-libs/pgplot/metadata.xml
index 05a8a5d33331..7afe58a52a3f 100644
--- a/sci-libs/pgplot/metadata.xml
+++ b/sci-libs/pgplot/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
PGPLOT is a Fortran subroutine package for drawing graphs on a variety
of display devices. The CPGPLOT library adds an intermediate level of
wrapper functions between C programs and the PGPLOT library. These
diff --git a/sci-libs/pgplot/pgplot-5.2.2-r5.ebuild b/sci-libs/pgplot/pgplot-5.2.2-r5.ebuild
index ae93a851d83e..0287f515bab9 100644
--- a/sci-libs/pgplot/pgplot-5.2.2-r5.ebuild
+++ b/sci-libs/pgplot/pgplot-5.2.2-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r5.ebuild,v 1.4 2013/01/13 12:40:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r5.ebuild,v 1.5 2013/01/16 20:35:15 jlec Exp $
EAPI=4
@@ -34,7 +34,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-makemake.patch \
"${FILESDIR}"/${PN}-compile-setup.patch \
"${FILESDIR}"/${PN}-headers.patch \
- "${FILESDIR}"/${PN}-libpng15.patch
+ "${FILESDIR}"/${PN}-libpng15.patch \
+ "${FILESDIR}"/${PN}-tk86.patch
# gfortran < 4.3 does not compile gif, pp and wd drivers
if [[ $(tc-getFC) == *gfortran* ]] &&