summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-25 08:37:45 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-25 08:37:45 +0000
commitc2987eec1b3ff651c506c3eefb4c474157812842 (patch)
tree73072600f2d2aa5d5b07efa0cfad6b70c4723f0b /sci-libs/rosetta-fragments
parentsci-libs/profphd-utils: Give it some prefix love (diff)
downloadgentoo-2-c2987eec1b3ff651c506c3eefb4c474157812842.tar.gz
gentoo-2-c2987eec1b3ff651c506c3eefb4c474157812842.tar.bz2
gentoo-2-c2987eec1b3ff651c506c3eefb4c474157812842.zip
sci-libs/rosetta-fragments: Bump to EAPI=5 and straighten several issues
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/rosetta-fragments')
-rw-r--r--sci-libs/rosetta-fragments/ChangeLog10
-rw-r--r--sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch62
-rw-r--r--sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch153
-rw-r--r--sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild57
-rw-r--r--sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild4
5 files changed, 283 insertions, 3 deletions
diff --git a/sci-libs/rosetta-fragments/ChangeLog b/sci-libs/rosetta-fragments/ChangeLog
index cff9e5b62a2a..15296ca1fde7 100644
--- a/sci-libs/rosetta-fragments/ChangeLog
+++ b/sci-libs/rosetta-fragments/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/rosetta-fragments
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/rosetta-fragments/ChangeLog,v 1.4 2013/04/24 12:12:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/rosetta-fragments/ChangeLog,v 1.5 2013/04/25 08:37:45 jlec Exp $
+
+*rosetta-fragments-3.1-r1 (25 Apr 2013)
+
+ 25 Apr 2013; Justin Lecher <jlec@gentoo.org> rosetta-fragments-3.1.ebuild,
+ +rosetta-fragments-3.1-r1.ebuild,
+ +files/rosetta-fragments-3.1-chemshift.patch,
+ +files/rosetta-fragments-3.1-nnmake.patch:
+ Bump to EAPI=5 and straighten several issues
24 Apr 2013; Justin Lecher <jlec@gentoo.org> rosetta-fragments-3.1.ebuild,
metadata.xml:
diff --git a/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch
new file mode 100644
index 000000000000..cb8fd9197d1b
--- /dev/null
+++ b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch
@@ -0,0 +1,62 @@
+ chemshift/make.system | 24 ++++++++++++------------
+ chemshift/makefile | 2 +-
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/chemshift/make.system b/chemshift/make.system
+index 53bbd38..d105802 100644
+--- a/chemshift/make.system
++++ b/chemshift/make.system
+@@ -60,18 +60,18 @@ endif
+ ########## once COMPILER is set, here are the options
+
+ # defaults
+-F77=f77
+-FFLAGS=
+-FOPTIMFLAGS=-O
+-FDEBUGFLAGS=-g
++F77?=f77
++FFLAGS?=
++FOPTIMFLAGS?=
++FDEBUGFLAGS?=
+ FPROFILEFLAGS=-P
+
+ ifeq ($(COMPILER),gnu)
+- F77 = g77
+- FFLAGS = -finline-functions -funroll-loops -W -ffixed-line-length-132 -Wimplicit
+- FOPTIMFLAGS = -O -ffast-math -malign-double
+- FDEBUGFLAGS = -g -Wall -Wimplicit -Wsurprising -Wformat -W
+- FPROFILEFLAGS = -pg
++ F77 ?= g77
++ FFLAGS += -W -ffixed-line-length-132 -Wimplicit
++ FOPTIMFLAGS += -malign-double
++ FDEBUGFLAGS += -Wall -Wimplicit -Wsurprising -Wformat -W
++ FPROFILEFLAGS =
+ endif
+
+ ifeq ($(COMPILER),pgi) # on mary, good bounds checking
+@@ -108,9 +108,9 @@ endif
+
+ # Suse ppc gnu
+ ifeq ($(COMPILER),ppc)
+- F77 = g77
+- FFLAGS = -Wall -finline-functions -funroll-loops -W -ffixed-line-length-132
+- FDEBUGFLAGS = -g -C -Mbounds
++ F77 ?= g77
++ FFLAGS += -Wall -W -ffixed-line-length-132
++ FDEBUGFLAGS += -C -Mbounds
+ FOPTIMFLAGS =
+ endif
+
+diff --git a/chemshift/makefile b/chemshift/makefile
+index 712e98f..05d3b64 100644
+--- a/chemshift/makefile
++++ b/chemshift/makefile
+@@ -64,7 +64,7 @@ regular: compile
+ # rule to compile executable
+ compile: $(BASE_NAME).$(COMPILER)
+ $(BASE_NAME).$(COMPILER) : print ${OBJS}
+- $(F77) $(FFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
++ $(F77) $(FFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
+
+ # rule to compile object files:
+ .$(COMPILER).%.o: %.f
diff --git a/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch
new file mode 100644
index 000000000000..91da48017eff
--- /dev/null
+++ b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch
@@ -0,0 +1,153 @@
+ nnmake/dipolar_nn.f | 2 +-
+ nnmake/make.system | 33 ++++++++++++++++-----------------
+ nnmake/make_fragments.pl | 36 ++++++++++++++++++------------------
+ nnmake/makefile | 2 +-
+ 4 files changed, 36 insertions(+), 37 deletions(-)
+
+diff --git a/nnmake/dipolar_nn.f b/nnmake/dipolar_nn.f
+index c159888..4412a20 100644
+--- a/nnmake/dipolar_nn.f
++++ b/nnmake/dipolar_nn.f
+@@ -1396,7 +1396,7 @@ car pairDipolar(1,i) .le. pairDipolar(1,i+1)
+ write(0,*)'rejected'
+ write(0,*)x(1,iset),x(2,iset),x(3,iset),x(4,iset),x(5,iset)
+ do i=1,maplength(iset)
+- write(0,'(i,6f6.3)')i,A(i,1),A(i,2),A(i,3),A(i,4),A(i,5),
++ write(0,'(i6,6f6.3)')i,A(i,1),A(i,2),A(i,3),A(i,4),A(i,5),
+ # b(i)
+ enddo
+ goto 300
+diff --git a/nnmake/make.system b/nnmake/make.system
+index 34bea8f..2fbfabf 100644
+--- a/nnmake/make.system
++++ b/nnmake/make.system
+@@ -55,18 +55,17 @@ endif
+ ########## once COMPILER is set, here are the options
+
+ # defaults
+-F77=f77
+-FFLAGS=
+-FOPTIMFLAGS=-O
+-FDEBUGFLAGS=-g
+-FPROFILEFLAGS=-P
++F77?=f77
++FOPTIMFLAGS=
++FDEBUGFLAGS=
++FPROFILEFLAGS=
+
+ ifeq ($(COMPILER),gnu)
+- F77 = g77
+- FFLAGS = -finline-functions -funroll-loops -W -ffixed-line-length-132 -Wimplicit
+- FOPTIMFLAGS = -O -ffast-math -malign-double
+- FDEBUGFLAGS = -g -Wall -Wimplicit -Wsurprising -Wformat -W
+- FPROFILEFLAGS = -pg
++ F77 ?= g77
++ FFLAGS += -W -ffixed-line-length-132 -Wimplicit
++ FOPTIMFLAGS += -malign-double
++ FDEBUGFLAGS += -Wall -Wimplicit -Wsurprising -Wformat -W
++ FPROFILEFLAGS =
+ endif
+
+ ifeq ($(COMPILER),pgi) # on mary, good bounds checking
+@@ -82,9 +81,9 @@ ifeq ($(COMPILER),pgi) # on mary, good bounds checking
+ endif
+
+ ifeq ($(COMPILER),absoft) # on mary, fast
+- F77 = f77
+- FFLAGS = -N109 -s -W
+- LINKFLAGS = -lU77
++ F77 ?= f77
++ FFLAGS ?= -N109 -s -W
++ LINKFLAGS += -lU77
+ FDEBUGFLAGS = -C -g
+ FOPTIMFLAGS = -O -N18
+ FPROFILEFLAGS = -P -O
+@@ -103,10 +102,10 @@ endif
+
+ # Suse ppc gnu
+ ifeq ($(COMPILER),ppc)
+- F77 = g77
+- FFLAGS = -Wall -finline-functions -funroll-loops -W -ffixed-line-length-132
+- FDEBUGFLAGS = -g -C -Mbounds
+- FOPTIMFLAGS =
++ F77 ?= g77
++ FFLAGS += -Wall -W -ffixed-line-length-132
++ FDEBUGFLAGS += -C -Mbounds
++ FOPTIMFLAGS +=
+ endif
+
+ # alpha flags
+diff --git a/nnmake/make_fragments.pl b/nnmake/make_fragments.pl
+index 5273685..29619a2 100755
+--- a/nnmake/make_fragments.pl
++++ b/nnmake/make_fragments.pl
+@@ -19,38 +19,38 @@
+
+ my $TAIL = "_v1_3";
+
+-$src_dir = '/work/chu/rosetta/rosetta_C++/rosetta-2.2.0/rosetta_fragments';
+-$shareware_dir = '/work/chu/src/shareware';
+-$scratch = "/scratch/shared";
++$src_dir = '@GENTOO_PORTAGE_EPREFIX@/';
++$shareware_dir = '$src_dir/usr/share';
++$scratch = "$src_dir/scratch/shared";
+
+ # psi-blast
+ #my $BLAST_BIN_DIR = "$shareware_dir/new_blast/blast-2.2.12/bin";
+-my $PSIBLAST = "$shareware_dir/blast/bin/blastpgp"; # PSI-BLAST (duh.)
+-my $NR = "/$scratch/genomes/nr"; # nr blast database filename
+-my $VALL_BLAST_DB = "/$scratch/nnmake_database/vall.blast.2006-05-05"; # vall blast database filename (cvs respository 'nnmake_database')
+-my $BLOSUM = "$scratch/nnmake_database/"; # BLOSUM score matrices directory (cvs repository 'nnmake_database')
++my $PSIBLAST = "$src_dir/usr/bin/blastpgp"; # PSI-BLAST (duh.)
++my $NR = "$shareware_dir/nr"; # nr blast database filename
++my $VALL_BLAST_DB = "$shareware_dir/rosetta-fragments/nnmake_database/vall.blast.2006-05-05"; # vall blast database filename (cvs respository 'nnmake_database')
++my $BLOSUM = "$shareware_dir/rosetta-fragments/nnmake_database/"; # BLOSUM score matrices directory (cvs repository 'nnmake_database')
+
+ # psipred
+-my $FILTNR = "$scratch/genomes/filtnr"; # filtnr blast database filename
+-my $MAKEMAT = "$shareware_dir/blast/bin/makemat"; # makemat utility (part of NCBI tools)
+-my $PSIPRED = "$shareware_dir/psipred/bin/psipred"; # psipred
+-my $PSIPASS2 = "$shareware_dir/psipred/bin/psipass2"; # psipass2 (part of psipred pkg)
++my $FILTNR = "$src_dir/tmp/filtnr"; # filtnr blast database filename
++my $MAKEMAT = "$src_dir/usr/bin/makemat"; # makemat utility (part of NCBI tools)
++my $PSIPRED = "$src_dir/usr/bin/psipred"; # psipred
++my $PSIPASS2 = "$src_dir/usr/bin/psipass2"; # psipass2 (part of psipred pkg)
+ my $PSIPRED_DATA = "$shareware_dir/psipred/data"; # dir containing psipred data files.
+
+ # prof
+ #my $PROF = "$shareware_dir/prof/run_prof.py";
+-my $PROF = "$src_dir/nnmake/run_prof.py"; # remember to change prof executable location in run_prof.py
++my $PROF = "$src_dir/usr/bin/run_prof.py"; # remember to change prof executable location in run_prof.py
+
+ # nnmake
+-my $VALL = "$scratch/nnmake_database"; # dir containing vall database (cvs repository 'nnmake_database')
+-my $VALL2 = "$scratch/nnmake_database"; # alt dir containing vall database (cvs repository 'nnmake_database')
++my $VALL = "$shareware_dir/rosetta-fragments/nnmake_database"; # dir containing vall database (cvs repository 'nnmake_database')
++my $VALL2 = "$shareware_dir/rosetta-fragments/nnmake_database"; # alt dir containing vall database (cvs repository 'nnmake_database')
+ my $VALL_NAME = "vall.dat.2006-05-05"; # filename of vall (vall.dat.<id> and vall_cst_coord.dat.<id> must exist)
+-my $NNMAKE = "$src_dir/nnmake/pNNMAKE.gnu"; # nnmake binary (cvs respository 'nnmake')
+-my $TRIMLOOPS = "$src_dir/nnmake/trimLoopLibrary.pl"; # trimLoopLibrary.pl (cvs respository 'nnmake')
++my $NNMAKE = "$src_dir/usr/bin/pNNMAKE"; # nnmake binary (cvs respository 'nnmake')
++my $TRIMLOOPS = "$src_dir/usr/bin/trimLoopLibrary.pl"; # trimLoopLibrary.pl (cvs respository 'nnmake')
+
+ # chemshift
+-my $CHEMSHIFT = "$src_dir/chemshift/pCHEMSHIFT.gnu"; # chemshift binary (cvs repository 'chemshift')
+-my $TALOS_DB = "$scratch/chemshift_database"; # TALOS databases directory (cvs respository 'chemshift_database')
++my $CHEMSHIFT = "$src_dir/usr/bin/pCHEMSHIFT"; # chemshift binary (cvs repository 'chemshift')
++my $TALOS_DB = "$shareware_dir/rosetta-fragments/chemshift_database"; # TALOS databases directory (cvs respository 'chemshift_database')
+
+ # jufo (secondary structure prediction software)
+ my $JUFO = "$shareware_dir/jufo/molecule.exe"; # jufo executable
+diff --git a/nnmake/makefile b/nnmake/makefile
+index c09ac1c..ebfde68 100644
+--- a/nnmake/makefile
++++ b/nnmake/makefile
+@@ -102,7 +102,7 @@ VallCoord: coord_compile
+ # rule to compile executable
+ compile: print $(BASE_NAME).$(COMPILER)
+ $(BASE_NAME).$(COMPILER) : ${OBJS}
+- $(F77) $(FFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
++ $(F77) $(FFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
+
+ coord_compile: print $(COORD_BASE_NAME).$(COMPILER)
+ $(COORD_BASE_NAME).$(COMPILER) : ${COORD_OBJS}
diff --git a/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
new file mode 100644
index 000000000000..d98deb515595
--- /dev/null
+++ b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild,v 1.1 2013/04/25 08:37:45 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic prefix toolchain-funcs
+
+DESCRIPTION="Fragment library for rosetta"
+HOMEPAGE="http://www.rosettacommons.org"
+SRC_URI="rosetta3.1_fragments.tgz"
+
+LICENSE="rosetta"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ sci-biology/ncbi-tools
+ sci-biology/ncbi-tools++
+ sci-biology/psipred"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"/${PN/-/_}
+
+pkg_nofetch() {
+ einfo "Go to ${HOMEPAGE} and get ${PN}.tgz and rename it to ${A}"
+ einfo "which must be placed in ${DISTDIR}"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-nnmake.patch \
+ "${FILESDIR}"/${P}-chemshift.patch
+ tc-export F77
+ eprefixify nnmake/*.pl
+}
+
+src_compile() {
+ emake -C nnmake
+ emake -C chemshift
+}
+
+src_install() {
+ esvn_clean .
+
+ newbin nnmake/pNNMAKE.gnu pNNMAKE
+ newbin chemshift/pCHEMSHIFT.gnu pCHEMSHIFT
+
+ dobin nnmake/*.pl
+
+ insinto /usr/share/${PN}
+ doins -r *_database
+ dodoc fragments.README nnmake/{nnmake.README,vall/*.pl} chemshift/chemshift.README
+}
diff --git a/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild b/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild
index 3c2b44458adc..361dc70a481e 100644
--- a/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild
+++ b/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild,v 1.5 2013/04/24 12:12:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/rosetta-fragments/rosetta-fragments-3.1.ebuild,v 1.6 2013/04/25 08:37:45 jlec Exp $
EAPI="2"
-inherit flag-o-matic toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Fragment library for rosetta"
HOMEPAGE="http://www.rosettacommons.org"