summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-04 17:01:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-04 17:01:54 +0000
commit49ae72316a48a13b91d62adf4e3ed9ed98a42f20 (patch)
tree2ca76303a2e85473dabffbc851603be8805a2a8c /sci-libs/netcdf
parentVersion bump. Install systemd unit file wrt #375269 by Michał Górny. Remove... (diff)
downloadgentoo-2-49ae72316a48a13b91d62adf4e3ed9ed98a42f20.tar.gz
gentoo-2-49ae72316a48a13b91d62adf4e3ed9ed98a42f20.tar.bz2
gentoo-2-49ae72316a48a13b91d62adf4e3ed9ed98a42f20.zip
Version bump. Might need more testing for fortran
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog7
-rw-r--r--sci-libs/netcdf/netcdf-4.1.3.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 322a42692102..97724968e977 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.92 2011/06/21 15:08:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.93 2011/08/04 17:01:52 bicatali Exp $
+
+*netcdf-4.1.3 (04 Aug 2011)
+
+ 04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +netcdf-4.1.3.ebuild:
+ Version bump. Might need more testing for fortran
21 Jun 2011; Justin Lecher <jlec@gentoo.org> netcdf-3.6.3.ebuild,
netcdf-4.1.1-r4.ebuild:
diff --git a/sci-libs/netcdf/netcdf-4.1.3.ebuild b/sci-libs/netcdf/netcdf-4.1.3.ebuild
new file mode 100644
index 000000000000..b50e18bdd85f
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.1.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.3.ebuild,v 1.1 2011/08/04 17:01:54 bicatali Exp $
+
+EAPI=4
+
+inherit autotools autotools-utils fortran-2
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="cxx dap doc fortran hdf5 static-libs"
+
+RDEPEND="fortran? ( virtual/fortran )
+ dap? ( net-misc/curl )
+ hdf5? ( >=sci-libs/hdf5-1.8.6[zlib,szip,fortran?] )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ doc? ( virtual/latex-base )
+ fortran? ( dev-lang/cfortran )"
+
+DOCS=(README RELEASE_NOTES)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.1-parallel-build.patch
+ "${FILESDIR}"/${PN}-4.1.1-fortran.patch
+)
+
+pkg_setup() {
+ if use fortran; then
+ FORTRAN_STANDARD="77 90"
+ fortran-2_pkg_setup
+ fi
+ if use hdf5 && has_version sci-libs/hdf5[mpi]; then
+ export CC=mpicc
+ use cxx && export CXX=mpicxx
+ use fortran && export FC=mpif90 F77=mpif77
+ fi
+}
+
+src_prepare() {
+ # use system cfortran
+ rm -f fortran/cfortran.h || die
+ # check for szip is libsz, not libszip
+ sed -i -e 's/\[szip\]/\[sz\]/' configure.ac || die
+ # we don't build udunits and libcf
+ sed -i -e '/udunits libcf/d' configure.ac || die
+ if ! use doc; then
+ sed -i -e "/\$(NC_TEST4)/ s/man4//" Makefile.am || die
+ fi
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dap)
+ $(use_enable static-libs static)
+ $(use_enable fortran f77)
+ $(use_enable fortran f90)
+ $(use_enable cxx)
+ $(use_enable hdf5 netcdf-4)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ # hack to allow parallel build
+ if use doc; then
+ autotools-utils_src_compile pdf
+ autotools-utils_src_compile -j1 -C man4
+ fi
+ autotools-utils_src_compile
+}