summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-13 18:27:01 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-13 18:27:01 +0000
commitf47f1c28ae10d10b2eb9621773ecf7cbbf5ea668 (patch)
tree409831d6d7d9033db949bb01d7fc5cf37f6139ac /sci-libs/libint
parentAdd ~alpha/~arm/~s390/~sh wrt #297581 (diff)
downloadgentoo-2-f47f1c28ae10d10b2eb9621773ecf7cbbf5ea668.tar.gz
gentoo-2-f47f1c28ae10d10b2eb9621773ecf7cbbf5ea668.tar.bz2
gentoo-2-f47f1c28ae10d10b2eb9621773ecf7cbbf5ea668.zip
Fix for as-needed per bug 289232
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libint')
-rw-r--r--sci-libs/libint/ChangeLog11
-rw-r--r--sci-libs/libint/files/1.1.4-as-needed.patch39
-rw-r--r--sci-libs/libint/libint-1.1.4-r1.ebuild41
-rw-r--r--sci-libs/libint/libint-1.1.4.ebuild12
4 files changed, 95 insertions, 8 deletions
diff --git a/sci-libs/libint/ChangeLog b/sci-libs/libint/ChangeLog
index e930876f282f..db3053537761 100644
--- a/sci-libs/libint/ChangeLog
+++ b/sci-libs/libint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libint
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.6 2008/07/07 06:38:17 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.7 2010/02/13 18:27:00 jlec Exp $
+
+*libint-1.1.4-r1 (13 Feb 2010)
+
+ 13 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/1.1.4-as-needed.patch, libint-1.1.4.ebuild,
+ +libint-1.1.4-r1.ebuild:
+ Fix for as-needed per 289232
*libint-1.1.4 (07 Jul 2008)
diff --git a/sci-libs/libint/files/1.1.4-as-needed.patch b/sci-libs/libint/files/1.1.4-as-needed.patch
new file mode 100644
index 000000000000..cc87d760b699
--- /dev/null
+++ b/sci-libs/libint/files/1.1.4-as-needed.patch
@@ -0,0 +1,39 @@
+diff --git a/src/lib/libderiv/Makefile.library b/src/lib/libderiv/Makefile.library
+index ee152ef..8debfe8 100644
+--- a/src/lib/libderiv/Makefile.library
++++ b/src/lib/libderiv/Makefile.library
+@@ -23,7 +23,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libint/Makefile.library b/src/lib/libint/Makefile.library
+index 23e2918..01c4225 100644
+--- a/src/lib/libint/Makefile.library
++++ b/src/lib/libint/Makefile.library
+@@ -41,7 +41,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libr12/Makefile.library b/src/lib/libr12/Makefile.library
+index 1510807..26d47a4 100644
+--- a/src/lib/libr12/Makefile.library
++++ b/src/lib/libr12/Makefile.library
+@@ -47,7 +47,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
diff --git a/sci-libs/libint/libint-1.1.4-r1.ebuild b/sci-libs/libint/libint-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..4609b17bad9c
--- /dev/null
+++ b/sci-libs/libint/libint-1.1.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4-r1.ebuild,v 1.1 2010/02/13 18:27:00 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Used to evaluate traditional and novel two-body matrix elements (integrals) over Cartesian Gaussian functions"
+HOMEPAGE="http://www.chem.vt.edu/chem-dept/valeev/software/libint/libint.html"
+SRC_URI="http://www.chem.vt.edu/chem-dept/valeev/software/libint/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.1.4-as-needed.patch
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-deriv \
+ --enable-r12 \
+ --with-cc=$(tc-getCC) \
+ --with-cxx=$(tc-getCXX) \
+ --with-cc-optflags="${CFLAGS}" \
+ --with-cxx-optflags="${CXXFLAGS}"
+}
+
+src_compile() {
+ emake \
+ LDFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ einstall || die
+}
diff --git a/sci-libs/libint/libint-1.1.4.ebuild b/sci-libs/libint/libint-1.1.4.ebuild
index e438d7b0076b..fc5de514196c 100644
--- a/sci-libs/libint/libint-1.1.4.ebuild
+++ b/sci-libs/libint/libint-1.1.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4.ebuild,v 1.1 2008/07/07 06:38:17 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4.ebuild,v 1.2 2010/02/13 18:27:00 jlec Exp $
+
+EAPI="3"
inherit toolchain-funcs
@@ -14,7 +16,7 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-src_compile() {
+src_configure() {
econf \
--enable-shared \
--enable-deriv \
@@ -22,9 +24,7 @@ src_compile() {
--with-cc=$(tc-getCC) \
--with-cxx=$(tc-getCXX) \
--with-cc-optflags="${CFLAGS}" \
- --with-cxx-optflags="${CXXFLAGS}" \
- || die "econf failed"
- emake || die "emake failed"
+ --with-cxx-optflags="${CXXFLAGS}"
}
src_install() {