summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-06-02 13:15:44 +0000
committerRick Farina <zerochaos@gentoo.org>2014-06-02 13:15:44 +0000
commitc079d01853af79ac5144fe6e6c10d146d3b2af12 (patch)
tree9db13b083ca2166b292c97810324c0bee78e436f /sci-libs/itpp
parentVersion bump. (diff)
downloadgentoo-2-c079d01853af79ac5144fe6e6c10d146d3b2af12.tar.gz
gentoo-2-c079d01853af79ac5144fe6e6c10d146d3b2af12.tar.bz2
gentoo-2-c079d01853af79ac5144fe6e6c10d146d3b2af12.zip
fixing multilib-strict failure, acked by xarthisius
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog7
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 5ff61f1ca270..c4bb6dd5acc0 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.119 2014/01/15 06:01:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.120 2014/06/02 13:15:44 zerochaos Exp $
+
+*itpp-4.3.1-r1 (02 Jun 2014)
+
+ 02 Jun 2014; Rick Farina <zerochaos@gentoo.org> +itpp-4.3.1-r1.ebuild:
+ fixing multilib-strict failure, acked by xarthisius
*itpp-4.3.1 (15 Jan 2014)
diff --git a/sci-libs/itpp/itpp-4.3.1-r1.ebuild b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..a3f25c70dbe5
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.3.1-r1.ebuild,v 1.1 2014/06/02 13:15:44 zerochaos Exp $
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ >=sci-libs/fftw-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+DOCS=(ChangeLog NEWS AUTHORS README)
+
+src_prepare() {
+ # gentoo redefines the CMAKE_BUILD_TYPE
+ sed -i \
+ -e 's/CMAKE_BUILD_TYPE STREQUAL Release/NOT CMAKE_BUILD_TYPE STREQUAL Debug/' \
+ CMakeLists.txt || die
+ # respect gentoo doc dir
+ sed -i \
+ -e "s:share/doc/itpp:share/doc/${PF}:" \
+ itpp/CMakeLists.txt || die
+
+ # respect gentoo libdir
+ sed -i "s#/lib#/$(get_libdir)#" itpp-config.cmake.in
+ sed -i "s#/lib#/$(get_libdir)#" itpp.pc.cmake.in
+ sed -i \
+ -e "s#LIBRARY DESTINATION lib#LIBRARY DESTINATION $(get_libdir)#" \
+ -e "s#ARCHIVE DESTINATION lib#ARCHIVE DESTINATION $(get_libdir)#" \
+ itpp/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLA_VENDOR=Generic
+ $(cmake-utils_use doc HTML_DOCS)
+ )
+ cmake-utils_src_configure
+}