summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 14:09:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 14:09:09 +0000
commit97c1ab4a2059eb023a1320d5337160e5aa9b4f93 (patch)
tree12b6015a11244bbe073d7ed965f884a410a7cf0d /sci-libs/acml
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-97c1ab4a2059eb023a1320d5337160e5aa9b4f93.tar.gz
gentoo-2-97c1ab4a2059eb023a1320d5337160e5aa9b4f93.tar.bz2
gentoo-2-97c1ab4a2059eb023a1320d5337160e5aa9b4f93.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/acml')
-rw-r--r--sci-libs/acml/ChangeLog8
-rw-r--r--sci-libs/acml/acml-3.6.0-r1.ebuild11
-rw-r--r--sci-libs/acml/acml-3.6.1-r1.ebuild17
-rw-r--r--sci-libs/acml/acml-4.0.1.ebuild20
-rw-r--r--sci-libs/acml/acml-4.1.0-r1.ebuild11
5 files changed, 33 insertions, 34 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index f1325d2b518e..6e3523258cfb 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/acml
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.40 2009/07/07 23:27:59 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.41 2010/12/16 14:09:09 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> acml-3.6.0-r1.ebuild,
+ acml-3.6.1-r1.ebuild, acml-4.0.1.ebuild, acml-4.1.0-r1.ebuild:
+ Removal of fortran.eclass, #348851
07 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> ChangeLog:
Use elog for fetch error.
diff --git a/sci-libs/acml/acml-3.6.0-r1.ebuild b/sci-libs/acml/acml-3.6.0-r1.ebuild
index 48fdb665bf16..a59848c33736 100644
--- a/sci-libs/acml/acml-3.6.0-r1.ebuild
+++ b/sci-libs/acml/acml-3.6.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.9 2008/04/22 08:13:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.10 2010/12/16 14:09:09 jlec Exp $
-inherit eutils toolchain-funcs fortran
+inherit eutils toolchain-funcs
DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
HOMEPAGE="http://developer.amd.com/acml.jsp"
@@ -51,7 +51,6 @@ pkg_setup() {
FORTRAN=ifc
FORT=ifort
! use ifc && ! use openmp && FORTRAN=g77 && FORT=gnu
- fortran_pkg_setup
}
src_unpack() {
@@ -69,7 +68,7 @@ src_test() {
cd "${S}"/${fort}/examples/${d}
emake \
ACMLDIR="${S}"/${fort} \
- F77=${FORTRANC} \
+ F77=$(tc-getFC) \
CC="$(tc-getCC)" \
CPLUSPLUS="$(tc-getCXX)" \
|| die "emake test in ${fort}/examples/${d} failed"
@@ -89,7 +88,7 @@ src_install() {
cp -pPR "${S}/${fort}" "${D}"${instdir} || die "copy ${fort} failed"
# install profiles
- ESELECT_PROF=acml-${FORTRANC}
+ ESELECT_PROF=acml-$(tc-getFC)
local acmldir=${instdir}/${fort}
local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
diff --git a/sci-libs/acml/acml-3.6.1-r1.ebuild b/sci-libs/acml/acml-3.6.1-r1.ebuild
index 1f37ba11b54b..2d98972e9043 100644
--- a/sci-libs/acml/acml-3.6.1-r1.ebuild
+++ b/sci-libs/acml/acml-3.6.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.1-r1.ebuild,v 1.9 2008/04/22 08:13:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.1-r1.ebuild,v 1.10 2010/12/16 14:09:09 jlec Exp $
-inherit eutils toolchain-funcs fortran
+inherit eutils toolchain-funcs
DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
HOMEPAGE="http://developer.amd.com/acml.jsp"
@@ -40,8 +40,7 @@ pkg_setup() {
elog "For older 32-bit without SSE/SSE2, use other blas/lapack libraries,"
elog "or file a bug if you wish to have earlier ACML versions supported."
FORTRAN="gfortran"
- fortran_pkg_setup
- if [[ ${FORTRANC} == gfortran ]]; then
+ if [[ $(tc-getFC) == gfortran ]]; then
local gcc_version=$(gcc-major-version)$(gcc-minor-version)
if ! use openmp && (( ${gcc_version} != 41 )); then
eerror "You need gcc-4.1.x to test acml."
@@ -58,10 +57,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
(DISTDIR="${S}" unpack contents-acml-*.tgz)
- case ${FORTRANC} in
+ case $(tc-getFC) in
gfortran) FORT=gfortran ;;
if*) FORT=ifort ;;
- *) eerror "Unsupported fortran compiler: ${FORTRANC}"
+ *) eerror "Unsupported fortran compiler: $(tc-getFC)"
die ;;
esac
use openmp || rm -rf ${FORT}*_mp*
@@ -79,7 +78,7 @@ src_test() {
cd "${S}"/${fort}/examples/${d}
emake \
ACMLDIR="${S}"/${fort} \
- F77=${FORTRANC} \
+ F77=$(tc-getFC) \
CC="$(tc-getCC)" \
CPLUSPLUS="$(tc-getCXX)" \
|| die "emake test in ${fort}/examples/${d} failed"
@@ -99,7 +98,7 @@ src_install() {
cp -pPR "${S}/${fort}" "${D}"${instdir} || die "copy ${fort} failed"
# install profiles
- ESELECT_PROF=acml-${FORTRANC}
+ ESELECT_PROF=acml-$(tc-getFC)
local acmldir=${instdir}/${fort}
local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
diff --git a/sci-libs/acml/acml-4.0.1.ebuild b/sci-libs/acml/acml-4.0.1.ebuild
index a749f62737c4..567c6eda5bfb 100644
--- a/sci-libs/acml/acml-4.0.1.ebuild
+++ b/sci-libs/acml/acml-4.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.5 2008/04/22 08:13:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.6 2010/12/16 14:09:09 jlec Exp $
-inherit eutils toolchain-funcs fortran
+inherit eutils toolchain-funcs
MY_PV=${PV//\./\-}
@@ -40,15 +40,13 @@ pkg_nofetch() {
pkg_setup() {
FORTRAN="gfortran"
- use ifc && FORTRAN="ifc"
- fortran_pkg_setup
- if [[ ${FORTRANC} == gfortran ]]; then
+ if [[ $(tc-getFC) == gfortran ]]; then
local gcc_version=$(gcc-major-version)$(gcc-minor-version)
if ! use openmp && (( ${gcc_version} != 41 )); then
eerror "You need gcc-4.1.x to test acml."
eerror "Please use gcc-config to swicth gcc version 4.1.x"
die "setup gcc failed"
- elif use openmp && (( ${gcc_version} != 42 )); then
+ elif use openmp && ! tc-has-openmp; then
eerror "You need gfortran >= 4.2 to use openmp features."
eerror "Please use gcc-config to switch gcc version >= 4.2"
die "setup gcc failed"
@@ -59,10 +57,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
(DISTDIR="${S}" unpack contents-acml-*.tgz)
- case ${FORTRANC} in
+ case $(tc-getFC) in
gfortran) FORT=gfortran ;;
if*) FORT=ifort ;;
- *) eerror "Unsupported fortran compiler: ${FORTRANC}"
+ *) eerror "Unsupported fortran compiler: $(tc-getFC)"
die "failed configuring fortran";;
esac
use openmp || rm -rf ${FORT}*_mp*
@@ -80,7 +78,7 @@ src_test() {
cd "${S}"/${fort}/examples/${d}
emake \
ACMLDIR="${S}"/${fort} \
- F77=${FORTRANC} \
+ F77=$(tc-getFC) \
CC="$(tc-getCC)" \
CPLUSPLUS="$(tc-getCXX)" \
|| die "emake test in ${fort}/examples/${d} failed"
@@ -100,7 +98,7 @@ src_install() {
cp -pPR "${S}"/${fort} "${D}"${instdir} || die "copy ${fort} failed"
# install profiles
- ESELECT_PROF=acml-${FORTRANC}
+ ESELECT_PROF=acml-$(tc-getFC)
local acmldir=${instdir}/${fort}
local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
diff --git a/sci-libs/acml/acml-4.1.0-r1.ebuild b/sci-libs/acml/acml-4.1.0-r1.ebuild
index 863c79958718..a31b0cc57915 100644
--- a/sci-libs/acml/acml-4.1.0-r1.ebuild
+++ b/sci-libs/acml/acml-4.1.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.1.0-r1.ebuild,v 1.4 2008/12/07 18:28:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.1.0-r1.ebuild,v 1.5 2010/12/16 14:09:09 jlec Exp $
EAPI="1"
-inherit eutils toolchain-funcs fortran versionator
+inherit eutils toolchain-funcs versionator
MY_P=${PN}-$(replace_all_version_separators -)
@@ -60,10 +60,9 @@ pkg_setup() {
use gfortran && FORTRAN="${FORTRAN} gfortran"
use ifc && FORTRAN="${FORTRAN} ifc"
use gfortran || use ifc || FORTRAN="gfortran"
- fortran_pkg_setup
# work around incomplete fortran eclass
if use gfortran &&
- [[ ${FORTRANC} == gfortran ]] &&
+ [[ $(tc-getFC) == gfortran ]] &&
[[ $(gcc-version) != 4.2 ]]
then
eerror "You need gfortran-4.2 to test acml"
@@ -94,7 +93,7 @@ src_test() {
cd "${S}"/${fdir}/examples/${d}
emake \
ACMLDIR="${S}"/${fdir} \
- F77=${FORTRANC} \
+ F77=$(tc-getFC) \
CC="$(tc-getCC)" \
CPLUSPLUS="$(tc-getCXX)" \
|| die "emake test in ${fdir}/examples/${d} failed"