summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-26 15:27:44 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-26 15:27:44 +0000
commit654b4966e2b5c42fb11e52796a8e02ee7b8b01f1 (patch)
treea002faad6f0e18cd2262ec59ef6a5de573d7a4b8 /sci-geosciences/grass
parentFix building with sys-devel/gcc >= 4.6 wrt #357305 by Ryan Hill. (diff)
downloadgentoo-2-654b4966e2b5c42fb11e52796a8e02ee7b8b01f1.tar.gz
gentoo-2-654b4966e2b5c42fb11e52796a8e02ee7b8b01f1.tar.bz2
gentoo-2-654b4966e2b5c42fb11e52796a8e02ee7b8b01f1.zip
Depend on virtual/ffmpeg instead of media-video/ffmpeg. Cleanup the deprecated if has_version for old ffmpeg.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog7
-rw-r--r--sci-geosciences/grass/grass-6.3.0.ebuild12
-rw-r--r--sci-geosciences/grass/grass-6.4.0.ebuild4
3 files changed, 11 insertions, 12 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 713ab159df74..64cf71b0bffa 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.96 2011/03/24 20:54:40 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.97 2011/03/26 15:27:44 scarabeus Exp $
+
+ 26 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> grass-6.3.0.ebuild,
+ grass-6.4.0.ebuild:
+ Depend on virtual/ffmpeg instead of media-video/ffmpeg. Cleanup the
+ deprecated if has_version for old ffmpeg.
24 Mar 2011; Ryan Hill <dirtyepic@gentoo.org> grass-6.4.0.ebuild:
eselect wxwidgets affects build behaviour, not runtime, and only outside of
diff --git a/sci-geosciences/grass/grass-6.3.0.ebuild b/sci-geosciences/grass/grass-6.3.0.ebuild
index 8c34e9d156c1..deb0f1f027fc 100644
--- a/sci-geosciences/grass/grass-6.3.0.ebuild
+++ b/sci-geosciences/grass/grass-6.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.21 2011/03/10 19:14:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.22 2011/03/26 15:27:44 scarabeus Exp $
EAPI=1
@@ -31,7 +31,7 @@ RDEPEND=">=sys-libs/zlib-1.1.4
sys-apps/man-db )
sci-libs/gdal
>=sci-libs/proj-4.4.7
- ffmpeg? ( media-video/ffmpeg )
+ ffmpeg? ( virtual/ffmpeg )
fftw? ( sci-libs/fftw )
gmath? ( virtual/blas
virtual/lapack )
@@ -178,13 +178,7 @@ src_compile() {
if use ffmpeg; then
myconf="${myconf} --with-ffmpeg \
--with-ffmpeg-libs=/usr/$(get_libdir)"
- if has_version ">=media-video/ffmpeg-0.4.9_p20080326" ; then
- # must pass multiple include dirs now; if you have a better
- # way to do this, please speak up and file a bug :)
- myconf="${myconf} --with-ffmpeg-includes=/usr/include/libav*"
- else
- myconf="${myconf} --with-ffmpeg-includes=/usr/include/ffmpeg"
- fi
+ myconf="${myconf} --with-ffmpeg-includes=/usr/include/libav*"
else
myconf="${myconf} --without-ffmpeg"
fi
diff --git a/sci-geosciences/grass/grass-6.4.0.ebuild b/sci-geosciences/grass/grass-6.4.0.ebuild
index b7d3b834e660..b7e4d76a1a72 100644
--- a/sci-geosciences/grass/grass-6.4.0.ebuild
+++ b/sci-geosciences/grass/grass-6.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0.ebuild,v 1.7 2011/03/24 20:54:40 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0.ebuild,v 1.8 2011/03/26 15:27:44 scarabeus Exp $
EAPI="3"
@@ -33,7 +33,7 @@ RDEPEND="
sys-libs/ncurses
sys-libs/zlib
cairo? ( x11-libs/cairo[X?,opengl?] )
- ffmpeg? ( media-video/ffmpeg )
+ ffmpeg? ( virtual/ffmpeg )
fftw? ( sci-libs/fftw:3.0 )
gmath? (
virtual/blas