summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-06-06 17:07:53 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-06-06 17:07:53 +0000
commit64dfdecd3234c1f32e4001bcd35af1cf625639c2 (patch)
tree866025cb519c9bec5a086a696e1ebcd16b433895 /sci-electronics/ghdl
parentold (diff)
downloadgentoo-2-64dfdecd3234c1f32e4001bcd35af1cf625639c2.tar.gz
gentoo-2-64dfdecd3234c1f32e4001bcd35af1cf625639c2.tar.bz2
gentoo-2-64dfdecd3234c1f32e4001bcd35af1cf625639c2.zip
Vesion bump, bug #233109.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-electronics/ghdl')
-rw-r--r--sci-electronics/ghdl/ChangeLog7
-rw-r--r--sci-electronics/ghdl/ghdl-0.27.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-electronics/ghdl/ChangeLog b/sci-electronics/ghdl/ChangeLog
index 7d53a6800057..4479d7298363 100644
--- a/sci-electronics/ghdl/ChangeLog
+++ b/sci-electronics/ghdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/ghdl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.6 2009/05/29 16:14:59 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.7 2009/06/06 17:07:53 calchan Exp $
+
+*ghdl-0.27 (06 Jun 2009)
+
+ 06 Jun 2009; Denis Dupeyron <calchan@gentoo.org> +ghdl-0.27.ebuild:
+ Vesion bump, bug #233109.
29 May 2009; Denis Dupeyron <calchan@gentoo.org> ghdl-0.26.ebuild:
Locked dependency on >=dev-lang/gnat-gcc-4.2 instead of virtual/gnat,
diff --git a/sci-electronics/ghdl/ghdl-0.27.ebuild b/sci-electronics/ghdl/ghdl-0.27.ebuild
new file mode 100644
index 000000000000..060d4994b7c7
--- /dev/null
+++ b/sci-electronics/ghdl/ghdl-0.27.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.27.ebuild,v 1.1 2009/06/06 17:07:53 calchan Exp $
+
+EAPI="2"
+
+inherit multilib
+
+GCC_VERSION="4.2.4"
+
+DESCRIPTION="Complete VHDL simulator using the GCC technology"
+HOMEPAGE="http://ghdl.free.fr"
+SRC_URI="http://ghdl.free.fr/${P}.tar.bz2
+ mirror://gnu/gcc/releases/gcc-${GCC_VERSION}/gcc-core-${GCC_VERSION}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=sys-apps/portage-2.1.2.10
+ >=dev-lang/gnat-gcc-4.2"
+RDEPEND=""
+S="${WORKDIR}/gcc-${GCC_VERSION}"
+
+src_prepare() {
+ mv "${WORKDIR}/${P}"/vhdl gcc
+ sed -i -e 's/ADAC = \$(CC)/ADAC = gnatgcc/' gcc/vhdl/Makefile.in || die "sed failed"
+ sed -i -e 's/AGCC_CFLAGS=-g/AGCC_CFLAGS=$(CFLAGS)/' gcc/vhdl/Make-lang.in || die "sed failed"
+
+ # Fix issue similar to bug #195074, ported from vapier's fix for binutils
+ sed -i -e "s:egrep.*texinfo.*dev/null:egrep 'texinfo[^0-9]*(4\.([4-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null:" \
+ configure* || die "sed failed"
+
+ # For multilib profile arch, see bug #203721
+ if (has_multilib_profile || use multilib ) ; then
+ for T_LINUX64 in `find "${S}/gcc/config" -name t-linux64` ;
+ do
+ einfo "sed for ${T_LINUX64} for multilib. :)"
+ sed -i \
+ -e "s:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:" \
+ "${T_LINUX64}" \
+ || die "sed for ${T_LINUX64} failed. :("
+ done
+ fi
+}
+
+src_configure() {
+ econf --enable-languages=vhdl
+}
+
+src_compile() {
+ emake -j1 || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ cd "${D}"/usr/bin ; rm `ls --ignore=ghdl`
+ rm -rf "${D}"/usr/include
+ rm "${D}"/usr/$(get_libdir)/lib*
+ cd "${D}"/usr/$(get_libdir)/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=vhdl*`
+ cd "${D}"/usr/libexec/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=ghdl*`
+ cd "${D}"/usr/share/info ; rm `ls --ignore=ghdl*`
+ cd "${D}"/usr/share/man/man1 ; rm `ls --ignore=ghdl*`
+ rm -Rf "${D}"/usr/share/locale
+ rm -Rf "${D}"/usr/share/man/man7
+}